aMule Forum

English => Translations (i18n) => Topic started by: raditzman on April 15, 2008, 04:02:00 AM

Title: Completed PT_PT translation
Post by: raditzman on April 15, 2008, 04:02:00 AM
 ;D
Here is the completed translation for portuguese from Portugal.

Here it goes...

Title: Re: Completed PT_PT translation
Post by: wuischke on April 15, 2008, 09:44:47 PM
I've updated the translation, muito obrigado.
Title: Re: Completed PT_PT translation
Post by: Pitxyoki on July 03, 2008, 05:13:49 PM
Why isn't the file at http://www.amule.org/translations/pt_PT.po the same that was uploaded by raditzman? Some strings seem to be missing there...
Title: Re: Completed PT_PT translation
Post by: wuischke on July 03, 2008, 05:45:32 PM
Things change as time goes by. We add new strings, remove old ones, modify existing ones.
Title: Re: Completed PT_PT translation
Post by: Pitxyoki on July 03, 2008, 05:56:16 PM
What I mean is that there are strings that were translated on the file submitted by raditzman that are not included on the http://www.amule.org/translations/pt_PT.po file.

An example:

Code: [Select]
$ diff pt_PT-submitted-by-raditzman.po pt_PT-on-amule-org.po
(...)
37,38c37,38
< msgid "EC Connection Failed. Empty reply."
< msgstr "Falha de Conex√£o EC. Resposta vazia."
---
> msgid "EC connection failed. Empty reply."
> msgstr ""
(...)

...among other places where this happens.


EDIT: I just noticed that happened because of a capital letter at "Connection"... And on other places, the situation is identical: little changes on the original text make the translation disappear.  :-\ Well, maybe soon I will try and update this translation. :)
Title: Re: Completed PT_PT translation
Post by: wuischke on July 03, 2008, 06:01:51 PM
This is a problem with gettext. See the capitalization of connection? That's the only change made, but it is considered to be a completely different string. I'm not happy about this and try to avoid it now, if possible.