aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Amule e conflitti con le librerie  (Read 3868 times)

PxPert

  • Italian forum helper
  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 91
Amule e conflitti con le librerie
« on: May 16, 2006, 08:36:55 PM »

Ho da poco aggiornato tutti i programmi del mio server ricompilandoli/aggiornandoli usando gcc 4.1
Tra questi ovviamente non poteva mancare amuled ;)
Il problema è che una volta rimesso l'hd nel serverone (non posso aggiornare tutto un sistema usando un pentium pro 200...) amuled mi dà sto errore:

localhost ~ # amuled
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.6 (no debug,Unicode,compiler with C++ ABI 102,wx containers,compatible with 2.4),
and your program used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4).
Aborted

Any ideas? Denghiu  :rolleyes:
Logged
Server ~ # amuled
amuled: OnInit - starting timer
This binary requires you to use the flag --only-chuck-norris-would-stop-me and only if you're very sure of it.

TROVATEMI UN'ALTRO PROGRAMMA COSI PIMPANTE COME AMULE E MI FACCIO PRETE  :D :D :D

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: Amule e conflitti con le librerie
« Reply #1 on: May 16, 2006, 09:11:36 PM »

Logged

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
Re: Amule e conflitti con le librerie
« Reply #2 on: May 17, 2006, 02:10:41 AM »

Ri-compila aMule, sono state aggiornate delle librerie dopo aver compilato aMule per cui ci sono dei riferimenti errati  ;)

Ciao by Truzzone  :)
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: Amule e conflitti con le librerie
« Reply #3 on: May 17, 2006, 02:25:30 AM »

He actually has to recompile wxWidgets, not aMule (or maybe both) because aMule is already compiled with GCC 4.1, but wxWidgets is not, according to the error message.

Sorry, non posso scrivere in italiano... ;(
Logged

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
Re: Amule e conflitti con le librerie
« Reply #4 on: May 17, 2006, 11:55:12 AM »

Sorry for my error Gerd78  :))
Devi ricompilare le librerie wx poichè hai compilato aMule con un compilatore diverso  ;)

Ciao by Truzzone  :)
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

PxPert

  • Italian forum helper
  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 91
Re: Amule e conflitti con le librerie
« Reply #5 on: May 28, 2006, 11:10:45 PM »

Infatti ho ricompilato amule si e no 3-4 volte, però sempre con lo stesso problema... Ora ricompilo le wxWidgets e metto amule 2.1.2. Thanks to truzzone & Gerd78 :)
Logged
Server ~ # amuled
amuled: OnInit - starting timer
This binary requires you to use the flag --only-chuck-norris-would-stop-me and only if you're very sure of it.

TROVATEMI UN'ALTRO PROGRAMMA COSI PIMPANTE COME AMULE E MI FACCIO PRETE  :D :D :D

PxPert

  • Italian forum helper
  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 91
Re: Amule e conflitti con le librerie
« Reply #6 on: June 13, 2006, 10:04:41 AM »

Ho ricompilato le librerie e gia che c'ero ho messo l'ultima versione dal fork cvs :)
Ora funge tutto, chuck norris permettendo :D
tnx to all!
Logged
Server ~ # amuled
amuled: OnInit - starting timer
This binary requires you to use the flag --only-chuck-norris-would-stop-me and only if you're very sure of it.

TROVATEMI UN'ALTRO PROGRAMMA COSI PIMPANTE COME AMULE E MI FACCIO PRETE  :D :D :D