aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2]

Author Topic: Umlaute verbessern  (Read 14493 times)

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Umlaute verbessern
« Reply #15 on: May 27, 2006, 09:57:56 PM »

ok amule version is ok, zumindest was den unicode support angeht...

aus deiner locale geht leider aber nicht hervor ob sie iso oder unicode codiert ist...

gib mal ein

locale -a

und poste mal was du so alles hast..
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: Umlaute verbessern
« Reply #16 on: May 27, 2006, 09:58:33 PM »

Ja, die Ausgabe von "locale" klärt es auf: Dein System ist nich auf Unicode eingestellt. Statt "de_DE" müsste da "de_DE.UTF-8" stehen.

Ich hab grad kein Mandriva-System da, aber das lässt sich bestimmt in /etc/sysconfig umstellen. Alternativ kannst Du die Änderung auch nur für aMule machen, indem Du vor dem Start von aMule die Umgebungsvariable setzt:
Code: [Select]
export LC_ALL=de_DE.UTF-8
amule
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Umlaute verbessern
« Reply #17 on: May 27, 2006, 10:01:31 PM »

^^

dazu sollte er mit

locale -a

aber erstemal gucken ob die überhaupt vorhanden ist..  :]
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

mrgreen

  • Guest
Re: Umlaute verbessern
« Reply #18 on: May 27, 2006, 10:04:45 PM »

Quote
gib mal ein

locale -a

und poste mal was du so alles hast..


[mrgreen2@localhost ~]$ locale -a
C
CP1251
de
de_AT
de_AT.ISO-8859-1
de_AT.ISO-8859-15
de_AT.UTF-8
de_BE
de_BE.ISO-8859-1
de_BE.ISO-8859-15
de_BE.UTF-8
de_CH
de_CH.ISO-8859-1
de_CH.ISO-8859-15
de_CH.UTF-8
de_DE
de_DE.ISO-8859-1
de_DE.ISO-8859-15
de_DE.UTF-8
de_LU
de_LU.ISO-8859-1
de_LU.ISO-8859-15
de_LU.UTF-8
deutsch
german
ISO-8859-1
ISO-8859-10
ISO-8859-13
ISO-8859-14
ISO-8859-15
ISO-8859-2
ISO-8859-3
ISO-8859-4
ISO-8859-5
ISO-8859-7
ISO-8859-9
KOI8-R
KOI8-U
POSIX
UTF-8
[mrgreen2@localhost ~]$

Quote
Bin mit meinen Einstellungen hier noch sehr im unklaren. Vielleicht sollte ich die erstmal screenen...? Confused

Was ist damit??

mrgreen
« Last Edit: May 27, 2006, 10:07:09 PM by mrgreen »
Logged

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: Umlaute verbessern
« Reply #19 on: May 27, 2006, 10:34:52 PM »

Quote
Originally posted by stefanero
dazu sollte er mit

locale -a

aber erstemal gucken ob die überhaupt vorhanden ist..  :]
Naja, die entsprechende UTF-8-locale einer installierten locale kann man meistens eigentlich voraussetzen... Im Zweifelsfall springen die Programme auf C zurück, wenn man eine nicht installierte locale auswählt, was zumindest nicht schlechter als die jetzige Situation ist.

Zum eigentlichen Problem: Hast Du eine Datei namens /etc/sysconfig/language? Oder /etc/sysconfig/i18n? Da kann man das normalerweise einstellen. Vielleicht hat Mandriva auch ein grafisches Konfigurationstool dafür => Wenn ja, benutze es.
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Umlaute verbessern
« Reply #20 on: May 27, 2006, 11:52:31 PM »

mach mla ne console auf und tipp was gerd78 gesagt hat

export LC_ALL=de_DE.UTF-8
amule

dann guckst ob alles tut mit den umlauten, wenn ja dann wie gerd78 wiederrum gesagt hat nach den dateien suchen und de_DE mit de_DE.UTF-8 ersetzen...

mit deiner letzten frage

Quote

Bin mit meinen Einstellungen hier noch sehr im unklaren. Vielleicht sollte ich die erstmal screenen...? Confused

kann ich nix anfangen
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

mrgreen

  • Guest
Re: Umlaute verbessern
« Reply #21 on: May 28, 2006, 12:15:50 AM »

Quote
mach mla ne console auf und tipp was gerd78 gesagt hat

export LC_ALL=de_DE.UTF-8
amule

mit den umlauten hat sich nix verändernt weiterhin so wie oben.

Quote
wie gerd78 wiederrum gesagt hat nach den dateien suchen und de_DE mit de_DE.UTF-8 ersetzen...
Quote
eine Datei namens /etc/sysconfig/language? Oder /etc/sysconfig/i18n?

jou hab ich, da steht das drin (i18n)

SYSFONTACM=iso15
LANGUAGE=de_DE:de
LC_ADDRESS=de_DE
LC_COLLATE=de_DE
LC_NAME=de_DE
LC_NUMERIC=de_DE
LC_MEASUREMENT=de_DE
LC_TIME=de_DE
LANG=de_DE
LC_IDENTIFICATION=de_DE
LC_MESSAGES=de_DE
LC_CTYPE=de_DE
LC_TELEPHONE=de_DE
LC_MONETARY=de_DE
LC_PAPER=de_DE
SYSFONT=lat0-16

Quote
und de_DE mit de_DE.UTF-8 ersetzen...

ich probiere das mal jetzt.

mrgreen
Logged

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: Umlaute verbessern
« Reply #22 on: May 28, 2006, 12:39:13 AM »

Quote
Originally posted by mrgreen
mit den umlauten hat sich nix verändernt weiterhin so wie oben.
Bist Du sicher? Hast Du die beiden Zeilen in derselben Shell ausgeführt? Das ist ganz wichtig, sonst bringt es nichts.

Beende noch mal alle irgendwo laufenden aMule-Prozesse und verwende dann diese Syntax:
Code: [Select]
env LC_ALL=de_DE.UTF-8 amuleUnd dann bitte in genau dem aMule-Fenster prüfen, das sich nach Ausführen dieses Befehls öffnet.
Logged

mrgreen

  • Guest
Re: Umlaute verbessern
« Reply #23 on: May 28, 2006, 01:51:16 AM »

SYSFONTACM=iso15
LANGUAGE=de_DE:de
LC_ADDRESS=de_DE.UTF-8
LC_COLLATE=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LANG=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_MESSAGES=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_PAPER=de_DE.UTF-8
SYSFONT=lat0-16

so sieht die i18n Datei jetzt aus. Dann habe ich das in die Konsole eingegeben...

env LC_ALL=de_DE.UTF-8 amule
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
HTTP download thread started
Host: amule.sourceforge.net:80
URL: http://amule.sourceforge.net/lastversion
Response: 200 (Error: 0)
Download size: 7
HTTP download thread end
Loading temp files from /home/mrgreen2/Emule Temp.
Loading PartFile 37 of 37
All PartFiles Loaded.
ListenSocket: Ok.

External connections disabled in config file
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
*** Client UDP socket (extended eMule) at 0.0.0.0:4672

Das Ergebnis bei der Suche.....

weiterhin unverändert!!!!!!!!!!!

Zum anderen Problem, gibt es irgendwo die Idealeinstellung für amule oder Standardeinstellungen für meine Leitung 2048/512?

mrgreen
« Last Edit: June 03, 2006, 03:07:13 AM by mrgreen »
Logged

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: Umlaute verbessern
« Reply #24 on: May 28, 2006, 02:14:43 AM »

OK, die locale-Umstellung bringt offensichtlich nichts. Dann mach die Änderung in /etc/sysconfig/i18n besser wieder rückgängig. Keine Ahnung, woran es liegt - wer weiß, was da noch alles kaputt ist, wenn selbst sowas nicht geht...
Logged

mrgreen

  • Guest
Re: Umlaute verbessern
« Reply #25 on: May 28, 2006, 02:28:07 AM »

ist egal, trotzdem danke. wie sieht es denn hiermit aus..?

http://www.amule.org/wiki/index.php/Usage_Preferences

kann man die ganzen einstellungen so übernehmen oder gibts da bessere?
« Last Edit: May 28, 2006, 02:28:38 AM by mrgreen »
Logged
Pages: 1 [2]