aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: quando la gui non si connette  (Read 14249 times)

lennynero

  • Newbie
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 29
quando la gui non si connette
« on: September 27, 2006, 02:20:16 AM »

raga non avevo mai postato nella sezione italian perché volevo sfoggiare il mio inglese(a volte dubbio:) ) nella sezione English, ma la richiesta che volevo fare è un pò strana e non so se l'ho spiegata bene lì quindi magari la ripropongo qui dove posso essere un pizzico + chiaro

premetto che uso la aMule su windows...e uso amulegui compilata da me sia per win che per linux(slackware rulez), solo che ho notato che quando inserisco dei parametri di accesso sbagliati(ip o porta o pass) mi viene rifiutato l'accesso ma il processo di amulegui rimane appeso, invece sarebbe + usabile se mostrasse un alert e mi riproponesse il prompt per reinserire i parametri...

in sostanza, in caso di parametri errati, in win amulegui.exe rimane in background a consumar ram e magari anche cpu, mentre in linux ho notato che lanciato da console rimane in esecuzione con il messaggio: "going to event loop"

grazie in anticipo per qualunque delucidazione a riguardo.
« Last Edit: September 27, 2006, 02:22:52 PM by lennynero »
Logged

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1239
RE: quando la gui non si connette
« Reply #1 on: September 27, 2006, 01:01:04 PM »

Non, so niente a riguardo, comunque se hai postato nel forum Inglese riceverai una risposta dagli sviluppatori  ;)

Ciao by Truzzone  :)
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

lennynero

  • Newbie
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 29
Re: quando la gui non si connette
« Reply #2 on: September 28, 2006, 06:30:57 PM »

visto che nessuno risponde ne qui ne in english ho deciso di mettere le mani nel codice...

per ora ho individuato e patchato i file amule-remote-gui.cpp e RemoteConnect.cpp in modo da controllare che siano presenti host porta e password e ripresentare il promp per reinserirli qualora mancassero(con un messaggio di avvertimento), solo che non sono in grado di capire dove la gui capisce di non avere le credenziali corrette...ho individuato un metodo Authenticate nel file ExternalConn.cpp ma non riesco da lì a restituire il controllo alla gui per lanciare il metodo che mostra il ConnectionDialog e il messaggio...

l'ideale prima di controllare che la pass sia corretta sarebbe controllare che host:port risponde.. ma il promblema è il medesimo della pass...

attendo fiducioso che qualcuno che ci capisce qualcosa + di me mi dia qualche dritta
Logged

blackfede

  • Jr. Member
  • **
  • Karma: 3
  • Offline Offline
  • Posts: 70
Re: quando la gui non si connette
« Reply #3 on: February 24, 2008, 04:23:25 PM »

@lennynero:
So che non centra nulla con quello che hai postato, ma volevo chiederti se per favore potresti compilarmi una versione cvs per windows della remotegui. Io uso amuled su linux, ma per lavoro devo stare su windows, solo che non ho la possibilità di installare sulla macchina tutto l'ambiente di compilazione. Che dici?
Logged
All troll are idiots and will go in /dev/null

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: quando la gui non si connette
« Reply #4 on: February 24, 2008, 08:54:05 PM »

Magari facendo un 'search' sul forum... oppure cercando nella sezione specifica:
aMule Forum > English > Distro-Specific Packages > Packages for development versions

Dai una occhiata qui:

http://forum.amule.org/index.php?topic=8895.0
oppure
http://forum.amule.org/index.php?topic=14392.0
Logged

blackfede

  • Jr. Member
  • **
  • Karma: 3
  • Offline Offline
  • Posts: 70
Re: quando la gui non si connette
« Reply #5 on: February 28, 2008, 12:01:21 PM »

Grazie mille per la segnalazione!
« Last Edit: February 28, 2008, 12:03:33 PM by blackfede »
Logged
All troll are idiots and will go in /dev/null