aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Daemon - problemy z polaczeniem do serwerow  (Read 5500 times)

Leonik

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Daemon - problemy z polaczeniem do serwerow
« on: January 05, 2007, 11:33:52 PM »

Witam,

Bardzo prosze o pomoc szanownych u|ytkowników tego forum. Mam aMule 2.1.3 pracujace jako daemon na Debianie w najnowszej wersji testing. Niestety mam kilka pytan i problemów, z którymi nie moge dac sobie rady:

1. Gdy daemon rozlaczy sie od serwera ed2k, to przez wiele godzin automatycznie próbuje nawiazac ponownie polaczenie i niestety nie udaje mu sie to. Generuje natomiast setki megabajtów loga, który wyglada w ten sposób:

2007-01-05 18:44:39: Servers: Trying to connect
2007-01-05 18:44:39: Aczenie z 66.172.60.134 (66.172.60.134 - 66.172.60.134:3000)
2007-01-05 18:44:39: Próba poBczenia z 217.228.203.152 (217.228.203.152:9661) upByn limit czasu.
2007-01-05 18:44:39: Servers: Trying to connect
2007-01-05 18:44:39: Aczenie z 62.90.55.67 (62.90.55.67 - 62.90.55.67:4000)
2007-01-05 18:44:39: Próba poBczenia z 66.172.60.134 (66.172.60.134:3000) upByn limit czasu.
2007-01-05 18:44:39: Servers: Trying to connect
2007-01-05 18:44:39: Aczenie z 217.228.240.125 (217.228.240.125 - 217.228.240.125:9661)
2007-01-05 18:44:39: Próba poBczenia z 62.90.55.67 (62.90.55.67:4000) upByn limit czasu.

W ciagu 1 sekundy próbuje podlaczyc sie do okolo 100 serwerów i dla kazdego z nich pisze, ze uplynal timeout. Pomaga uruchomienie aMule Gui i reczne podlaczenie sie do jakiegokolwiek serwera, co udaje sie bezproblemowo.

Podejrzewam, ze problem lezy w zbyt malym czasie oczekiwania na odpowiedz serwera. Czy nie mozna go gdzies zwiekszyc ?

2. KAD w czasie pracy daemona jest praktycznie caBy czas rozlaczony. Polaczony jest tylko zaraz po starcie daemona aMule i wtedy, gdy go recznie wlacze. Po jakims czasie (np. 15 minut) KAD sie rozlacza. Dodam, ze na tym samym polaczeniu internetowym na innym komputerze na Windowsie pracuje jednocze[nie eMule i Kad sie na nim nie wylacza, a w dodatku wyglada na to, ze dostarcza wiele kontaktów.

3. W pliku addresses.dat mam adresy, jak nizej (z emule). Ustawiona mam takze opcje autmatycznej aktualizacji listy serwerów przy starcie.

http://www.server-met.de/dl.php?load=gz&trace=31595874.1389
http://www.server-met.de/dl.php?load=gz&trace=32304311.6944
http://www.alldivx.de/gz/server.met.gz
http://ocbmaurice.dyns.net/pl/slist.pl?download/server-best.met

Niestety albo adresy te sa zle, albo jest jeszcze jakis inny problem, którego nie rozumiem, poniewaz w logu jest taka informacja:

2007-01-05 22:53:11: Kad started.
2007-01-05 22:53:11: Acze z klientem: aMuleweb 2.1.3
2007-01-05 22:53:11: Dostp udzielony.
2007-01-05 22:53:11: The URL to download can't be empty
2007-01-05 22:53:11: Nie udaBo si pobra listy serwerów z
2007-01-05 22:53:11: The URL to download can't be empty
2007-01-05 22:53:11: Nie udaBo si pobra listy serwerów z
2007-01-05 22:53:11: The URL to download can't be empty
2007-01-05 22:53:11: Nie udaBo si pobra listy serwerów z
2007-01-05 22:53:11: The URL to download can't be empty
2007-01-05 22:53:11: Nie udaBo si pobra listy serwerów z

4. W aMule Gui (aMule podlaczone do daemona) po wybraniu opcji "statystyki", aMule Gui sie wywala i zamyka.

5. Jaka jest róznica pomiedzy amule.conf, a remote.conf ?



Z góry dziekuje za wszelka pomoc.
« Last Edit: January 05, 2007, 11:41:06 PM by Leonik »
Logged