aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Fedora 8  (Read 7859 times)

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Fedora 8
« on: February 12, 2008, 01:40:00 PM »

Hi all,
occasionally I build aMule SVN  RPM packages for Fedora 8.
It means that you may not find RPMs for every SVN release; I make a new RPM build when SVN has new features, fixes significative bugs or so.

You can find them here :

http://www.webalice.it/iz0bbz/amule.html

EDIT:
Since May 19, 2008 packages are compiled with GeoIP support. Therefore you need to install GeoIP libraries ('yum install GeoIP') as a prerequisite - rpm will warn you.
Since June 18, 2008 packages are built against wxGTK 2.8.7 libraries

Note: You must remove the amule packages you have installed before aMule SVN, otherwise rpm will complain about overlapping files...


Technical information

1) Switches used in the configure phase:

 --prefix=/usr
 --with-denoise-level=4
 --enable-optimize
 --disable-debug
 --enable-cas
 --enable-wxcas
 --enable-amulecmd
 --enable-amule-daemon
 --enable-amule-gui
 --enable-geoip
 --enable-webserver
 --enable-verbose
 --disable-ccache

2) Libraries used in the build process:
wxGTK 2.8.7Since June 18, 2008
crypto++5.5.2Self-compiled
libpng1.2.22
libgd2.0.34
zlib1.2.3
GeoIP1.4.4Since May 19, 2008

« Last Edit: June 18, 2008, 02:56:40 PM by iz0bbz »
Logged

ak_birdofprey

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: Fedora 8
« Reply #1 on: April 26, 2008, 12:10:15 AM »

Hi all,

from time to time I build aMule SVN 2.2.0  RPM packages for Fedora 8.

You can find them here :

http://www.webalice.it/iz0bbz/amule.html

Packages are compiled without GeoIP support.

Note: You must remove the amule packages you have installed before aMule SVN, otherwise rpm will complain about overlapping files...

Switches used in the configure phase:

 --prefix=/usr
 --with-denoise-level=4
 --enable-optimize
 --disable-debug
 --enable-cas
 --enable-wxcas
 --enable-amulecmd
 --enable-amule-daemon
 --enable-amule-gui
 --enable-webserver
 --enable-verbose
 --disable-ccache

 Libraries used in the build process:

wxWidgets     2.8.4
crypto++       5.5.2
libpng              1.2.22
libgd                 2.0.34
zlib                    1.2.3


OK OK OK  ;D
Logged

once375ml

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Fedora 8
« Reply #2 on: May 17, 2008, 07:16:13 PM »

Hi, iz0bbz

Could packages be compiled with GeoIP ?
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: Fedora 8
« Reply #3 on: May 18, 2008, 08:46:21 PM »

I initially compiled them with GeoIP support, then I removed it  - don't remember exactly why.

I'll have a look at that - and possibly reintroduce GeoIP.
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: Fedora 8
« Reply #4 on: May 19, 2008, 06:12:01 PM »

GeoIP enabled today (amule-2.2.0-SVN_20080519_fc8.i386.rpm)

Same dowload link, see top of thread.
Logged

Shnoulle

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: Fedora 8
« Reply #5 on: May 30, 2008, 12:59:41 AM »

Thank you !!!

Work great !
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: Fedora 8
« Reply #6 on: June 18, 2008, 01:27:32 PM »

Fedora 8 official updates include now wxGTK 2.8.7

Starting today, all my Fedora 8 SVN builds will be compiled against the 2.8.7 library.
Logged