aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2]

Author Topic: aMule SVN 01.23.2008 crash  (Read 7349 times)

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #15 on: March 23, 2008, 02:18:37 PM »

I'm also using the same amule 20080309 version compiled without geoip inside gdb, but it didn't crashed.

Now I would like to know what does make amuled consuming all the cpu after some time of activity.. but this is another issue.....
Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #16 on: March 23, 2008, 05:14:19 PM »

By the way, just so you know, I did not abandon this topic. I stopped posting because I do not have much to say. I downloaded SVN the 5th of March, compiled with debugging (and geo-ip), and I'm running it inside gdb. No crash has occured since then, even though I reproduced the same situation a couple of times (popular files with many sources). I like the messaging theory though I do not have any facts to back it up.

Could you please try a little test, just to see if the messaging theory happens to anyone else.

Run two instances of amule with two different users (if not, it will complain saying that an instance is already running). Then, in the Messages tab, add to the second aMule the first one as a friend (right click-> add fiend). Use as IP 127.0.0.1 (ie. localhost) and as port, the TCP port of the first amule. Once added, right click on it, and Send Message, and send any message to the first one. If you have compiled with geo-ip and you're not filtering messages, the first aMule should crash in the SetTrayIcon function.

Although, I'm reading again this topic, and this particular crash (in SetTrayIcon) didn't happen to you, just to emisca...
Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #17 on: March 23, 2008, 06:38:17 PM »

I've disabled any message filter on the first amule, started another amule as another user, but I don't receive messages, either using 127.0.0.1 ip and the amule tcp port nor the public ip/port of the first amule....
Logged

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: aMule SVN 01.23.2008 crash
« Reply #18 on: March 23, 2008, 06:47:42 PM »

I did exactly what kuanto said and I receive the messages and no crash.
Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #19 on: March 23, 2008, 07:45:31 PM »

Thanks for trying  ;)

I've disabled any message filter on the first amule, started another amule as another user, but I don't receive messages, either using 127.0.0.1 ip and the amule tcp port nor the public ip/port of the first amule....

Any signal of the message? Neither a "message filtered" in the log, neither crash, neither the message itself...??
Maybe it wasn't succesfully sent from the second amule: Did the message you typed appear in the chat window of the sender?

I did exactly what kuanto said and I receive the messages and no crash.

Well. in my machine it crashes whenever I follow those steps. Maybe it happens only on some specific configuration: If it helps, my system is:

AMD64
Kubuntu 7.10
g++ (GCC) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Linux kernel  2.6.22-14-generic
wxGTK 2.8.7 compiled from sources following wiki instructions
aMule CVS 23-03-2008 (just downloaded today version to try, and crashed too) compiled with
./configure --disable-optimize --enable-debug --enable-geoip --with-wx-config=/home/yo/usr/lib/wx/config/gtk2-unicode-release-2.8

Any idea? If you want me to run some test, just let me know  ;)

« Last Edit: March 23, 2008, 07:59:18 PM by kuanto »
Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #20 on: March 23, 2008, 08:06:04 PM »

My ipfilter list filtered it :-(

I've disabled it, and also "filter lan ip" but nothing to do...


Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #21 on: March 23, 2008, 08:19:27 PM »

My ipfilter list filtered it :-(

I've disabled it, and also "filter lan ip" but nothing to do...

Mmm, now that you mention it... 127.0.0.1 is in my ipfiler and I have "always filter LAN IPs" on. That message packet should be filtered from the beginning, shouldn't it?
Logged

emisca

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: aMule SVN 01.23.2008 crash
« Reply #22 on: March 23, 2008, 09:13:35 PM »

Yes. Your amule doesn't filter it?
Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #23 on: March 23, 2008, 09:29:26 PM »

Yes. Your amule doesn't filter it?

Yes.  The message is accepted, although it comes from an IP which is in ipfilter, and even that IP (127.0.0.1) should be filtered by the "Always filter LAN IPs" option.

Could this be another bug?
Logged

kuanto

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
Re: aMule SVN 01.23.2008 crash
« Reply #24 on: March 24, 2008, 01:10:01 AM »

Some news.

I downloaded the Festor pre-compiled aMule package from here (to see if i was compiling it wrongly) : http://forum.amule.org/index.php?topic=13700.0 and I crashed it from another instance of aMule, sending a message. But this time, the backtrace says nothing about TrayIcon.


----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN using wxGTK2 v2.8.4 (Snapshot: Sat Mar 15 07:01:47 CET 2008)
Running on: Linux 2.6.22-14-generic x86_64

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x4486b5]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x2ad75afd764c]
[4] ?? in /lib/libpthread.so.0 [0x2ad759a82100]
[5] wxMenuItemList::~wxMenuItemList() in amule [0x5768d8]
[6] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x51ab27]
[7] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x51b282]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2ad75afd366f]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x2ad75afd380f]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x2ad75afd3959]
[11] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ad75a959d76]
[12] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x2ad75a850a14]
[13] ?? in /usr/lib/libglib-2.0.so.0 [0x2ad75d69470b]
[14] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x2ad75d693fd3]
[15] ?? in /usr/lib/libglib-2.0.so.0 [0x2ad75d6972dd]
[16] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x2ad75d6975ea]
[17] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x2ad75dc93883]
[18] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ad75a84850d]
[19] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ad75a8d9c8b]
[20] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x2ad75af7280c]
[21] std::basic_string<char, std::char_traits<char>, std::allocator<char> > std::operator+<char, std::char_traits<char>, std::allocator<char> >(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) in amule [0x516062]
[22] __libc_start_main in /lib/libc.so.6[0x2ad75be20b44]
[23] CryptoPP::BufferedTransformation::ChannelPut2(std::string const&, unsigned char const*, unsigned long, int, bool) in amule[0x4478f9]


--------------------------------------------------------------------------------

Could this be something Ubuntu specific?

Hope it helps  ;)
Logged

shirms

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule SVN 01.23.2008 crash
« Reply #25 on: March 31, 2008, 09:19:56 PM »

Current version is: aMule SVN using wxGTK2 v2.8.7 (Snapshot: Mon Mar 31 07:01:45 CEST 2008)
Running on: Linux 2.6.18-6-686 i686

[2] ?? in amule [0x808b5b5]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xb7469bd6]
[4] ?? in [0xb7f03420]
[5] ?? in [0x8d910b5]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0xb6ce8b3f]
[7] ?? in /usr/lib/libglib-2.0.so.0 [0xb6a8a45d]
[8] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb6a567e8]
[9] ?? in /usr/lib/libglib-2.0.so.0 [0xb6a59a3e]
[10] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb6a59dc7]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb6e99cd4]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb762af0c]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb76cd23e]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb76cc871]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xb73fa2ca]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xb73fa377]
[17] ?? in amule [0x824be9e]
[18] __libc_start_main in /lib/i686/cmov/libc.so.6[0xb70e4450]
[19] ?? in amule [0x8085991]

now i'm running with message filtering enabled. if it'll crush again, i'm going to make backtrace from wiki
Running Debian etch
Logged

shirms

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule SVN 01.23.2008 crash
« Reply #26 on: April 01, 2008, 11:03:54 PM »

thanks for the solution (the one 'bout turning message filtering on). seems like it helped - at least more than 24h without crashes ;)
Logged
Pages: 1 [2]