aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amule-ubuntu  (Read 5018 times)

schwedeii

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
amule-ubuntu
« on: July 25, 2008, 03:14:40 PM »

Nachdem amule einige Minuten gelaufen ist, schliesst es sich selbst. Nach einem Start aus der Konsole gibt diese folgende Meldung aus:
Current version is: aMule SVN using wxGTK2 v2.8.7 (Snapshot: Mon Feb 18 07:02:15 CET 2008)
Running on: Linux 2.6.24-19-generic x86_64

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x4495b5]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x7f6be518686c]
[4] ?? in /lib/libpthread.so.0 [0x7f6be664e7d0]
[5] wxMenuItemList::~wxMenuItemList() in amule [0x57b783]
[6] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x51e66b]
[7] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x51edb6]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x7f6be518272d]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x7f6be51828ec]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x7f6be5182a2d]
[11] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f6be591a616]
[12] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x7f6be5811554]
[13] ?? in /usr/lib/libglib-2.0.so.0 [0x7f6be27b498b]
[14] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x7f6be27b4262]
[15] ?? in /usr/lib/libglib-2.0.so.0 [0x7f6be27b7516]
[16] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x7f6be27b77d7]
[17] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x7f6be3ceff03]
[18] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f6be580901d]
[19] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f6be589b58b]
[20] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x7f6be512119c]
[21] std::basic_string<char, std::char_traits<char>, std::allocator<char> > std::operator+<char, std::char_traits<char>, std::allocator<char> >(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) in amule [0x51a302]
[22] __libc_start_main in /lib/libc.so.6[0x7f6be439b1c4]
[23] CryptoPP::BufferedTransformation::ChannelPut2(std::string const&, unsigned char const*, unsigned long, int, bool) in amule[0x4487c9]


--------------------------------------------------------------------------------
Aborted
chef@wzpc:~$

Das Betribssystem ist ubuntu 8.10
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: amule-ubuntu
« Reply #1 on: July 25, 2008, 04:26:14 PM »

Bitte nutze zumindest die Version 2.2.1.

Nebenbei solltest du dir bewusst sein, dass wir a) für Distributionspackete keine Hilfe anbieten (da diese oft Fehler verursachen, für die wir schlicht und ergreifend nichts können= und b) Ubuntu 8.10 eine Entwicklungsversion ist, die, wie der Name bereits andeutet, sich noch in Entwicklung befindet und daher Fehler enthalten kann. (Dieses ist allerdings ein altes Problem mit Ubuntu, was auch schon in älteren Versionen aufgetreten ist und meist durch selbstkompilieren von Crypto++, wxGTK und aMule gelöst werden kann.)
Logged