aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: Debian Stable  (Read 33306 times)

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1486
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Debian Stable
« on: August 08, 2008, 09:04:25 PM »

The stable version is updated

deb http://www.vollstreckernet.de/debian/ stable amule-stable wx upnp

wx is needed for wx-2.8, you can omit it, if you have it already from somewhere else

upnp is needed for libupnp 1.6.6, you can omit it, if you have it already from somewhere else

For both optional parameters is said, if it's not needed anaymore, becuase the official repo includes it, they will just get an empty index. So if you leave them in the sources.list, you'll get the updated versions when they are needed by amule and didn't reach stable.

For sure, you can get the sources for selfcompile the usual way via:

deb-src http://www.vollstreckernet.de/debian/ stable amule-stable wx upnp

You can combine those two possibilities to get just what you want.
« Last Edit: August 09, 2008, 11:15:38 AM by Vollstrecker »
Logged
Homefucking is killing prostitution

MMMMMMMM

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Debian Stable
« Reply #1 on: August 09, 2008, 05:44:44 AM »

I am currently using  aMule 2.2.0 on Ubuntu 8.04.  I am somewhat new to Linux. I was notified the latest version is aMule 2.2.2. While searching for a way to update, I ended up on this thread. Now I don't know what to do next. Can someone tell me what to do to update? (i.e. What file do I need to download? Where is it located? Once I've downloaded it, how do I actually install it? Isn't there an automated way through Synaptic or the Ubuntu sofware updater? If not, what do I type in the terminal to make it happen?) 

Thanks!!!!
Logged

johndoe32102002

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 6
  • http://johndoe32102002.blogspot.com
Re: Debian Stable
« Reply #2 on: August 09, 2008, 08:52:35 AM »

Can someone please provide a URL to directly download a *.deb file for aMule?  What platforms are supported?  x86, x64, ARM?
Logged
My Public PGP Encryption Key:
http://johndoe32102002.blogspot.com

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1486
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Debian Stable
« Reply #3 on: August 09, 2008, 11:01:34 AM »

@M The line starting with deb belong into the repository list of synaptic.

@john only 32 bit intel from my side.
Logged
Homefucking is killing prostitution

Aardvarh

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Re: Debian Stable
« Reply #4 on: August 09, 2008, 04:44:26 PM »

Any chance of including the libcrypto++5 in the repository as this doesn't seem to be available on Hardy? Or is it possible to build against libcrypto++7

TIA
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1486
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Debian Stable
« Reply #5 on: August 09, 2008, 05:30:41 PM »

Use the testing repo.
Logged
Homefucking is killing prostitution

Aardvarh

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Re: Debian Stable
« Reply #6 on: August 09, 2008, 07:26:42 PM »

Unfortunately the testing  repo has an unresolved dependency on libstdc++ >= 4.3 (Hardy has 4.2).
Logged

skidzo

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: Debian Stable
« Reply #7 on: August 09, 2008, 08:37:23 PM »

Unfortunately the testing  repo has an unresolved dependency on libstdc++ >= 4.3 (Hardy has 4.2).


amule:

in german :D
 Hängt ab: »libstdc++6 (>=4.3)«, aber es wird »4.2.3-2ubuntu7« installiert.

and what about this?? also in german   :D
 Hängt ab: »amule-i18n-en-gb«, aber es wird nicht installiert. oder
   amule-i18n

sudo apt-get install amule tells some more stuff that is of no content at all and wont't install what I wan't

I would be pleased if there is some information to overcome those package dependency errors

i will try svn now... ehm ok

Sorry, I no longer use Ubuntu (I use Debian) and therefore I can not do, nor do I want, more deb packages

PS I AM USING THE TESTING REPO
« Last Edit: August 09, 2008, 08:47:04 PM by skidzo »
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1486
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Debian Stable
« Reply #8 on: August 10, 2008, 01:11:31 AM »

Mayxbe I do some packages for Ubuntu the next week. But only for the stable releases (amule and current ubuntu).
Logged
Homefucking is killing prostitution

marcpalaus

  • Guest
Re: Debian Stable
« Reply #9 on: August 11, 2008, 01:12:40 AM »

I get an error if I try to update form 2.2.1 in debian stable.

Quote
Els següents paquets tenen dependències sense satisfer:
  amule-daemon: Depén: libupnp3 però no és instal·lable
E: Paquets trencats

(amule-daemon depends on libupnp3 but this package is not installable. Broken packages)

thanks in advance
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1486
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Debian Stable
« Reply #10 on: August 11, 2008, 09:39:31 AM »

You have upnp appended to your sources.list line?
Logged
Homefucking is killing prostitution

ProteinPappa

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Debian Stable
« Reply #11 on: August 11, 2008, 05:50:21 PM »

I'm running Ubuntu 8.04 and have added your repo, however it won't upgrade from it because the source isn't authenticated. It asks for a "puplic key", and I'm guessing it's something like what you do when you add the WINE repo: http://www.winehq.org/site/download-deb

is there any way around this?


Thanks for the update btw :)
Logged

ferchon03

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: Debian Stable
« Reply #12 on: August 11, 2008, 07:07:33 PM »

I 'm on ubuntu 8.04 too. I get this errors after 'sudo apt-get update':

Code: [Select]
W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/Release.gpg  Could not connect to www.vollstreckernet.de:80 (62.67.235.26). - connect (111 Connection refused)

W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/amule-stable/i18n/Translation-en_US.bz2  Could not connect to www.vollstreckernet.de:80 (62.67.235.26). - connect (111 Connection refused)

W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/wx/i18n/Translation-en_US.bz2  Could not connect to www.vollstreckernet.de:80 (62.67.235.26). - connect (111 Connection refused)

W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/upnp/i18n/Translation-en_US.bz2  Could not connect to www.vollstreckernet.de:80 (62.67.235.26). - connect (111 Connection refused)
Thanks
Logged

macman

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: Debian Stable
« Reply #13 on: August 12, 2008, 01:19:52 PM »

amule: error while loading shared libraries: libbfd-2.17.so: cannot open shared object file: No such file or directory

What can I do? Thanks.
Logged

MMMMMMMM

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Debian Stable
« Reply #14 on: August 12, 2008, 01:45:11 PM »

I have the same problem as ProteinPappa, also on Ubuntu 8.04
Logged
Pages: [1] 2