aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Aggirare il router, amule firewalled  (Read 23154 times)

overbost

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Aggirare il router, amule firewalled
« on: January 17, 2009, 03:26:14 PM »

Ciao,

Ho notato che come tutti i client p2p che girano su linux, aMule non è capace di aggirare un router, senza il forwarding delle porte
per non ottenere un low-id. Il problema è caratterizzato dal sistema operativo o dalla mancanza di questa preziosa funzionalità?
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Aggirare il router, amule firewalled
« Reply #1 on: January 17, 2009, 04:22:44 PM »

Infatti aMule e' capace di fare il forwarding. Hai bisogno di upnp (aMule compilato con upnp) e lo devi attivare. Puoi attivare upnp e dirci (dire a noi?) cosa dice nel log in rispetto a upnp, per favore?

Credo che siano altri clienti per bittorent con upnp...
Logged

overbost

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Aggirare il router, amule firewalled
« Reply #2 on: January 17, 2009, 04:50:51 PM »

Questo viene riportato nel log


2009-01-17 16:47:43: Universal Plug and Play: bound to xxx.xxx.xxx.xxx:50000.
2009-01-17 16:47:43: Universal Plug and Play: UPnP Error: CUPnPControlPoint::AddPortMapping: WAN Service not detected.

chiaramente al posto delle x cè il mio ip
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Aggirare il router, amule firewalled
« Reply #3 on: January 17, 2009, 05:42:09 PM »

Sembra tutto sul cavallo. (Si può ignorare quest'errore.) C'è ancora un problema con il port forwarding?
Logged

overbost

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Aggirare il router, amule firewalled
« Reply #4 on: January 17, 2009, 05:51:08 PM »

Il port forwarding non posso farlo sul router.

Comunque ottengo sempre un Low Id
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Aggirare il router, amule firewalled
« Reply #5 on: January 17, 2009, 06:24:21 PM »

Poi, funziona UPnP con Windows? Che modello di router tieni? Il tuo sistema operativo, ha un firewall?
Logged

overbost

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Aggirare il router, amule firewalled
« Reply #6 on: January 18, 2009, 03:24:46 PM »

Io uso Fedora 10, e il mio router è Alice wifi gate 2 plus della Telecom NON CONFIGURABILE, ovvero non si può fare il port forwarding delle porte, ma con Windows tutti i programmi p2p funzionano a dovere perchè hanno implementato delle funzionalità per aggirare questo problema, volevo sapere se aMule ha implementato qualcosa del genere, e in caso proporla come prossima features.

Ho anche configurato iptables come ho letto in una guida ma il risultato è lo stesso.
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Aggirare il router, amule firewalled
« Reply #7 on: January 18, 2009, 03:36:57 PM »

Mi spiace, ma l'unica possibilità di fare il forwarding che conosco io è upnp, non so cosa fanno i clienti windows diverso di noi se il log non dice niente.
Logged

minage

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 117
Re: Aggirare il router, amule firewalled
« Reply #8 on: January 19, 2009, 03:01:41 AM »

overbost se da windows non hai problemi vuol dire che lì l'upnp funziona.
Il fatto che il modem di alice non sia configurabile probabilmente non vuol dire in senso assoluto ma semplicemente non puoi farlo te manualmente.

Non è che esistano trucchi e magie in cui in windows si "raggira" l'ostacolo e in altri sistemi operativi no.

Tu amule come l'hai installato? Compilato o con i pacchetti?
Se compilato ricordi se su ./configure hai avuto errori?

Se non l'hai compilato, scaricati i sorgenti e una volta estratti apri la console e vai nella cartella di amule.
Poi dai il comando:
./configure

e vedi se ti da qualche errore serio (ossia si interrompe tutto).
Se si, guarda se è per l'upnp o no.
Se no, eventualmente disabilita quella funzione cercandola con ./configure --help

Quando tutto andrà bene, dopo ./configure avrai un piccolo riepilogo delle funzioni che andranno installate.
Lì controlla se upnp c'è scritto Si/Yes o No.

da li potresti capire se è supportato o no.

Poi basta che cancelli la directory di amule su cui hai fatto le prove e basta.
Logged

overbost

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Aggirare il router, amule firewalled
« Reply #9 on: January 19, 2009, 01:56:48 PM »

Con windows non uso aMule ma eMule, e non mi sembra che utilizzi upnp.

aMule l'ho installato con rpm o con yum, non ricordo, versione 2.2.2.

l'output di ./configure è

...
checking for wx-config... /usr/local/bin/wx-config
checking for wxWidgets version >= 2.8.0 (--unicode=yes)... no
configure: error:
    The requested wxWidgets build couldn't be found.
   
    The configuration you asked for aMule requires a wxWidgets
    build with the following settings:
        --unicode=yes
    but such build is not available.

    To see the wxWidgets builds available on this system, please use
    'wx-config --list' command. To use the default build, returned by
    'wx-config --selected-config', use the options with their 'auto'
    default values.

    If you still get this error, then check that 'wx-config' is
    in path, the directory where wxWidgets libraries are installed
    (returned by 'wx-config --libs' command) is in LD_LIBRARY_PATH
    or equivalent variable and wxWidgets version is 2.8.0 or above.

la libreria wxwidget è installata, penso manchi il parametro --unicode=yes, ma non sò dove settarlo.
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: Aggirare il router, amule firewalled
« Reply #10 on: January 26, 2009, 01:32:36 PM »

Io uso Fedora 10 ...
Ho anche configurato iptables come ho letto in una guida ma il risultato è lo stesso.

Per essere certi che non sia un problema delle iptables, prova a disabilitarle temporaneamente con 'service iptables stop' , riavvia amule e vedi se cambia qualcosa - anche nei messaggi del log.
Hai provato a connetterti alla rete Kad invece che ai server?
Logged

overbost

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Aggirare il router, amule firewalled
« Reply #11 on: January 31, 2009, 03:16:01 PM »

stoppando iptables ottengo ID-ALTO!!

cosa comporta la disabilitazione di iptables?
come posso tenere il servizio attivo e amule id alto?
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: Aggirare il router, amule firewalled
« Reply #12 on: January 31, 2009, 03:38:00 PM »

Il tuo sistema operativo, ha un firewall?
iptables è il firewall incluso nel kernel. Non è consigliabile lasciarlo disabilitato in via permanente. E' servito solo per una prova.

La conclusione è che non hai configurato correttamente le regole di iptables per abilitare le porte TCP e UDP utilizzate da amule.

Logged

franz1789

  • Full Member
  • ***
  • Karma: 2
  • Offline Offline
  • Posts: 133
    • Franz's blog
Re: Aggirare il router, amule firewalled
« Reply #13 on: March 26, 2010, 12:58:51 AM »

Se lo avessi io tra le mani farei questo... ma se combini casini poi sono ca**i...