aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amuled 2.2.5 NON si connette alla rete KAD  (Read 12618 times)

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
amuled 2.2.5 NON si connette alla rete KAD
« on: June 25, 2009, 11:34:39 PM »

Ciao, come da oggetto amule-daemon presente su  una macchina Ubuntu 9.04 server NON si connette alla rete KAD, mentre i server funzionano correttamente; usualmente vi accedo tramite aMuleGUI su Mac OS X 10.5.

Riavviando il demone leggo:
Code: [Select]
$ amulecmd
This is amulecmd 2.2.5
Enter password for mule connection:

Creating client...
Succeeded! Connection established to aMule 2.2.5

---------------------------------------
|          aMule text client          |
---------------------------------------

Use 'Help' for command list

aMulecmd$ show log
 > 2009-06-25 23:25:02: Starting aMuled 2.2.5 using wxGTK2 v2.8.9
 [...]
 > 2009-06-25 23:25:03: Letti 124 contatti Kad
 [...]
 > 2009-06-25 23:25:04: Kad avviato.
 [...]
 > 2009-06-25 23:25:09: Accettata nuova connessione esterna
 > 2009-06-25 23:25:09: Connessione al client: aMulecmd 2.2.5
 > 2009-06-25 23:25:09: Accesso consentito.
aMulecmd$ status
 > eD2k: Connected to BiG BanG 1 [129.47.150.9:4661] with HighID
 > Kad: Not connected
 > Download: 0 bytes/sec
 > Upload: 110 bytes/sec
 > Clients in queue: 0
 > Total sources: 0

Quali accorgimenti posso adottare per risolvere il problema? Quali altre informazioni possono servire?

Il mio obiettivo finale e' far in modo che amuled sia connesso alla SOLA rete KAD; preciso inoltre che una installazione di prova di aMule su una macchina virtuale si connette regolarmente.

Grazie a tutti per l'attenzione,
wo
« Last Edit: June 25, 2009, 11:42:23 PM by wodanymir »
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #1 on: June 26, 2009, 01:08:58 PM »

Ciao, per prima cosa ti segnalo la presenza del wiki per le FAQ e molte informazioni di base.

Nel tuo caso il problema è che non è facile configurare amuled, in quanto la GUI remota manca ancora di alcune funzionalità.
Siccome amuled e amule (la versione 'monolitica' compresa la GUI) condividono la stessa configurazione, se puoi far partire sulla tua macchina amule invece di amuled, fallo almeno una volta per configurare le preferenze tramite la GUI. Poi salva, chiudi e dal quel momento in poi fai partire amuled .

Nella pagina delle preferenze/Connessione ci sono dei flag per decidere indipendentemente a quali reti connettersi - ed2k e/o kad.

Se proprio non puoi far partire amule (compresa GUI), segui questa procedura:

1) chiudi amuled
2) edita il file di configurazione  $HOME/.aMule/amule.conf ablitando la connessione ad entrambe le reti modificando come segue le seguentidue righe:

ConnectToED2K=1
ConnectToKad=1

3) fai ripartire amuled

Questo ti servirà per popolare la lista iniziale dei nodi per la rete Kad.
Dopo un po' di tempo, puoi ripetere la procedura disabilitando la rete ed2k ("ConnectToED2K=0")
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #2 on: June 26, 2009, 01:10:28 PM »

Mi viene un sospetto:
per caso è  installato aMule-adunanza invece di aMule ?
Logged

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #3 on: June 26, 2009, 06:06:09 PM »

Ciao e grazie per la tua risposta. :)

Non posso utilizzare la versione monolitica perche' non ho installato Xorg ad ogni modo ho sempre editato il file ~/.aMule/amule.conf, previo arresto del demone.
1. Subito ho dovuto attivare le connessioni esterne altrimenti amuled NON si avviava a priori
Code: [Select]
AcceptExternalConnections=12. dopo di che ho sostituito manualmente il file nodes.dat con quello di una precedente installazione, abilitato solo la connessione alla rete KAD ed avviato amuled
Code: [Select]
ConnectToKad=1
ConnectToED2K=0
amuled NON si connetteva a KAD
3. ho abilitato quindi anche la rete ED2K col risultato di essere connesso correttamente a quest'ultima e non a KAD (vedi primo post) sebbene il file nodes.dat fosse corretto
4. dopo aver aggiornato la lista dei server ieri sera, attualmente ho trovato amuled connesso a KAD, ma posto il log
Code: [Select]
aMulecmd$ show log
 > 2009-06-26 00:04:47: Starting aMuled 2.2.5 using wxGTK2 v2.8.9
 > 2009-06-26 00:04:47: Il file dei crediti è stato caricato, 0 client conosciuti
 > 2009-06-26 00:04:47: Carico i filtri IP da 'ipfilter.dat' e 'ipfilter_static.dat'.
 > 2009-06-26 00:04:47: Caricati 0 intervalli di IP da '/home/login/.aMule/ipfilter.dat'. 0 righe non valide sono state scartate.
 > 2009-06-26 00:04:47: Caricati 0 intervalli di IP da '/home/login/.aMule/ipfilter_static.dat'. 0 righe non valide sono state scartate.
 > 2009-06-26 00:04:47: *** TCP socket (ECServer) listening on 0.0.0.0:4712
 > 2009-06-26 00:04:47: Created Server UDP-Socket at port 1758
 > 2009-06-26 00:04:47: Created Client UDP-Socket at port 1756
 > 2009-06-26 00:04:47: Caricamento file server.met: /home/login/.aMule/server.met
 > 2009-06-26 00:04:47: Trovati 143 server nel file server.met
 > 2009-06-26 00:04:47: Trovati 48 file parziali
 > 2009-06-26 00:04:47: Trovati 173 file condivisi conosciuti
 > 2009-06-26 00:04:47: Connessione in corso
 > 2009-06-26 00:04:47: Connessione a Real Sharing No1 (94.23.200.122 - 94.23.200.122:4500)
 > 2009-06-26 00:04:47: Letti 103 contatti Kad
 > 2009-06-26 00:04:47: ThreadScheduler: Completed task 'AICH Syncronizing', 0 tasks remaining.
 > 2009-06-26 00:04:47: Connesso a Real Sharing No1 (94.23.200.122:4500)
 > 2009-06-26 00:04:47: Kad avviato.
 > 2009-06-26 00:04:48: Connessione a Capitol (38.99.169.87 - 38.99.169.87:5661)
 > 2009-06-26 00:04:48: Connesso a Capitol (38.99.169.87:5661)
 > 2009-06-26 00:04:49: Connessione stabilita con: Real Sharing No1
 > 2009-06-26 00:04:49: Connesso a Real Sharing No1 con ID alto
 > 2009-06-26 00:04:49: Il nuovo clientID è 2702258071
 > 2009-06-26 00:04:49: Messaggio del server: server version 17.15 (lugdunum)
 > 2009-06-26 00:04:54: Accettata nuova connessione esterna
 > 2009-06-26 00:04:54: Connessione al client: amule-remote 0x0001
 > 2009-06-26 00:04:54: Accesso consentito.
 > 2009-06-26 00:08:06: Connessione esterna chiusa.
 > 2009-06-26 00:09:02: Accettata nuova connessione esterna
 > 2009-06-26 00:09:02: Connessione al client: amule-remote 0x0001
 > 2009-06-26 00:09:02: Accesso consentito.
 > 2009-06-26 00:09:22: Connessione esterna chiusa.
 > 2009-06-26 00:59:23: Kad arrestato.
 > 2009-06-26 00:59:23: Connesso alla rete Kad (firewalled)
 > 2009-06-26 01:53:50: Solo 2 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 01:53:50: Created Client UDP-Socket at port 1756
 > 2009-06-26 01:53:50: Letti 103 contatti Kad
 > 2009-06-26 02:56:53: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 02:56:53: Created Client UDP-Socket at port 1756
 > 2009-06-26 02:56:53: Letti 103 contatti Kad
 > 2009-06-26 05:02:59: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 05:02:59: Created Client UDP-Socket at port 1756
 > 2009-06-26 05:02:59: Letti 103 contatti Kad
 > 2009-06-26 07:30:08: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 07:30:08: Created Client UDP-Socket at port 1756
 > 2009-06-26 07:30:08: Letti 103 contatti Kad
 > 2009-06-26 07:58:21: Connesso alla rete Kad (ok)
 > 2009-06-26 09:30:08: Connesso alla rete Kad (firewalled)
 > 2009-06-26 09:36:16: Solo 2 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 09:36:16: Created Client UDP-Socket at port 1756
 > 2009-06-26 09:36:16: Letti 103 contatti Kad
 > 2009-06-26 11:00:19: Solo 2 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 11:00:19: Created Client UDP-Socket at port 1756
 > 2009-06-26 11:00:19: Letti 103 contatti Kad
 > 2009-06-26 11:42:24: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 11:42:24: Created Client UDP-Socket at port 1756
 > 2009-06-26 11:42:25: Letti 103 contatti Kad
 > 2009-06-26 14:30:30: Solo 2 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 14:30:30: Created Client UDP-Socket at port 1756
 > 2009-06-26 14:30:30: Letti 103 contatti Kad
 > 2009-06-26 15:04:57: Connesso alla rete Kad (ok)
 > 2009-06-26 15:33:31: Solo 2 contatti Kad disponibili, nodes.dat non scritto
 > 2009-06-26 15:33:31: Created Client UDP-Socket at port 1756
 > 2009-06-26 15:33:31: Letti 103 contatti Kad
 > 2009-06-26 15:36:06: Connesso alla rete Kad (firewalled)
 > 2009-06-26 16:06:37: Connesso alla rete Kad (ok)
 > 2009-06-26 17:23:55: Accettata nuova connessione esterna
 > 2009-06-26 17:23:55: Connessione al client: amule-remote 0x0001
 > 2009-06-26 17:23:55: Accesso consentito.
 > 2009-06-26 17:33:31: Connesso alla rete Kad (firewalled)
 > 2009-06-26 17:58:04: Accettata nuova connessione esterna
 > 2009-06-26 17:58:04: Connessione al client: aMulecmd 2.2.5
 > 2009-06-26 17:58:04: Accesso consentito.
 > 2009-06-26 17:58:04: Connessione esterna chiusa.
 > 2009-06-26 17:58:26: Accettata nuova connessione esterna
 > 2009-06-26 17:58:26: Connessione al client: aMulecmd 2.2.5
 > 2009-06-26 17:58:26: Accesso consentito.
aMulecmd$

Adesso provero' a disabilitare la rete ED2K e vedere se riesco a mantenere la connessione solo a KAD: e' da un po' che uso amuled su un server headless, pero' sono queste ultime versioni che faticano a connettersi a KAD mentre la controparte monolitica no (la prova cui accennavo nel primo post)... perche'? ???

wo

p.s.: mi sono accorto di aver postato nel forum "it_Bugs" piuttosto che "Aiuto su aMule", chiedo venia se ho sbagliato... :-\
p.p.s.: non e' la versione Adunanza, ma quella pacchettizzata da Festor su PPA.
Code: [Select]
$ amuled -v
amuled: OnInit - starting timer
aMuled 2.2.5 using wxGTK2 v2.8.9 (OS: Linux)
$
« Last Edit: June 26, 2009, 06:08:07 PM by wodanymir »
Logged

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #4 on: June 26, 2009, 06:10:19 PM »

KAD appena sconnesso... :'(

Code: [Select]
$ amulecmd -c status
This is amulecmd 2.2.5
Enter password for mule connection:

Creating client...
Succeeded! Connection established to aMule 2.2.5
 > eD2k: Connected to Real Sharing No1 [94.23.200.122:4500] with HighID
 > Kad: Not connected
 > Download: 0 bytes/sec
 > Upload: 10.02 kB/s
 > Clients in queue: 875
 > Total sources: 72
$
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #5 on: June 29, 2009, 01:46:56 PM »

Ora non ho tempo per una analisi + profonda, ma mi sembra che di fatto non si colleghi mai alla rete Kad.
Anche se qualche volta da' 'ok', di fatto i nodi contattati tendono sempre a zero, e viene reinizializzato il socket UDP associato:
Quote
> 2009-06-26 15:33:31: Created Client UDP-Socket at port 1756
In questa situazione,  i nodi kad non vengono salvati per sicurezza e si riparte sempre, nel caso dell'ultimo tuo log, da 103 nodi iniziali - sempre gli stessi immagino - per poi scendere a zero.

A questo punto la prima verifica d'obbligo è quella di accertarsi che la porta 'UDP client' 1756 da te usata sia effettivamente aperta in ingresso sia nel firewall interno del sistema operativo che nel firewall del router.
Logged

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #6 on: July 04, 2009, 08:02:55 PM »

Ciao!
A questo punto la prima verifica d'obbligo è quella di accertarsi che la porta 'UDP client' 1756 da te usata sia effettivamente aperta in ingresso sia nel firewall interno del sistema operativo che nel firewall del router.
Lato router ne sono certo perche' utilizzando aMule monolitico su una macchina virtuale mi collego correttamente alla rete KAD (dopo aver modificato l'IP verso il quale viene fatto il port forwarding); lato firewall del sistema operativo vorrei dire "anche" perche' non ho messo mano ad iptables ed ubuntu server non mi sembra imposti di default delle regole particolari (mi baso su quanto avviene per la rete ED2K, connessa con ID alto per cui la relativa porta e' aperta), ad ogni modo mi documento che non so usare iptables, e confermo anche questo.

Grazie per il supporto! :)
wo
« Last Edit: July 04, 2009, 08:05:14 PM by wodanymir »
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #7 on: July 05, 2009, 03:59:20 PM »

In assenza di una configurazione specifica le connessioni in ingresso sono normalmente bloccate.
Prova con
Code: [Select]
iptables -I INPUT -p udp --destination-port 1756 -j ACCEPT
Logged

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #8 on: July 05, 2009, 05:26:12 PM »

Ciao!
In assenza di una configurazione specifica le connessioni in ingresso sono normalmente bloccate.

Ecco come e' configurato il mio server:
Code: [Select]
$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination        

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination        

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination        
$
in teoria non dovrebbe bloccare nulla, giusto?


EDIT: nel frattempo ho aggiornato anche i pacchetti di Festor, questo l'ultimo log dopo il riavvio del pc:
Code: [Select]
$ amulecmd
This is amulecmd 2.2.5
Enter password for mule connection:

Creating client...
Succeeded! Connection established to aMule 2.2.5

---------------------------------------
|          aMule text client          |
---------------------------------------

Use 'Help' for command list

aMulecmd$ status
 > eD2k: Connected to StormShare 4 [83.140.191.163:4500] with HighID
 > Kad: Connected (firewalled)
 > Download: 18.67 kB/s
 > Upload: 10.03 kB/s
 > Clients in queue: 667
 > Total sources: 523
aMulecmd$ show log
 > 2009-07-05 17:32:52: Starting aMuled 2.2.5 using wxGTK2 v2.8.9
 > 2009-07-05 17:32:53: Il file dei crediti è stato caricato, 1239 client conosciuti
 > 2009-07-05 17:32:53: Carico i filtri IP da 'ipfilter.dat' e 'ipfilter_static.dat'.
 > 2009-07-05 17:33:09: Caricati 217083 intervalli di IP da '/home/login/.aMule/ipfilter.dat'. 0 righe non valide sono state scartate.
 > 2009-07-05 17:33:09: Caricati 0 intervalli di IP da '/home/login/.aMule/ipfilter_static.dat'. 0 righe non valide sono state scartate.
 > 2009-07-05 17:33:10: *** TCP socket (ECServer) listening on 0.0.0.0:4712
 > 2009-07-05 17:33:10: Created Server UDP-Socket at port 1758
 > 2009-07-05 17:33:10: Created Client UDP-Socket at port 1756
 > 2009-07-05 17:33:10: Caricamento file server.met: /home/login/.aMule/server.met
 > 2009-07-05 17:33:10: Trovati 6 server nel file server.met
 > 2009-07-05 17:33:11: Trovati 58 file parziali
 > 2009-07-05 17:33:12: Trovati 281 file condivisi conosciuti
 > 2009-07-05 17:33:12: Connessione in corso
 > 2009-07-05 17:33:12: Connessione a StormShare 4 (83.140.191.163 - 83.140.191.163:4500) utilizzo offuscamento del protocollo.
 > 2009-07-05 17:33:12: Letti 29 contatti Kad
 > 2009-07-05 17:33:12: Connesso a StormShare 4 (83.140.191.163:4500)
 > 2009-07-05 17:33:12: Kad avviato.
 > 2009-07-05 17:33:12: ThreadScheduler: Completed task 'AICH Syncronizing', 0 tasks remaining.
 > 2009-07-05 17:33:14: Connessione stabilita con: StormShare 4
 > 2009-07-05 17:33:14: Connesso a StormShare 4 con ID alto
 > 2009-07-05 17:33:14: Il nuovo clientID è 3224186775
 > 2009-07-05 17:33:14: Messaggio del server: server version 17.15 (lugdunum)
 > 2009-07-05 17:33:23: Kad arrestato.
 > 2009-07-05 17:33:23: Connesso alla rete Kad (firewalled)
 > 2009-07-05 17:47:59: Accettata nuova connessione esterna
 > 2009-07-05 17:47:59: Connessione al client: aMulecmd 2.2.5
 > 2009-07-05 17:47:59: Accesso consentito.
aMulecmd$
Per ora non ha reinizializzato il socket UDP sebbene si sia connesso/disconnesso/riconnesso. I nodi iniziali sono ora 23, saranno aggiornati o parte dei 103 iniziali??

Ancora grazie,
wo
« Last Edit: July 05, 2009, 05:56:05 PM by wodanymir »
Logged

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #9 on: July 09, 2009, 10:16:11 AM »

Ciao!

In assenza di una configurazione specifica le connessioni in ingresso sono normalmente bloccate.
Prova con
Code: [Select]
iptables -I INPUT -p udp --destination-port 1756 -j ACCEPT

Ho provato anche cosi', ma non e' cambiata la situazione...
Code: [Select]
$ sudo iptables -L INPUT
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     udp  --  anywhere             anywhere            udp dpt:1756
$
ecco l'ultima parte del log di aMule:
Code: [Select]
> 2009-07-09 01:59:12: Solo 1 contatto Kad disponibile, nodes.dat non scritto
 > 2009-07-09 01:59:12: Created Client UDP-Socket at port 1756
 > 2009-07-09 01:59:12: Letti 29 contatti Kad
 > 2009-07-09 05:26:58: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-07-09 05:26:58: Created Client UDP-Socket at port 1756
 > 2009-07-09 05:26:58: Letti 29 contatti Kad
 > 2009-07-09 06:29:00: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-07-09 06:29:00: Created Client UDP-Socket at port 1756
 > 2009-07-09 06:29:00: Letti 29 contatti Kad
 > 2009-07-09 07:11:03: Solo 1 contatto Kad disponibile, nodes.dat non scritto
 > 2009-07-09 07:11:03: Created Client UDP-Socket at port 1756
 > 2009-07-09 07:11:03: Letti 29 contatti Kad
 > 2009-07-09 08:53:28: Solo 2 contatti Kad disponibili, nodes.dat non scritto
 > 2009-07-09 08:53:28: Created Client UDP-Socket at port 1756
 > 2009-07-09 08:53:28: Letti 29 contatti Kad
 > 2009-07-09 10:13:42: Accettata nuova connessione esterna
 > 2009-07-09 10:13:42: Connessione al client: aMulecmd 2.2.5
 > 2009-07-09 10:13:42: Accesso consentito.

Cavoli che situazione strana... ???
Logged

iz0bbz

  • Hero Member
  • *****
  • Karma: 57
  • Offline Offline
  • Posts: 766
  • Gort! Klaatu barada nikto!
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #10 on: July 09, 2009, 12:13:50 PM »

Sì è abbastanza strano .
In effetti il firewall, con quelle impostazioni, è completamente aperto.
Rileggendo i vari log inviati, pare che almeno a tratti la rete kad funzioni, e poi muore.

Se sei sicuro del funzionamento del router come dici, non ho più altri consigli se non quello di controllare log e monitor di sitema per vedere se ci sono problemi a livello di risorse  - principalmente memoria. La rete Kad è impegnativa....
Logged

wodanymir

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
  • gne gne gne
Re: amuled 2.2.5 NON si connette alla rete KAD
« Reply #11 on: July 09, 2009, 06:25:08 PM »

Ciao!

non ho più altri consigli se non quello di controllare log e monitor di sitema per vedere se ci sono problemi a livello di risorse  - principalmente memoria. La rete Kad è impegnativa....
Potenzialmente potrebbe essere questo il problema
Code: [Select]
$ free -m -t
             total       used       free     shared    buffers     cached
Mem:           370        366          4          0         19        279
-/+ buffers/cache:         67        303
Swap:         9632          0       9632
Total:       10003        366       9637
$
sebbene ora
Code: [Select]
> 2009-07-09 15:07:39: Solo 1 contatto Kad disponibile, nodes.dat non scritto
 > 2009-07-09 15:07:39: Created Client UDP-Socket at port 1756
 > 2009-07-09 15:07:39: Letti 29 contatti Kad
 > 2009-07-09 15:18:36: Connesso alla rete Kad (firewalled)
 > 2009-07-09 16:10:02: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-07-09 16:10:02: Created Client UDP-Socket at port 1756
 > 2009-07-09 16:10:02: Letti 29 contatti Kad
 > 2009-07-09 17:09:53: Solo 3 contatti Kad disponibili, nodes.dat non scritto
 > 2009-07-09 17:09:53: Created Client UDP-Socket at port 1756
 > 2009-07-09 17:09:53: Letti 29 contatti Kad
 > 2009-07-09 17:19:02: Connesso alla rete Kad (ok)
 > 2009-07-09 18:22:09: Accettata nuova connessione esterna
 > 2009-07-09 18:22:09: Connessione al client: aMulecmd 2.2.5
 > 2009-07-09 18:22:09: Accesso consentito.
???

Posso affermare che aver dedicato una "valanga" di spazio per lo swap ai fini di aMule non serve a nulla?

Ancora grazie,
wo
Logged