aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule crashes after several hours of problem-free running  (Read 5470 times)

Atalanttore

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 25
aMule crashes after several hours of problem-free running
« on: September 08, 2009, 08:23:32 PM »

Hi

I'm using aMule 2.2.5 on Ubuntu 9.04.
I've experienced some aMule crashes since I have about 15 files in the download queue, but I don't know if the files in the queue have anything to do with the crashes. The fact is that aMule crashes after several hours of problem-free running.

So, here is the backtrace:
Quote
***@*******:~$ gdb amule
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
r(gdb) run
Starting program: /usr/bin/amule
[Thread debugging using libthread_db enabled]
[New Thread 0x7f062555b7e0 (LWP 9098)]
Initialising aMule 2.2.5 using wxGTK2 v2.8.9
Checking if there is an instance already running...
No other instances are running.
ListenSocket: Ok.
[New Thread 0x7f0619268950 (LWP 9103)]
HTTP download thread started
[New Thread 0x7f0616d41950 (LWP 9106)]
Loading temp files from /home/***/******.
Loading PartFile 20 of 20
All PartFiles Loaded.
Adding file /home/***/******/015.part.met to shares
Adding file /home/***/******/014.part.met to shares
Adding file /home/***/******/013.part.met to shares
Adding file /home/***/******/012.part.met to shares
Adding file /home/***/******/011.part.met to shares
Adding file /home/***/******/009.part.met to shares
Adding file /home/***/******/008.part.met to shares
Adding file /home/***/******/007.part.met to shares
Adding file /home/***/******/006.part.met to shares
Adding file /home/***/******/005.part.met to shares
Adding file /home/***/******/004.part.met to shares
Adding file /home/***/******/002.part.met to shares
Adding file /home/***/******/001.part.met to shares
[New Thread 0x7f0616540950 (LWP 9107)]
[Thread 0x7f0616540950 (LWP 9107) exited]
[New Thread 0x7f0615d3f950 (LWP 9108)]
Host: amule.sourceforge.net:80
URL: http://amule.sourceforge.net/lastversion
Response: 200 (Error: 0)
Download size: 6
HTTP download thread ended
[Thread 0x7f0619268950 (LWP 9103) exited]
Keyword for search: spam
Keyword for search: spam
Keyword for search: spam
[New Thread 0x7f0616540950 (LWP 18403)]
[Thread 0x7f0616540950 (LWP 18403) exited]
[New Thread 0x7f0616540950 (LWP 18585)]
[Thread 0x7f0616540950 (LWP 18585) exited]
[New Thread 0x7f0616540950 (LWP 20069)]
[Thread 0x7f0616540950 (LWP 20069) exited]
[New Thread 0x7f0616540950 (LWP 20157)]
[Thread 0x7f0616540950 (LWP 20157) exited]
Invalid Kad tag; type=0x84 name=

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f062555b7e0 (LWP 9098)]
0x000000000545dc10 in ?? ()

(gdb) bt
#0  0x000000000545dc10 in ?? ()
#1  0x00007f0623832686 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#2  0x00007f06218fe1cf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#3  0x00007f061fe1020a in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#4  0x00007f061fe138e0 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0x00007f061fe13dad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#6  0x00007f0621cb1bc7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x00007f0623831068 in wxEventLoop::Run ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#8  0x00007f06238ba57b in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#9  0x00007f0623152a8d in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#10 0x0000000000596789 in main (argc=1, argv=0x7fffad0a6a88)
    at ../../src/amule-gui.cpp:95

(gdb) bt full
#0  0x000000000545dc10 in ?? ()
No symbol table info available.
#1  0x00007f0623832686 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#2  0x00007f06218fe1cf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#3  0x00007f061fe1020a in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00007f061fe138e0 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x00007f061fe13dad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00007f0621cb1bc7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#7  0x00007f0623831068 in wxEventLoop::Run ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#8  0x00007f06238ba57b in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#9  0x00007f0623152a8d in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#10 0x0000000000596789 in main (argc=1, argv=0x7fffad0a6a88)
    at ../../src/amule-gui.cpp:95
No locals.

(gdb) thread apply all bt

Thread 5 (Thread 0x7f0615d3f950 (LWP 9108)):
#0  0x00007f062516856d in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#1  0x00007f06231ab4d9 in wxConditionInternal::WaitTimeout ()
   from /usr/lib/libwx_baseu-2.8.so.0
#2  0x00007f06231ac862 in wxSemaphoreInternal::WaitTimeout ()
   from /usr/lib/libwx_baseu-2.8.so.0
#3  0x00000000006984d9 in CTimerThread::Entry (this=0x2cf4da0)
    at ../../src/Timer.cpp:64
#4  0x00007f06231aca4a in wxThreadInternal::PthreadStart ()
   from /usr/lib/libwx_baseu-2.8.so.0
#5  0x00007f06251643ba in start_thread () from /lib/libpthread.so.0
#6  0x00007f0622461fcd in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f0616d41950 (LWP 9106)):
#0  0x00007f062516b7e1 in nanosleep () from /lib/libpthread.so.0
#1  0x00007f06231b26fc in wxMicroSleep () from /usr/lib/libwx_baseu-2.8.so.0
#2  0x0000000000537e8c in UploadBandwidthThrottler::Entry (this=0x344e800)
    at ../../src/UploadBandwidthThrottler.cpp:324
#3  0x00007f06231aca4a in wxThreadInternal::PthreadStart ()
   from /usr/lib/libwx_baseu-2.8.so.0
---Type <return> to continue, or q <return> to quit---
#4  0x00007f06251643ba in start_thread () from /lib/libpthread.so.0
#5  0x00007f0622461fcd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f062555b7e0 (LWP 9098)):
#0  0x000000000545dc10 in ?? ()
#1  0x00007f0623832686 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#2  0x00007f06218fe1cf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#3  0x00007f061fe1020a in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#4  0x00007f061fe138e0 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0x00007f061fe13dad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#6  0x00007f0621cb1bc7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x00007f0623831068 in wxEventLoop::Run ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#8  0x00007f06238ba57b in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#9  0x00007f0623152a8d in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#10 0x0000000000596789 in main (argc=1, argv=0x7fffad0a6a88)
    at ../../src/amule-gui.cpp:95
(gdb)


Regards,
Atalanttore
« Last Edit: September 09, 2009, 07:21:20 PM by Atalanttore »
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: aMule crashes after several hours of problem-free running
« Reply #1 on: September 08, 2009, 09:15:17 PM »

Can you try running it with debug symbols?
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Atalanttore

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 25
Re: aMule crashes after several hours of problem-free running
« Reply #2 on: September 09, 2009, 07:32:00 PM »

How can I do that?

The backtraces manual isn't very helpful if you don't use Gentoo Linux. In my case, I'm using Ubuntu.


Regards,
Atalanttore
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule crashes after several hours of problem-free running
« Reply #3 on: September 09, 2009, 08:15:48 PM »

Code: [Select]
(gdb) bt
#0  0x000000000545dc10 in ?? ()
#1  0x00007f0623832686 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#2  0x00007f06218fe1cf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#3  0x00007f061fe1020a in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#4  0x00007f061fe138e0 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0x00007f061fe13dad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#6  0x00007f0621cb1bc7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x00007f0623831068 in wxEventLoop::Run ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#8  0x00007f06238ba57b in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0

Is this a 64-bit system?. If so, upgrading to Ubuntu 9.10 will likely solve your problem.
Logged

delta9thc

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule crashes after several hours of problem-free running
« Reply #4 on: September 09, 2009, 09:41:45 PM »

How can I do that?

The backtraces manual isn't very helpful if you don't use Gentoo Linux. In my case, I'm using Ubuntu.


Regards,
Atalanttore

sudo apt-get install gdb
gdb /usr/bin/amule   
(gdb) run
 
 :P
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: aMule crashes after several hours of problem-free running
« Reply #5 on: September 09, 2009, 10:06:16 PM »

He already has gdb installed if you bother to look - question was how to get an executable with debug symbols.  :P :P

I think you can simply install amule-dbg from Festor's Ubuntu packages.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

^marcell^

  • Developer
  • Hero Member
  • *****
  • Karma: 28
  • Offline Offline
  • Posts: 524
Re: aMule crashes after several hours of problem-free running
« Reply #6 on: September 10, 2009, 11:59:25 AM »

You can compile aMule with --enable-debug. Check this wiki. ;)
Logged

Atalanttore

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 25
Re: aMule crashes after several hours of problem-free running
« Reply #7 on: September 10, 2009, 06:32:59 PM »

I think you can simply install amule-dbg from Festor's Ubuntu packages.

Don't know what you mean...
I have installed amule-dbg before I made this backtrace (see attachment for screenshot).


Regards,
Atalanttore
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: aMule crashes after several hours of problem-free running
« Reply #8 on: September 10, 2009, 10:53:59 PM »

Hmm, we'd have to ask Festor that question, but I'm afraid he's taken a longer vacation.
Just compile it yourself.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule crashes after several hours of problem-free running
« Reply #9 on: September 21, 2009, 07:34:02 PM »

Atalanttore, this is a bug in libX11 for 64bits systems, exposed by aMule's high X usage. This is fixed in

http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=da6bbca07c796c69172a649405474f03bee66754

so you need a libX11 >= 1.2.0

If you install the libx11-dbg packages you will see the complete picture. Just upgrade to a new libX11 or apply the patch. If you don't do this, aMule will crash every 3 or 4 days on a typical usage.

Regards.
Logged

Atalanttore

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 25
Re: aMule crashes after several hours of problem-free running
« Reply #10 on: September 21, 2009, 07:47:45 PM »

Thanks for your explanation of the bug :)


Regards,
Atalanttore
Logged