aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule crash in Ubuntu 9.10 (new install)  (Read 3688 times)

Oronzo

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
aMule crash in Ubuntu 9.10 (new install)
« on: November 04, 2009, 08:16:56 PM »

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.6 using wxGTK2 v2.8.10
Running on: Linux 2.6.31-14-generic i686


** (amule:7688): CRITICAL **: murrine_style_draw_box_gap: assertion `height >= -1' failed
[2] ?? in amule [0x80849f9]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x6acba6]
[4] ?? in [0x9c1400]
[5] g_slice_free1 in /lib/libglib-2.0.so.0[0x11a5faf]
[6] ?? in /usr/lib/libgobject-2.0.so.0 [0xbf2655]
[7] g_datalist_id_set_data_full in /lib/libglib-2.0.so.0[0x1171e73]
[8] g_object_notify in /usr/lib/libgobject-2.0.so.0[0xbf4de9]
[9] gdk_window_set_cursor in /usr/lib/libgdk-x11-2.0.so.0[0xb84fea]
[10] wxWindow::OnInternalIdle() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xf373e9]
[11] wxTopLevelWindowGTK::OnInternalIdle() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xf2d9db]
[12] wxFrameBase::OnInternalIdle() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xfea0ed]
[13] wxFrame::OnInternalIdle() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xf84c9e]
[14] wxAppBase::SendIdleEvents(wxWindow*, wxIdleEvent&) in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xfb5d75]
[15] wxAppBase::ProcessIdle() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xfb6021]
[16] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0xf09423]
[17] ?? in /lib/libglib-2.0.so.0 [0x11850f1]
[18] g_main_context_dispatch in /lib/libglib-2.0.so.0[0x1186e78]
[19] ?? in /lib/libglib-2.0.so.0 [0x118a720]
[20] g_main_loop_run in /lib/libglib-2.0.so.0[0x118ab8f]
[21] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x74274a9]
[22] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xf22c78]
[23] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xfb5e3e]
[24] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xfb5a31]
[25] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x6437aa]
[26] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0x643987]
[27] ?? in amule [0x8158d8b]
[28] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xa21b56]
[29] ?? in amule [0x8083841]
Logged

Oronzo

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule crash in Ubuntu 9.10 (new install)
« Reply #1 on: November 04, 2009, 10:02:26 PM »

I got another error:


[2] ?? in amule [0x80849f9]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xcb7ba6]
[4] ?? in [0xd50400]                                               
[5] g_slice_free1 in /lib/libglib-2.0.so.0[0x4330faf]             
[6] gdk_region_destroy in /usr/lib/libgdk-x11-2.0.so.0[0x6eb5b0]   
[7] wxRegionRefData::~wxRegionRefData() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x904c74]
[8] wxObject::UnRef() in /usr/lib/libwx_baseu-2.8.so.0[0xc6302d]                       
[9] wxRegion::~wxRegion() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x9044f8]             
[10] wxWindowDC::DoBlit(int, int, int, int, wxDC*, int, int, int, bool, int, int) in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x8f9583]
[11] ?? in amule [0x81966e2]                                                                                                     
[12] ?? in amule [0x819b3c1]                                                                                                     
[13] ?? in amule [0x82657d5]                                                                                                     
[14] wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const in /usr/lib/libwx_baseu-2.8.so.0[0xc14a9f]
[15] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xcb3379]
[16] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0xcb4424]                                   
[17] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xcb4523]                                                     
[18] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xcb44b9]                                                     
[19] wxScrollHelperEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xa56026]                                     
[20] wxWindow::GtkSendPaintEvents() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x915652]                                                       
[21] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x915c18]
[22] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0x6073504]
[23] g_closure_invoke in /usr/lib/libgobject-2.0.so.0[0x4f7d072]
[24] ?? in /usr/lib/libgobject-2.0.so.0 [0x4f927a8]
[25] g_signal_emit_valist in /usr/lib/libgobject-2.0.so.0[0x4f939b8]
[26] g_signal_emit in /usr/lib/libgobject-2.0.so.0[0x4f93fb6]
[27] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0x618f9fe]
[28] gtk_main_do_event in /usr/lib/libgtk-x11-2.0.so.0[0x606d220]
[29] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff1d4]
[30] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[31] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[32] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[33] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[34] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[35] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[36] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[37] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[38] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[39] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[40] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[41] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[42] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[43] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[44] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[45] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6ff183]
[46] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x722734]
[47] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6f687f]
[48] gdk_window_process_all_updates in /usr/lib/libgdk-x11-2.0.so.0[0x6f883f]
[49] ?? in /usr/lib/libgtk-x11-2.0.so.0 [0x5fdf37f]
[50] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0x6d4f78]
[51] ?? in /lib/libglib-2.0.so.0 [0x43100f1]
[52] g_main_context_dispatch in /lib/libglib-2.0.so.0[0x4311e78]
[53] ?? in /lib/libglib-2.0.so.0 [0x4315720]
[54] g_main_loop_run in /lib/libglib-2.0.so.0[0x4315b8f]
[55] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x606d4a9]
[56] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x8fec78]
[57] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x991e3e]
[58] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x991a31]
[59] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xc4e7aa]
[60] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xc4e987]
[61] ?? in amule [0x8158d8b]
[62] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xf46b56]
[63] ?? in amule [0x8083841]
Logged

^marcell^

  • Developer
  • Hero Member
  • *****
  • Karma: 28
  • Offline Offline
  • Posts: 524
Re: aMule crash in Ubuntu 9.10 (new install)
« Reply #2 on: November 10, 2009, 09:07:44 PM »

The problem here is that "[61] ?? in amule [0x8158d8b]" tells us absolutely nothing except the place aMule was inside your memory when the crash occured. :D
Please read the wiki about how to produce a useful backtrace.
Logged

nicola1997

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
SOLVED - Re: aMule crash in Ubuntu 9.10 (new install) -
« Reply #3 on: November 10, 2009, 11:07:10 PM »

1. remove the provided package
sudo apt-get remove amule

2. Install apt-build
sudo apt-get install apt-build

3. compile and install

sudo apt-build  install amule

Whait some time...and then amule working fine!
Tested on kubuntu 9.10 fresh install

Nic
Logged