aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 ... 31 32 [33] 34 35 ... 37

Author Topic: RRM's epic struggle for a better aMule on high-speed connections  (Read 82360 times)

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #480 on: February 16, 2011, 10:14:06 AM »

Ok :)

Code: [Select]
rrm@rrm-desktop:~/temp-amule/wxWidgets-2.8.11$ cat kry.patch | patch -p1
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: src/gtk/gsockgtk.cpp
|===================================================================
|--- src/gtk/gsockgtk.cpp (revision 66879)
|+++ src/gtk/gsockgtk.cpp (working copy)
--------------------------
File to patch:

because there is no gsockgtk.cpp nor gsocket.cpp in my system.

Code: [Select]
File to patch: include/wx/unix/gsockunx.h
patching file include/wx/unix/gsockunx.h
Hunk #1 succeeded at 17 with fuzz 2 (offset -164 lines).
Hunk #2 FAILED at 380.
Hunk #3 FAILED at 423.
Hunk #4 FAILED at 1688.
3 out of 4 hunks FAILED -- saving rejects to file include/wx/unix/gsockunx.h.rej
can't find file to patch at input line 102
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: include/wx/unix/gsockunx.h
|===================================================================
|--- include/wx/unix/gsockunx.h (revision 66879)
|+++ include/wx/unix/gsockunx.h (working copy)
--------------------------
File to patch:

I dont know if its okay now...
I guess not, because in the gsockunx.h it still says:
Code: [Select]
  char *m_gui_dependent;

};

#ifdef __cplusplus

So, im going to patch manually, just to make sure.
Okay, but after calling
Quote from: btkaos
$ ./configure --prefix=~/temp-amule/build/ --enable-debug

i get this:
Code: [Select]
configure: error: expected an absolute directory name for --prefix: ~/temp-amule/build/
rrm@rrm-desktop:~/temp-amule/wxWidgets-2.8.11$

So, shouldnt it be:
Code: [Select]
$ ./configure --prefix=/home/rrm/temp-amule/build/ --enable-debug

Let me try...

Code: [Select]
configure: WARNING: system png library not found or too old, will use built-in instead
checking for jpeglib.h... no
configure: WARNING: system jpeg library not found, will use built-in instead
checking for tiffio.h... no
configure: WARNING: system tiff library not found, will use built-in instead
checking for expat.h... no
configure: WARNING: system expat library not found, will use built-in instead
checking for mspack.h... no
checking for GTK+ version...
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

The config.log only contains yesterday's pre-stu configuration, btw.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #481 on: February 16, 2011, 12:59:44 PM »

Oh sorry I see, you must use patch -p0

The exact line is

Code: [Select]
$ patch -p0 < kry.patch

Delete the wxWidget directory, and try again.

Use absolute paths, I wrote ~ because I didn't know your username.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #482 on: February 16, 2011, 01:00:20 PM »

Indeed see my ouput:

Code: [Select]
~/tmp/wx/wxWidgets-2.8.11$ patch -p0 < kry.patch
patching file src/gtk/gsockgtk.cpp
patching file src/unix/gsocket.cpp
patching file include/wx/unix/gsockunx.h
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #483 on: February 16, 2011, 01:43:14 PM »

Yes, thats the output im getting, but:
Code: [Select]
configure: WARNING: system png library not found or too old, will use built-in instead
checking for jpeglib.h... no
configure: WARNING: system jpeg library not found, will use built-in instead
checking for tiffio.h... no
configure: WARNING: system tiff library not found, will use built-in instead
checking for expat.h... no
configure: WARNING: system expat library not found, will use built-in instead
checking for mspack.h... no
checking for GTK+ version...
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #484 on: February 16, 2011, 03:05:15 PM »

Hi RRM. First make sure you did patch wx right.

Then you have to install some development libraries with aptitude. Try

Code: [Select]
sudo apt-get build-dep libwxgtk2.8-0

You may remove those packages when testing is finished.

Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #485 on: February 16, 2011, 03:55:23 PM »

Quote
sudo apt-get build-dep libwxgtk2.8-0

Thank you, that helps.

Quote
$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib amule

Ok, that worked well, but:
rrm@rrm-desktop:~/temp-amule/wxWidgets-2.8.11$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib amule
 2011-02-16 15:42:13: amuleAppCommon.cpp(331): Initialising aMule SVN compiled with wxGTK2 v2.8.10 (Debugging) (Snapshot: rev. 10446)

Quote
$ ldd amule #

ldd: ./amule: No such file or directory
rrm@rrm-desktop:~$

Quote
$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib ldd amule

ldd: ./amule: No such file or directory
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #486 on: February 16, 2011, 04:18:30 PM »

Since we have to run the non-stock version ("bad aMule")
I guess i have to stow that one of course:
$ cd /usr/local/stow
$ sudo stow -D amule-opt
$ sudo stow amule-pre-stu
$ cd
$ cd temp-amule/wxWidgets-2.8.11
$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib amule

Initialising aMule SVN compiled with wxGTK2 v2.8.10 (Debugging) (Snapshot: rev. 10446)

but then i get this:
Code: [Select]
EncryptedStreamSocket.cpp(441): assert "m_nReceiveBytesWanted > 0" failed in Negotiate().
and i click "continue"
Many connection attempts, and losses.
and i keep connecting, and losing.
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #487 on: February 16, 2011, 05:06:06 PM »

This mule keeps on losing the connection.
Nothing happens.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #488 on: February 16, 2011, 05:31:13 PM »


Quote
$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib ldd amule

ldd: ./amule: No such file or directory


Sorry it should be

Code: [Select]
$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib ldd /usr/local/bin/amule
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #489 on: February 16, 2011, 05:42:25 PM »

$ cd temp-amule/wxWidgets-2.8.11
$ LD_LIBRARY_PATH=/home/rrm/temp-amule/build/lib amule

Initialising aMule SVN compiled with wxGTK2 v2.8.10 (Debugging) (Snapshot: rev. 10446)


Umm, see the problem, you have mismatch between the library compiled 2.8.10 and the one you are using.
Are you using an old Ubuntu version. I did assume you were using current Ubuntu.

In that case, compile wx 2.8.11 as we said. Make sure the patch is applied and let it install in ~/temp-amule/build/

Then, do a fresh checkout of amule:

Code: [Select]
$ sudo aptitude install subversion
$ svn co http://amule.googlecode.com/svn/trunk amule-pre-stu
$ cd amule-pre-stu
$ sudo aptitude install autoconf automake autopoint
$ ./autogen.sh
Then modify EMSocket.cpp as we agreed. The above could be different in old Ubuntu versions

Configure amule then as follows
Code: [Select]
./configure --prefix=/usr/local/stow/amule-pre-stu --enable-debug --enable-optimize --with-wxdebug --with-wx-prefix=/home/rrm/temp-amule/build

This way you should have a good amule under /usr/local/stow/amule-pre-stu to test.

Go RRM, we are almost there, thanks for not giving up.
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #490 on: February 16, 2011, 06:50:28 PM »

Thank you, Bill.
Yes, i could never boot the live CDs (or via USB etc) for 10.04 and 10.10
Upgrading using update manager, i could not boot at all.
So i had to return to 9.10 (many ppl experienced the same)

Quote from: btkaos
compile wx 2.8.11 as we said. Make sure the patch is applied and let it install in ~/temp-amule/build/

All this already has been done, right?

Quote
Then, do a fresh checkout of amule

done.

Quote
Then modify EMSocket.cpp as we agreed.

The one in home/rrm/tmp/amule/src
right?
done.

Quote
./configure --prefix=/usr/local/stow/amule-pre-stu --enable-debug --enable-optimize --with-wxdebug --with-wx-prefix=/home/rrm/temp-amule/build

I get this:

    "checking for wxWidgets version >= 2.8.8 (--debug=yes --unicode=yes)... no
    configure: error:"
Code: [Select]
    The requested wxWidgets build couldn't be found.
   
    The configuration you asked for aMule requires a wxWidgets
    build with the following settings:
        --debug=yes --unicode=yes
    but such build is not available.

    To see the wxWidgets builds available on this system, please use
    'wx-config --list' command. To use the default build, returned by
    'wx-config --selected-config', use the options with their 'auto'
    default values.

    If you still get this error, then check that 'wx-config' is
    in path, the directory where wxWidgets libraries are installed
    (returned by 'wx-config --libs' command) is in LD_LIBRARY_PATH
    or equivalent variable and wxWidgets version is 2.8.8 or above.
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #491 on: February 16, 2011, 07:16:38 PM »

$ wx-config --list

Code: [Select]
    Default config is gtk2-unicode-release-2.8

  Default config will be used for output

  Alternate matches:
    base-unicode-debug-2.8
    base-unicode-release-2.8
    gtk2-unicode-debug-2.8

The installed libwxgtk2.8 (0, dbg, dev) is version 2.8.10.1-0ubuntu1
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #492 on: February 16, 2011, 07:23:02 PM »

Yes, i could never boot the live CDs (or via USB etc) for 10.04 and 10.10
Upgrading using update manager, i could not boot at all.
So i had to return to 9.10 (many ppl experienced the same)
Weird thing :( Hope you are luckier with 11.04 Anyways solving boot issues is not hard in Linux.
Quote
Quote from: btkaos
compile wx 2.8.11 as we said. Make sure the patch is applied and let it install in ~/temp-amule/build/

All this already has been done, right?
Yes, but maybe we have to do it again, see below.

Quote
Quote
Then modify EMSocket.cpp as we agreed.

The one in home/rrm/tmp/amule/src
right?
done.
If you typed my command exactly the checkout would be in the amule-pre-stu directory.
Quote
Quote
./configure --prefix=/usr/local/stow/amule-pre-stu --enable-debug --enable-optimize --with-wxdebug --with-wx-prefix=/home/rrm/temp-amule/build

I get this:

    "checking for wxWidgets version >= 2.8.8 (--debug=yes --unicode=yes)... no
    configure: error:"
Umm, maybe you need to pass --enable-unicode to wx configure.
So got to the directory wxWidgets-2.8.11 and type
Code: [Select]
./configure --prefix=~/temp-amule/build/ --enable-debug --enable-unicode
make clean && make install
Also make sure the patch was applied allright. Did you have more success when using patch -p0?

Once the wx build finishes, go to the fresh svn checkout and configure amule again, let's see if we are luckier this time around :)
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #493 on: February 16, 2011, 08:18:35 PM »

Quote
Anyways solving boot issues is not hard in Linux.

ha ha, okay, then i will ask for your help in the Ubuntu forums...  ;D

Quote
got to the directory wxWidgets-2.8.11 and type
Code: [Select]
./configure --prefix=~/temp-amule/build/ --enable-debug --enable-unicode
make clean && make install

./configure --prefix=/home/rrm/temp-amule/build/ --enable-debug --enable-unicode
make clean && make install
right?
done

Quote
Also make sure the patch was applied allright. Did you have more success when using patch -p0?

Yes.

Quote
Once the wx build finishes, go to the fresh svn checkout and configure amule again, let's see if we are luckier this time around :)

wx build has finished.
reconfiguring amule
Code: [Select]
Libraries aMule will use to build:
                             wxWidgets             2.8.11 (gtk2,debug,shared)
                             crypto++              5.6.0 (installed, in /usr)
                             libupnp               1.6.6
                             libintl               system
                             zlib                  1.2.3.3
make and install
done.
gdb amule
Initialising aMule SVN compiled with wxGTK2 v2.8.11 (Debugging) (Snapshot: rev. 10448)
seems to run fine...


Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: RRM's epic struggle for a better aMule on high-speed connections
« Reply #494 on: February 17, 2011, 12:20:18 AM »

seems to run fine...
Well let's see what happens. Thank you RRM, you are a fantastic tester.

By the way could you post the boot information version number to check?
Logged
Pages: 1 ... 31 32 [33] 34 35 ... 37