aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule 2.2.6 crashes on Ubuntu 10.10  (Read 6035 times)

Vax

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
aMule 2.2.6 crashes on Ubuntu 10.10
« on: December 14, 2010, 10:03:34 PM »

Hello,
I just started using aMule on Ubuntu 10.10 and I often crash problems.

This is the backtrace:

** (amule:2601): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

** (amule:2601): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.6 using wxGTK2 v2.8.11
Running on: Linux 2.6.35-23-generic i686


** (amule:2601): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

** (amule:2601): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed
[2] ?? in amule[0x80800b9]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x879896]
[4] ?? in [0xe65400]
[5] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xf8ace4]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0[0x291e62]
[7] ?? in /lib/libglib-2.0.so.0[0x5543e5b]
[8] g_main_context_dispatch in /lib/libglib-2.0.so.0[0x54fc855]
[9] ?? in /lib/libglib-2.0.so.0[0x5500668]
[10] g_main_loop_run in /lib/libglib-2.0.so.0[0x5500ba7]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x30ce1d9]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xf89568]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x101c63e]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x101c221]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x8106d3]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0x8108b7]
[17] ?? in amule[0x815636b]
[18] __libc_start_main in /lib/libc.so.6[0xb24ce7]
[19] ?? in amule[0x807f061]


--------------------------------------------------------------------------------
Aborted


The PC has installed:
- Ubuntu 10.10 (maverick)
- Kernel Linux 2.6.35-23-generic
- GNOME 2.32.0
Processor:
- Intel 2 Duo T7200

Thanks for your help.
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #1 on: December 20, 2010, 06:08:37 PM »

The backtrace aMule reports when it crashes is usually not usefull to track down the bug.
Please do not post those backtraces. Instead use GDB to obtain detailed and useful backtraces.
The document bellow is a guideline to using GDB with aMule for obtaining backtraces.

http://wiki.amule.org/index.php/Backtraces
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #2 on: December 20, 2010, 09:35:35 PM »

Revert your kernel to 2.6.35-22 . That should fix it.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Olhado

  • Approved Newbie
  • *
  • Karma: 4
  • Offline Offline
  • Posts: 26
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #3 on: December 25, 2010, 09:40:24 AM »

I've had the same problem and it persisted (or, in fact, seemed to get worse) when I updated to kernel 2.6.35-24 (the current kernel in Ubuntu Maverick). I have a feeling the crashes were connected either with the size of the size of the downloaded files or the number of sources, but I'm not sure.

Anyway, I wanted to ask if this is more of an aMule problem or an Ubuntu problem and how long will it take before we can update our kernels again? Is it possible that it's going to get fixed in another aMule version or do we have to wait until Ubuntu developers do something about it?
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #4 on: December 25, 2010, 06:37:28 PM »

We have no idea yet what could be the problem. I'm suspecting a subtle change in the networking code that causes wxWidget's socket layer to leak. But that's pure speculation.
Feel free to complain with the Ubuntu guys. They introduced the breaking change after all, whatever it is. However, if our app is the only one with problems, our chances of a reaction are thin.  :(
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Olhado

  • Approved Newbie
  • *
  • Karma: 4
  • Offline Offline
  • Posts: 26
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #5 on: December 25, 2010, 08:01:09 PM »

Feel free to complain with the Ubuntu guys. They introduced the breaking change after all, whatever it is. However, if our app is the only one with problems, our chances of a reaction are thin.  :(
It doesn't hurt to try, so I'll notify them :)
Logged

synth

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #6 on: March 24, 2011, 06:57:13 AM »

On my pc amule crashes randomly (say in an hour or two after being started) with errors like
** (amule:2068): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed
flooding the console output. No matter what "max sources for file" value is.
Last night I purposely turned off any special effects i.e. compiz and amule pretty well survived through the night.
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #7 on: March 24, 2011, 09:53:15 PM »

The clearlooks_style_draw_box_gap is harmless and fixed in SVN.
For a patch for out of memory crashes see http://forum.amule.org/index.php?topic=18543.0 .
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

synth

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule 2.2.6 crashes on Ubuntu 10.10
« Reply #8 on: March 24, 2011, 10:39:25 PM »

I'm ummm a little bit unexperienced in patching something. but anyway thanks for pointing to the post. :)
Logged