aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amule 2.2.6 crash on ubuntu 11.04  (Read 1768 times)

artlover

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
amule 2.2.6 crash on ubuntu 11.04
« on: June 26, 2011, 03:23:36 AM »

amule 2.2.6 crash on ubuntu 11.04, and sometimes when I click on the amule icon, it doesn't appear but I can find the process in system monitor , below is the crash info, I'm a Chinese user and lot of download file contains Chinese character , I'm not sure if it is the root cause .

(amule:3146): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/giounix.c:411Error while getting flags for FD: Bad file descriptor (9)


--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.6 using wxGTK2 v2.8.11
Running on: Linux 2.6.38-8-generic i686

[2] ?? in amule[0x8082651]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xa2d256]
[4] ?? in [0x4a3400]
[5] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2670e4]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0[0xe330a1]
[7] ?? in /lib/i386-linux-gnu/libglib-2.0.so.0[0x358a78b]
[8] g_main_context_dispatch in /lib/i386-linux-gnu/libglib-2.0.so.0[0x3542aa8]
[9] ?? in /lib/i386-linux-gnu/libglib-2.0.so.0[0x3543270]
[10] g_main_loop_run in /lib/i386-linux-gnu/libglib-2.0.so.0[0x354392b]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x1085c39]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x265e08]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2eebce]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x2ee511]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x9cdc7b]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0x9cdd27]
[17] ?? in amule[0x81510cb]
[18] __libc_start_main in /lib/i386-linux-gnu/libc.so.6[0xc97e37]
[19] ?? in amule[0x8081c91]


--------------------------------------------------------------------------------
Aborted
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: amule 2.2.6 crash on ubuntu 11.04
« Reply #1 on: June 26, 2011, 11:30:00 AM »

Please try the 2.3.1.rc1 .
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon