aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: autogen.sh of aMule-2.2.6 doesn't produce a valid configure script?  (Read 1700 times)

Bill Lee

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2

I am doing further development based on aMule-2.2.6, and I have changed some autoconf & automake config. When I run the autogen.sh script, it produces a configure script without any warning. But the configure script has syntax error. And then I try to run the autogen.sh in original aMule-2.2.6 tarball, but it still produces the same error. Here's the end of configure output:
Quote
...
checking for the --with-toolkit option... will be automatically detected
checking for the --with-wxshared option... will be automatically detected
checking for the --with-wxdebug option... will be automatically detected
checking for the --with-wxversion option... will be automatically detected
checking for wx-config... /usr/bin/wx-config
checking for wxWidgets version >= 2.8.0 (--unicode=yes)... yes (version 2.8.10)
checking for wxWidgets static library... no
checking if wxWidgets was built in DEBUG mode... no
checking if wxWidgets was built in STATIC mode... no
checking which wxWidgets toolkit was selected... gtk2
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
./configure: line 8571: syntax error near unexpected token `{'
./configure: line 8571: `fi      { $as_echo "$as_me:${as_lineno-$LINENO}: result: $result$resultstr" >&5'
I am using Ubuntu 10.04.
GNU Autoconf version: 2.65; GNU Automake version: 1.11.1
I wonder what is wrong. Thanks.
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2674
Re: autogen.sh of aMule-2.2.6 doesn't produce a valid configure script?
« Reply #1 on: July 13, 2011, 02:12:39 PM »

1) You'd better base your development on current development version, sources available for free: Subversion or git

2) Your problem is most likely caused by a superfluous 'dnl' command in one of the m4 source files, that makes newer autotools behave different than older ones. I can't tell you by heart which one is the trouble-maker, but as far as I know it's already fixed in the development version.
Logged
concordia cum veritate

Bill Lee

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: autogen.sh of aMule-2.2.6 doesn't produce a valid configure script?
« Reply #2 on: July 13, 2011, 05:19:20 PM »

Thank you for your suggestions.
I am just adding DLP support to aMule, and amule.org has said that DLP will not be accepted. Since a stable aMule with DLP is quite necessary for users in China, I just want to extend a stable release instead of a development version. I will try the aMule 2.3.1 RC1.
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2674
Re: autogen.sh of aMule-2.2.6 doesn't produce a valid configure script?
« Reply #3 on: July 13, 2011, 09:47:37 PM »

I said to use the development version because that will soon become the next stable version, so your work will already be done for 2.3.1.
Logged
concordia cum veritate