aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: Compilar amule para actualizarlo a la última SVN.  (Read 7822 times)

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Compilar amule para actualizarlo a la última SVN.
« on: September 11, 2011, 11:09:28 PM »

Mi sistema operativo es Linux Mint Katya, una variante de Ubuntu 11.04. Tengo instalado aMule 2.2.6, que siempre me ha dado problemas, aunque lo he reinstalado varias veces. Quisiera probar la última SVN para ver si se me soluciona alguno, pero soy demasiado torpe para compilarlo. Intento seguir las instrucciones de la wiki y no consigo otra cosa que llenar el ordenador de archivos inútiles que no me funcionan. Seeguro que hago algo mal de base, pero no sé qué es. Ojalá me podáis ayudar paso a paso y yo iré consultando los comentarios que me haga el terminal. Muchas gracias.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #1 on: September 12, 2011, 12:30:14 AM »

Mi sistema operativo es Linux Mint Katya, una variante de Ubuntu 11.04. Tengo instalado aMule 2.2.6, que siempre me ha dado problemas, aunque lo he reinstalado varias veces. Quisiera probar la última SVN para ver si se me soluciona alguno, pero soy demasiado torpe para compilarlo. Intento seguir las instrucciones de la wiki y no consigo otra cosa que llenar el ordenador de archivos inútiles que no me funcionan. Seeguro que hago algo mal de base, pero no sé qué es. Ojalá me podáis ayudar paso a paso y yo iré consultando los comentarios que me haga el terminal. Muchas gracias.
Ok primero descarga wx-widgest 2.8.12

Luego  escribe 'sudo apt-get build-dep libwxgtk2.8-0 amule'

Una vez tengas el wx widgets crea un directorio temporal, y lo descomprimes ahí.

Dentro del directorio tienes que poner ./configure y luego make. No hagas make install

Luego te descargas la rc de amule, la descomprimes y pones ./configure --with-wxdir=$donde hayas descomprimido las wx, pones make, y deberías poder ejecutar amule como ./src/amule

Cualquier cosa ya nos vas contando.
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #2 on: September 12, 2011, 01:52:11 AM »

Después de ejecutar sudo apt-get build-dep libwxgtk2.8-0 amule, el terminal me responde que no se puede encontrar un paquete de fuentes para  wxwidgets2.8

¿Cómo debo poner ./configure y luego make dentro del directorio?.

Tengo wxwidgets2.8 descargado y descomprimido en la carpeta de bajadas. ¿Qué debo hacer allí?.

Todo eso lo he estado haciendo con el amule funcionando. ¿Debía pararlo?.

¿Donde puedo encontrar la rc de amule?. No encuentro de dóndde descargarla.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #3 on: September 12, 2011, 03:00:46 AM »

Después de ejecutar sudo apt-get build-dep libwxgtk2.8-0 amule, el terminal me responde que no se puede encontrar un paquete de fuentes para  wxwidgets2.8
¿Umm, puedes copiar el error exacto? Es la primera vez que trato con Linux Mint.
Quote
¿Cómo debo poner ./configure y luego make dentro del directorio?.
Tengo wxwidgets2.8 descargado y descomprimido en la carpeta de bajadas. ¿Qué debo hacer allí?.
Debes extraerlo a una carpeta nueva (la que tu quieras) Eso lo puedes hacer con el gestor gráfico, da igual.

Luego te vas con el terminal a dicha carpeta y pones
Code: [Select]
$ ./configure
$ make
tal cual. Si te da algún problema lo copias aquí.
Quote
Todo eso lo he estado haciendo con el amule funcionando. ¿Debía pararlo?.
No para nada, de hecho vamos a instalar el nuevo amule aparte, no tocaremos el linux mint.
La rc está en la página prinicipal de amule
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #4 on: September 12, 2011, 07:31:20 AM »

Perdón, me daba el error porqué no descargué wxwidgets2.8 sino wxwidgets2.9.1. No encuentro de dónde descargar el 2.8 y no está en Synaptic.

Por favor, escríbeme la ruta a la carpeta porqué siempre cambio algun signo o espacio y me pierdo en los directorios. Podriamos llamarla prov, por ejemplo.


Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #5 on: September 12, 2011, 08:22:45 AM »

Perdón, me daba el error porqué no descargué wxwidgets2.8 sino wxwidgets2.9.1. No encuentro de dónde descargar el 2.8 y no está en Synaptic.
Tienes que descargarlo de la página de wxwidgets, luego lo descomprimes donde te venga bien y ejecutas el configure, make.

http://www.wxwidgets.org/downloads/#latest_stable

Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #6 on: September 12, 2011, 08:39:24 AM »

Bueno, sigo sin encontrar la descarga que me indicas, por lo cual entiendo que ha sido substituída por la nueva versión  que tengo descargada y que funcionará igual, haciendo las modificaciones en el nombre. Así que ejecuto la orden con el nombre cambiado y el resultado es idéntico. Te copio la respuesta exacta que me da el terminal, sin traducir ni nada:

Quote
S'està llegint la llista de paquets... Fet
S'està construint l'arbre de dependències       
S'està llegint la informació de l'estat... Fet
E: No es pot trobar un paquet de fonts per a libwxgtk2.9-1

¿Alguna sugerencia?.
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #7 on: September 12, 2011, 10:28:58 AM »

Por probar, he descomprimido la rc de amule en la carpeta .amule y he reiniciado, para ver si se actualizaba. Ahora no se pone en marcha. Si lo intento desde el terminal, me responde:

Quote
$ amule
amule: error while loading shared libraries: libbfd-2.20.so: cannot open shared object file: No such file or directory

¿Es grave?. Tengo que reinstalarlo perdiendo la configuración, descargas, etc.?.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #8 on: September 12, 2011, 04:17:50 PM »

Por probar, he descomprimido la rc de amule en la carpeta .amule y he reiniciado, para ver si se actualizaba. Ahora no se pone en marcha. Si lo intento desde el terminal, me responde:

Quote
$ amule
amule: error while loading shared libraries: libbfd-2.20.so: cannot open shared object file: No such file or directory

¿Es grave?. Tengo que reinstalarlo perdiendo la configuración, descargas, etc.?.
No grave no es, la verdad no sé que has hecho, no tiene nada que ver la carpeta .amule con todo los demás, si te la has cargado pues pierdes la configuración, no las descargas. A ver, vayamos por partes. primero desinstala en synaptic amule y wx y quita cualquier fuente rara que tengas. Luego lo vuelves a instalar tal y como viene por defecto en Mint.

 Tienes que usar wx-2.8.12, esto es importante, no wx-2.9.1

Luego, para descargar, descomprimir y todo lo demás tienes que hacer esto (la descarga está donde te dije). A ver si poniendo las instrucciones exactas funciona.
Code: [Select]
$ cd
$ mkdir amule-build
$ cd amule-build
$ wget http://sourceforge.net/projects/wxwindows/files/2.8.12/wxWidgets-2.8.12.tar.gz
$ tar xvfz wxWidgets-2.8.12.tar.gz
$ cd wxWidgets-2.8.12
$ ./configure
$ ./make
$ cd ..
$ wget http://sourceforge.net/projects/amule/files/aMule/2.3.1rc2/aMule-2.3.1rc2.tar.bz2
$ cd amule-2.3.1rc2
$ ./configure --with-wxdir=`pwd`/../wxWidgets-2.8.12/
$ ./make
$ ./src/amule
Si te da cualquier error paras y preguntas.
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #9 on: September 12, 2011, 05:22:05 PM »

No grave no es, la verdad no sé que has hecho, no tiene nada que ver la carpeta .amule con todo los demás, si te la has cargado pues pierdes la configuración, no las descargas.

Te recuerdo que .aMule/Incoming y .aMule/Temp son las carpetas por defecto.
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #10 on: September 12, 2011, 06:29:43 PM »

Por probar, he descomprimido la rc de amule en la carpeta .amule y he reiniciado, para ver si se actualizaba. Ahora no se pone en marcha. Si lo intento desde el terminal, me responde:

Quote
$ amule
amule: error while loading shared libraries: libbfd-2.20.so: cannot open shared object file: No such file or directory

¿Es grave?. Tengo que reinstalarlo perdiendo la configuración, descargas, etc.?.
No grave no es, la verdad no sé que has hecho, no tiene nada que ver la carpeta .amule con todo los demás, si te la has cargado pues pierdes la configuración, no las descargas. A ver, vayamos por partes. primero desinstala en synaptic amule y wx y quita cualquier fuente rara que tengas. Luego lo vuelves a instalar tal y como viene por defecto en Mint.

 Tienes que usar wx-2.8.12, esto es importante, no wx-2.9.1

Luego, para descargar, descomprimir y todo lo demás tienes que hacer esto (la descarga está donde te dije). A ver si poniendo las instrucciones exactas funciona.
Code: [Select]
$ cd
$ mkdir amule-build
$ cd amule-build
$ wget http://sourceforge.net/projects/wxwindows/files/2.8.12/wxWidgets-2.8.12.tar.gz
$ tar xvfz wxWidgets-2.8.12.tar.gz
$ cd wxWidgets-2.8.12
$ ./configure
$ ./make
$ cd ..
$ wget http://sourceforge.net/projects/amule/files/aMule/2.3.1rc2/aMule-2.3.1rc2.tar.bz2
$ cd amule-2.3.1rc2
$ ./configure --with-wxdir=`pwd`/../wxWidgets-2.8.12/
$ ./make
$ ./src/amule
Si te da cualquier error paras y preguntas.


Ya desinstalé completamente aMule 2.3.1 y he encontrado en la página de amule la versión antigua que tenía (2.2.6), pero no se puede instalar porqué, después de descomprimir el archivo tar, el fichero install.sh me indica que no se puede ejecutar.

La que trae por defecto Linux Mint en el Synaptic, ahora, es la versión 2.3.1 y también es la que se instala por terminal. No puedo hacer otra cosa. Creo que, en este caso, lo único que puedo hacer es buscar otro programa P2P.
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #11 on: September 12, 2011, 06:51:10 PM »

Si Mint tiene 2.3.1, con usar la 2.3.1 deberia valerte, no?


Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #12 on: September 12, 2011, 07:03:35 PM »

Debería, sería lógico, pero no es así. Por alguna extraña razón, no ve una librería que tiene instalada. En algunos casos, se hace un puente simbólico para que la vea pero, en mi caso, no consigo que la vea. Ya he abierto otro hilo con el problema pero sé que es difícil encontrar a alguien con el mismo problema. En el Google no encuentro ayuda.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #13 on: September 12, 2011, 10:48:52 PM »

muleta,  ¿por qué no haces lo que te digo? Te aseguro que es más fácil que cualquier otra opción.

Saludos,
BTK
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: Compilar amule para actualizarlo a la última SVN.
« Reply #14 on: September 13, 2011, 09:29:13 AM »

Es posible que me hubiera resultdo fácil si, de entrada, me hubieras dado las instrucciones tan claras que me has dado cuando ya lo había estropeado todo.

Gracias de todos modos. Estoy instalando, configurando y conociendo Debian en otro ordenador. Veo que allí se instala la versión 2.2.6 de amule y la he instalado. Podré experimentar lo que tú me aconsejas cuando aprenda a moverme por esta distro.

Ya comentaré.
Logged
Pages: [1] 2