aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: aMule crashes  (Read 5080 times)

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
aMule crashes
« on: September 25, 2011, 05:24:00 PM »

Hello,

my amule 2.2.6 crashes after running about 10 minutes.

Here is the output and backtrace from gdb:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7bcbed4 in pthread_mutex_lock () from /lib/libpthread.so.0
(gdb) backtrace
#0  0x00007ffff7bcbed4 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x00007ffff2cc93ff in ?? () from /lib/libglib-2.0.so.0
#2  0x00007ffff2ccbc1e in g_source_remove () from /lib/libglib-2.0.so.0
#3  0x00007ffff657eae6 in GSocketGUIFunctionsTableConcrete::Uninstall_Callback(GSocket*, GSocketEvent) () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#4  0x00007ffff617c327 in GSocket::Detected_Write() () from /usr/lib/libwx_baseu_net-2.8.so.0
#5  0x00007ffff4804c4f in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#6  0x00007ffff2cc96f2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#7  0x00007ffff2ccd568 in ?? () from /lib/libglib-2.0.so.0
#8  0x00007ffff2ccda75 in g_main_loop_run () from /lib/libglib-2.0.so.0
#9  0x00007ffff4bc76b7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#10 0x00007ffff657d408 in wxEventLoop::Run() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#11 0x00007ffff660218b in wxAppBase::MainLoop() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#12 0x00007ffff5e8c63c in wxEntry(int&, wchar_t**) () from /usr/lib/libwx_baseu-2.8.so.0
#13 0x0000000000514a42 in ?? ()
#14 0x00007ffff50cbc4d in __libc_start_main () from /lib/libc.so.6
#15 0x00000000004476f9 in ?? ()
#16 0x00007fffffffe378 in ?? ()
#17 0x000000000000001c in ?? ()
#18 0x0000000000000001 in ?? ()
#19 0x00007fffffffe626 in ?? ()
#20 0x0000000000000000 in ?? ()

amule -v:
aMule 2.2.6 using wxGTK2 v2.8.10 (OS: Linux)

running squeeze

What can I do?

Thanks
Magnus
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: aMule crashes
« Reply #1 on: September 25, 2011, 06:05:23 PM »

Update to wx 2.8.12.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #2 on: September 26, 2011, 05:31:26 AM »

Thank you!

Can I do this without bypassing the package manager (apt) in debian?

Magnus
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1480
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule crashes
« Reply #3 on: September 26, 2011, 01:36:58 PM »

Sure, I've  built them for testing and stable.
Logged
Homefucking is killing prostitution

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #4 on: September 26, 2011, 06:24:59 PM »

Hi,

my package manager only offers these packages:

libwxbase2.8-0
libwxgtk2.8-0

Do I need a special entry in the sources.list?

Magnus
Logged

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #5 on: September 26, 2011, 07:07:12 PM »

Hi,

I found it in another thread. But I get errors:

added to sources.list:
deb http://www.vollstreckernet.de/debian/ stable amule-stable wx upnp

Then:
$ gpg --recv-keys D63913EF50D0AE60
$ gpg --export -armor D63913EF50D0AE60 | apt-key add -

$ apt-get update
Hit http://security.debian.org squeeze/updates Release.gpg
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-en_US
Hit http://www.vollstreckernet.de stable Release.gpg
Ign http://www.vollstreckernet.de/debian/ stable/amule-stable Translation-en
Ign http://www.vollstreckernet.de/debian/ stable/amule-stable Translation-en_US
Hit http://security.debian.org squeeze/updates Release
Ign http://www.vollstreckernet.de/debian/ stable/upnp Translation-en 
Ign http://www.vollstreckernet.de/debian/ stable/upnp Translation-en_US
Ign http://www.vollstreckernet.de/debian/ stable/wx Translation-en   
Ign http://www.vollstreckernet.de/debian/ stable/wx Translation-en_US
Hit http://www.vollstreckernet.de stable Release                     
Hit http://security.debian.org squeeze/updates/main Sources           
Hit http://security.debian.org squeeze/updates/main amd64 Packages
Hit http://ftp.uni-bayreuth.de squeeze Release.gpg
Ign http://ftp.uni-bayreuth.de/debian/ squeeze/main Translation-en
Ign http://ftp.uni-bayreuth.de/debian/ squeeze/main Translation-en_US
Hit http://ftp.uni-bayreuth.de squeeze-updates Release.gpg
Ign http://ftp.uni-bayreuth.de/debian/ squeeze-updates/main Translation-en
Ign http://ftp.uni-bayreuth.de/debian/ squeeze-updates/main Translation-en_US
Hit http://ftp.uni-bayreuth.de squeeze Release
Hit http://ftp.uni-bayreuth.de squeeze-updates Release
Hit http://ftp.uni-bayreuth.de squeeze/main Sources
Hit http://ftp.uni-bayreuth.de squeeze/main amd64 Packages
Hit http://ftp.uni-bayreuth.de squeeze-updates/main Sources/DiffIndex
Hit http://ftp.uni-bayreuth.de squeeze-updates/main amd64 Packages/DiffIndex
Hit http://ftp.uni-bayreuth.de squeeze-updates/main amd64 Packages
W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/Release  Unable to find expected entry  amule-stable/binary-amd64/Packages in Meta-index file (malformed Release file?)

E: Some index files failed to download, they have been ignored, or old ones used instead.

What can I do?

Magnus
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1480
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule crashes
« Reply #6 on: September 27, 2011, 03:56:49 AM »

My bad, for this arch you can only get the source packages to build them yourself.
Logged
Homefucking is killing prostitution

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #7 on: September 27, 2011, 05:27:05 PM »

Ok, but if the wx-library is the problem, compiling amule would not help, correct?

Could you please tell me, what to do exactly?

Thanks
Magnus
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1480
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule crashes
« Reply #8 on: September 27, 2011, 07:47:59 PM »

If you compile the lib, you have to compile aMule , too. For sure.
Logged
Homefucking is killing prostitution

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #9 on: September 29, 2011, 05:44:42 PM »

Hi,

I don't know why, but I cannot see the source files in my repository.

I added to sources.list:
deb-src http://www.vollstreckernet.de/debian/ stable amule-stable wx upnp

After apt-get update I do not see amule source in my repository, e. g. with synaptic.

Please help!

Magnus
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2673
Re: aMule crashes
« Reply #10 on: September 29, 2011, 09:32:31 PM »

You can always get the latest sources from the tarballs page.
Logged
concordia cum veritate

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #11 on: September 30, 2011, 05:11:47 AM »

Hi,

I began compiling the source. The first thing is that it requires a newer version of zlib. I think I have to provide this also by bypassing the package manager. Maybe, zlib is not the only library that must be newer than my repository provides. This is what I wanted to avoid. :-/

Magnus
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: aMule crashes
« Reply #12 on: September 30, 2011, 09:30:28 PM »

Omg, another get-it-running-on-Debian-in-287-easy-steps thread.  :-\
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Knorpi

  • Approved Newbie
  • *
  • Karma: -1
  • Offline Offline
  • Posts: 11
Re: aMule crashes
« Reply #13 on: October 01, 2011, 04:36:48 AM »

Silly posting!
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule crashes
« Reply #14 on: October 01, 2011, 07:11:40 AM »

A newer version? That is strange, maybe you didn't install zlib-dev.

Please post the exact message in order to satisfy Stu :)
Logged
Pages: [1] 2