aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Ubuntu 11.10 regression: Libreadline  (Read 3298 times)

stoatwblr

  • Sr. Member
  • ****
  • Karma: 12
  • Offline Offline
  • Posts: 318
Ubuntu 11.10 regression: Libreadline
« on: November 14, 2011, 02:36:22 AM »


nothing major, just a prerequsite package has been renamed

Building dependency tree       
Reading state information... Done
Package libreadline5-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libreadline-gplv2-dev:i386 lib64readline-gplv2-dev:i386
  libreadline-gplv2-dev

E: Package 'libreadline5-dev' has no installation candidate

Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: Ubuntu 11.10 regression: Libreadline
« Reply #1 on: November 14, 2011, 09:00:11 PM »

What are you doing? I have never installed a libreadline-something.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu 11.10 regression: Libreadline
« Reply #2 on: November 14, 2011, 09:53:42 PM »

I guess he tries to build packages, and I guess I forgot to change libreadline5-dev to the generic libreadline-dev in Build-Deps. Iirc it's needed for amulecmd.
Logged
Homefucking is killing prostitution

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: Ubuntu 11.10 regression: Libreadline
« Reply #3 on: November 14, 2011, 10:33:12 PM »

The whole package (without the plamamule) builds and runs fine on Obnoxious Ozelot without any libreadline-dev. The package description in the wiki works with a from-scratch Ubuntu installation.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: Ubuntu 11.10 regression: Libreadline
« Reply #4 on: November 15, 2011, 08:16:36 AM »

libreadline is used for amulecmd, iirc.
Logged

stoatwblr

  • Sr. Member
  • ****
  • Karma: 12
  • Offline Offline
  • Posts: 318
Re: Ubuntu 11.10 regression: Libreadline
« Reply #5 on: November 15, 2011, 01:22:29 PM »

What are you doing? I have never installed a libreadline-something.

Using the instructions in readme-debian for making .deb packages.

It's overridable in any case, but it gives Vollstrecker the hint he needs to make it work again.

Compilation itself works fine.

Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2674
Re: Ubuntu 11.10 regression: Libreadline
« Reply #6 on: November 15, 2011, 04:33:22 PM »

libreadline is used for amulecmd, iirc.
Right. An optional prerequisite.
Logged
concordia cum veritate

stoatwblr

  • Sr. Member
  • ****
  • Karma: 12
  • Offline Offline
  • Posts: 318
Re: Ubuntu 11.10 regression: Libreadline
« Reply #7 on: November 15, 2011, 09:57:52 PM »


Compilation on Oneiric is also failing on lack of wx-config - the bundled wxwidgets is 2.8.11, not 2.8.12.

There used to be a wxwidgets ppa but that seems to have disappeared.
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: Ubuntu 11.10 regression: Libreadline
« Reply #8 on: November 15, 2011, 10:29:15 PM »

An optional prerequisite.
You mean, you can install it, but compilation works without it as well? That's true for almost every available package.  :P

Compilation on Oneiric is also failing on lack of wx-config - the bundled wxwidgets is 2.8.11, not 2.8.12.
We noticed. It's rapidly regressing to Debian level. One of the reasons I call it "Obnoxious".
You have to compile wx yourself as described in the wiki.

And Festor has found more important stuff to do with his life, so we have to make do without Ubuntu packages for now.  :(
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2674
Re: Ubuntu 11.10 regression: Libreadline
« Reply #9 on: November 16, 2011, 06:27:43 PM »

An optional prerequisite.
You mean, you can install it, but compilation works without it as well? That's true for almost every available package.  :P
I mean if you don't have readline you can still compile and run amulecmd (and amuleweb), but you won't have command history and advanced line editing support.
Logged
concordia cum veritate

stoatwblr

  • Sr. Member
  • ****
  • Karma: 12
  • Offline Offline
  • Posts: 318
Re: Ubuntu 11.10 regression: Libreadline
« Reply #10 on: November 17, 2011, 01:42:55 AM »

And Festor has found more important stuff to do with his life, so we have to make do without Ubuntu packages for now.  :(

I'm just trying to run through the compilation method in README.debian

I sorted the wxwidgets issue (had to reinstall all the packages) but now I'm running into a bunch of QT errors when compiling plasmamule which appear to be missing libraries, but as far as I can tell everything is installed.

Has anyone had plasmamule working in any version of Ubuntu? (I never have been able to get this to compile)
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu 11.10 regression: Libreadline
« Reply #11 on: November 17, 2011, 02:17:09 PM »

I just compiled the pkg's for testing and now stable's are compiling, so at least here they work. The readline problem can be solved by editing debian/control, just grep for it, there's only one line with readline.

For the Qt-Errors, there has been a problem some time ago, where the libs has been split, but before I got time to investigate this, it disappeared. Stable has versions before the prob, testing has one after it. It seems Ubuntu has released right in that period. But the error should tell you everything needed.

I'm thinking about building at least wx and 2.3.1 for Ubuntu too. Maybe more when I find time.
Logged
Homefucking is killing prostitution