aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Amule 2.3.2 not starting on Zesty (Future Ubuntu 17.04)  (Read 682 times)

trekfan1

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 31
Amule 2.3.2 not starting on Zesty (Future Ubuntu 17.04)
« on: November 06, 2016, 10:29:39 PM »

After short period amule 2.3.2 not starting, on terminal appears this message
Code: [Select]
amule: symbol lookup error: amule: undefined symbol: _ZN8CryptoPP7IntegerC1EPKhmNS0_10SignednessEversion of amule is
Code: [Select]
dpkg -l | grep amule
ii  amule                                                1:2.3.2-1build1                             amd64        client for the eD2k and Kad networks, like eMule
ii  amule-common                                         1:2.3.2-1build1                             all          common files for the rest of aMule packages
ii  amule-utils                                          1:2.3.2-1build1                             amd64        utilities for aMule (command-line version)
On yakkety (16.10) no problem, same version working ok
Logged
Sorry for my English, I'm Italian

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 163
  • Offline Offline
  • Posts: 2688
Re: Amule 2.3.2 not starting on Zesty (Future Ubuntu 17.04)
« Reply #1 on: November 09, 2016, 12:20:12 AM »

Looks like aMule is trying to use a different crypto++ version than it was compiled with.
Logged
concordia cum veritate

trekfan1

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 31
Re: Amule 2.3.2 not starting on Zesty (Future Ubuntu 17.04)
« Reply #2 on: November 10, 2016, 07:34:13 AM »

meanwhile problem is fixed, new version is released and amule starting, but this version is depends on libboost zesty version. I have uploaded the previous version (working on yakkety but not have tested on xenial) here
Logged
Sorry for my English, I'm Italian