aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: wxwidgets 2.8.12 irgendwo?  (Read 16010 times)

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
wxwidgets 2.8.12 irgendwo?
« on: April 06, 2011, 01:17:30 AM »

Da ich bisher kein REpository mit einer unter Ubuntu Maverick lauffähigen Version von wxwidgets 2.8.12 gefunden habe frage ich mal hier danach.
Ansonst muss ich das Testen einstellen bis Ubuntu diese Version auf die Repos gestellt hat.  :(
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #1 on: April 06, 2011, 01:03:41 PM »

Vieleicht als File, muss ja kein Repostitory sein.
die bei wxwidgets haben zwar ein Repository aber das unterstützt nicht die aktuelle Ubuntu Version.
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #3 on: April 06, 2011, 11:40:47 PM »

So, ich baue garade ein wx paket.
Derzeit habe ich für Version 2.8.11 folgende Pakete installiert (aus dem Ubuntu REpository):

wx2.8-headers
libwxgtk2.8-dev
libwxgtk2.8-0
libwxbase2.8-dev
libwxbase2.8-0

Alle sind mit der Version 2.8.11.

Ersetzt das selbstkompilierte alle diese Dateien?
(Ich habe das tar.gz von der wxwidget Seite genommen)
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #4 on: April 07, 2011, 12:20:36 AM »

Weiss jemand welche wx Version Ubuntu 11.04 verwendet?
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: wxwidgets 2.8.12 irgendwo?
« Reply #5 on: April 08, 2011, 10:51:12 PM »

Weiss jemand welche wx Version Ubuntu 11.04 verwendet?
Aktuell 2.8.11 .

Quote
Ersetzt das selbstkompilierte alle diese Dateien?
Ja.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: wxwidgets 2.8.12 irgendwo?
« Reply #6 on: April 08, 2011, 11:34:11 PM »

Quote
Ersetzt das selbstkompilierte alle diese Dateien?
Ja.

Im wiki-Artikel steht --prefix=/home/me...., also wäre die richtige Antwort: "Nein, es installiert eine zweite Version an einen andere Ort, könnte allerdings mit anderen Einstellungen all diese Dateien ersetzen".
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #7 on: June 10, 2011, 08:03:26 AM »

Hier gibts offensichtlich aktuellere non-stable wx:

https://launchpad.net/~fransschreuder1/%2Barchive/usbpicprog-stable

als Repository.
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #8 on: June 10, 2011, 08:14:25 AM »

Aber scheinbar gehts trotzdem nicht:

Quote
checking for wx-config... /usr/bin/wx-config
checking for wxWidgets version >= 2.8.12 (--unicode=yes)... no (version 2.8.11 is not new enough)

Version zu hoch?
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #9 on: June 10, 2011, 08:24:42 AM »

Wenn man 2.8.11 deinstalliert geht es dann doch.
Leider braucht der filezilla 2.8.11.
Nur funktioniert die Abfrage von configure nur wenn keine niedrigere Version drauf ist obowhl beide wx Versionen auch parallel druaf sein könnten.
Sucht die Abfrage die niedrigste Version und nimmt die für die Abfrage?

Könnte man die Abfrage so anpassen dass er auch mehrere wx Versionen parallel akzeptiert?
Also 2.8.11 und 2.9.0 unstable und trotzdem die 2.9.0 als ausreichend annimmt?
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #10 on: June 10, 2011, 09:32:10 AM »

Liegt das jetzt an wx 2.9.1 dass bei R10578 die Reiter der Kategorien weg sind oder ist das ein Bug?
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: wxwidgets 2.8.12 irgendwo?
« Reply #11 on: June 10, 2011, 09:39:53 PM »

Hier gibts offensichtlich aktuellere non-stable wx:
Was hältst du von http://svn.wxwidgets.org ?

http://wiki.amule.org/index.php/HowTo_Compile_In_Ubuntu
Schau doch mal rein. Da steht, wie man aMule mit 2.8.12 ans laufen bekommt, ohne die Distro zu verschrauben.

Liegt das jetzt an wx 2.9.1 dass bei R10578 die Reiter der Kategorien weg sind oder ist das ein Bug?
Screenshot?
Bitte probier mal die aktuelle SVN-Version von wx.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #12 on: June 11, 2011, 07:40:56 AM »

Hier gibts offensichtlich aktuellere non-stable wx:
Was hältst du von http://svn.wxwidgets.org ?

DAs mit dem dort lassen wo man es compiliert hat hatte ich schon mal.
Hat nie so geklappt wie es sollte.
Bin ja doch eine Zeit lang auf der Suche nach aktuelleren Versionen von wx gewesen da ich noch mit Ubuntu 10.10 arbeite da die neue Version Ärger macht.

Quote
http://wiki.amule.org/index.php/HowTo_Compile_In_Ubuntu
Schau doch mal rein. Da steht, wie man aMule mit 2.8.12 ans laufen bekommt, ohne die Distro zu verschrauben.
Ich kann mich erinnern dass ich damals versucht hatte wx zu erneuern.

Aktuell hat das COmpilieren erst geklappt als NUR mehr 2.9.1 drauf war.
Als ich 2.8.11 UND 2.9.1 drauf hatte hat das configure script gemeckert dass die Vesion nicht neu genug sei.

Quote
Liegt das jetzt an wx 2.9.1 dass bei R10578 die Reiter der Kategorien weg sind oder ist das ein Bug?
Screenshot?
Bitte probier mal die aktuelle SVN-Version von wx.

Ist leider noch die gleiche wie ich gerade gestern compiliert hatte. R10578.
Muss ich halt warten bis eine Neue kommt.
Laufen tut der Amule ja und mit solchen harmlosen Bugs muss man als SVN Tester eh leben können.  ;D
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: wxwidgets 2.8.12 irgendwo?
« Reply #13 on: June 11, 2011, 07:09:03 PM »

Ich sprach von der SVN-Version von wxWidgets. Aktuell ist 67917.
Quote
DAs mit dem dort lassen wo man es compiliert hat hatte ich schon mal.
Hat nie so geklappt wie es sollte.
Mit so einer Fehlerbeschreibung kann dir niemand helfen.

Meine Empfehlung ist ganz eindeutig:
- Wer es selbst compiliert (aMule, wx oder beides) sollte es nur in einem lokalen Pfad installieren. Außerhalb vom Bereich der Distro. Am besten im Home, dann gehts ohne sudo und man macht sicher nichts kaputt. Wie das geht (ohne Kollisionen mit installierten Versionen von wx) steht in dem Wiki-Artikel.
- Pakete bauen sollten nur Leute, die Pakete für andere anbieten wollen.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 373
Re: wxwidgets 2.8.12 irgendwo?
« Reply #14 on: March 14, 2012, 03:52:15 PM »

Hier gibts das für debian Systeme fertig:

http://wiki.wxpython.org/InstallingOnUbuntuOrDebian
Logged