aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Crash on Debian Stable  (Read 495 times)

laura99

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Crash on Debian Stable
« on: December 22, 2017, 11:00:53 AM »

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/wiki/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.3.2 compiled with wxGTK2 v3.0.2 and Boost 1.62
Running on: Linux 4.9.0-4-amd64 x86_64

[2] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7f21bdb8232c]
[3] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7f21bfd270c0]
[4] ?? in amule[0x5564d577e8e9]
[5] ?? in amule[0x5564d577ff4c]
[6] ?? in amule[0x5564d57842c6]
[7] ?? in amule[0x5564d578e781]
[8] ?? in amule[0x5564d578ea6f]
[9] ?? in amule[0x5564d577ed25]
[10] ?? in amule[0x5564d5783585]
[11] ?? in amule[0x5564d578747a]
[12] wxThread::CallEntry() in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7f21bdb78012]
[13] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7f21bdb806a3]
[14] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7f21bfd1d494]
[15] clone in /lib/x86_64-linux-gnu/libc.so.6[0x7f21bcc32aff]

--------------------------------------------------------------------------------
[1]    12304 abort      amule
Logged

piep

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9
Re: Crash on Debian Stable
« Reply #1 on: February 22, 2018, 06:30:13 PM »

Hello,

it's a bug of libwxbase3.0-0v5  (3.0.2+dfsg-4) delivered with stretch (debian 9)

the solution is to replace it by the one provided on actual testing 'buster'
libwxbase3.0-0v5 (3.0.3.1+dfsg2-1)

I am going to ask to debian to push this package on stretch-updates but in the meantime it's simple to get it.

add a temporary depot on synaptic with : "deb http://deb.debian.org/debian/ buster main"
research the package libwxbase  you will find : libwxbase3.0-0v5 (3.0.3.1+dfsg2-1)
 install it.
be careful . don't install other package from testing !!!!!
then on depot unset the line "deb http://debian.proxad.net/debian/ buster main" to be back on stable (stretch).


best regards,
Piep
22,Feb 2018
Logged