aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMuleD 2.3.2 on OSMC 2017.12-1 (Debian 9.3) on Raspberry pi 3 crashes on start  (Read 692 times)

ariakas

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

aMuleD 2.3.2 on OSMC 2017.12-1 (based on debian 9.3) on Raspberry pi 3
aMuleD installed via apt-get from http://ftp.debian.org/debian stretch main contrib non-free

Code: [Select]
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMuleD 2.3.2 compiled with wxBase(GTK2) v3.0.2 and Boost 1.62
Running on: Linux 4.9.29-13-osmc armv7l

[2] ?? in /usr/lib/arm-linux-gnueabihf/libwx_baseu-3.0.so.0[0x76b1b8b4]
[3] ?? in /lib/arm-linux-gnueabihf/libc.so.6[0x7677afd0]
[4] ?? in amuled[0x54c40c2a]
[5] ?? in amuled[0x54c429f8]
[6] ?? in amuled[0x54c3f950]
[7] ?? in amuled[0x54c3eee8]
[8] ?? in amuled[0x54c41116]
[9] wxThread::CallEntry() in /usr/lib/arm-linux-gnueabihf/libwx_baseu-3.0.so.0[0x76b14d0e]
[10] ?? in /usr/lib/arm-linux-gnueabihf/libwx_baseu-3.0.so.0[0x76b19b98]

--------------------------------------------------------------------------------
Logged

piep

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9

Hello,

I guess the problem is the same on x86_64.
it's a  bug of  libwxbase3.0-0v5  (3.0.2+dfsg-4) delivered with stretch (debian 9)

the solution is to replace it by the one provided on actual testing 'buster'
libwxbase3.0-0v5 (3.0.3.1+dfsg2-1)

best regards,
Piep
Logged