aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amule 1.2.7 et libcurl  (Read 3397 times)

val-geant

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
  • Linux newbie needs help
amule 1.2.7 et libcurl
« on: July 06, 2004, 11:21:55 PM »

Bonjour à tous.

G essayé d'installer amule 1.2.7 sur MDK 9.2, g téléchargé puis installé wxbase2.4.2, de même avec wxGTK2.4.2 puis crypto5.1, avant de passer à amule 1.2.7

A la compil d'amule, une erreur m'indique qu'il me manque curl, je dl curl 7.12.0 et j'installe.

Re compil de amule puis install, plus de soucis :-)

Par contre au démarrage :

[val@localhost val]$ amule
amule: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory

Je ne trouve effectivement pas de telle librairie sur mon systeme.

curl 7.12.0 est il incompatible ? Comment ledésisntaller pour essayer une version antérieure ?

Si quelqu'un a déjà connu ce genre de pb merci de m'aider.


Val, linuxien en herbe.
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: amule 1.2.7 et libcurl
« Reply #1 on: July 06, 2004, 11:24:11 PM »

i think u lack curl-devel

greets

big_julius

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 33
Re: amule 1.2.7 et libcurl
« Reply #2 on: July 07, 2004, 09:32:49 AM »

C'est bien ca, il te manque le package libcurl2-devel

par contre il te faut les lib de meme version que le curl que tu as installé.

Si tu utilise internet pour installer tes packages, curl ainsi que la libcurl2-devel sont disponibles dessus.

curl-7.10.7-2mdk
libcurl2-devel-7.10.7-2mdk

G ces 2 packages et ca marche nickel. ;)
Logged

thepolish

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 908
Re: amule 1.2.7 et libcurl
« Reply #3 on: July 07, 2004, 11:12:41 AM »

Slt,

Utilise "installer des logiciels" et installe les à partir de tes sources de la 9.2,  ca marche

the polish
Logged
Only after the last tree has been cut down
Only after the last river has been poisoned
Only after the last fish has been caught
Only then you will find out that money cannot be eaten
(Cree Prophecy)

val-geant

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
  • Linux newbie needs help
Re: amule 1.2.7 et libcurl
« Reply #4 on: July 08, 2004, 06:12:34 PM »

merci pour tous ces precieux conseils !!

Ca marche nickel merci !

Vive l'aMule et vive Linux !!

A bientôt.

V@l geant linuxien en herbe
Logged