aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 2 [3]

Author Topic: aMule läuft nicht lange  (Read 6860 times)

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1524
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #30 on: December 21, 2019, 01:24:16 PM »

Ist das jetzt mit der boost-gui oder der anderen? Und eigentlich sollte da git und nicht svn stehen, ist das der aktuelle master?
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #31 on: December 21, 2019, 01:45:41 PM »

Laut configure ist boost vorhanden.
Bei der gui starte ich mit amulegui.
Das CVN ist weil ich die Quellen mit
svn co https://github.com/amule-project/amule/trunk amule
runterlade.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1524
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #32 on: December 21, 2019, 01:54:45 PM »

Schon klar, wenn du aber das --with-boost weglässt erhältst du eine gui ohne boost die sich mit dem gerade laufende amuled verbinden können sollte.
Das mit svn kannte ich noch nicht, git finde ich halt persönlich angenehmer.
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #33 on: December 21, 2019, 02:15:58 PM »

Derzeit habe ich boost dabei, ich übersetze immer das ganze Paket mit amuled und GUI in einem Rutsch.
Meine Zeile für configure lautet derzeit:

./configure --with-boost --disable-debug --enable-optimize --disable-ccache  --disable-upnp --enable-alc --enable-alcc --disable-xas --enable-amulecmd --enable-webserver --enable-amule-daemon --enable-amule-gui --enable-fileview

Bei Bedarf wird auch debug eingeschaltet.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1524
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #34 on: December 21, 2019, 02:26:08 PM »

Jep, und wenn du --with-boost --enable-alc --enable-alcc --enable-amulecmd --enable-webserver --enable-amule-daemon --enable-fileview weglässt, sollte nur die gui rauskommen.
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #35 on: December 21, 2019, 06:41:19 PM »

Ist wx eigentlich notwendig wenn boost verwendet wird, kenne mich mit diesen Paketen nicht so wirklich aus.
Wenn asio/boost wx komplett ersetzen kann, wie bekomme ich wx dann raus?
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1524
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #36 on: December 22, 2019, 09:40:04 AM »

wx ist auch für die gesamte GUI zuständig, inklusive Strings, Configparsing u.v.m, das wirst du erst los, wenn ich endlich mit meinem QT-port anfangen kann.
Logged
Homefucking is killing prostitution
Pages: 1 2 [3]