aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2 3

Author Topic: amule crashes after start  (Read 9918 times)

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
amule crashes after start
« on: August 21, 2004, 10:48:52 PM »

Hi!

I installed amule from official unstable debian repositories, and the first time I run amule, I have the next info confirmation:
-- This is the first time you ruun aMule 2.0.0rc5 --
Quote
Your locale has been changed to System Default due tu a version change. Sorry.
Feel free to report any bugs to forum.amule.org
[ok]


Then, amule crashes showing the next output:

Code: [Select]
Initialising aMule
Userhash loaded: 5AFA6A186C0E6F124015084A72D76FFE
*** UDP socket at 4665
*** TCP socket at 4662
*** UDP socket at 4672
Serverlist loaded.
*** reading servers
Loading temp files from /root/.aMule/Temp/*.part.met.
Empty dir /root/.aMule/Incoming/ shared
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 5433 error_code 2 request_code 45 minor_code 0

I've tried to chmod 777 /root/.aMule/Temp but it didn't work

What can I do? (the next times it crashes without the first message).
Logged

lfroen

  • Guest
Re: amule crashes after start
« Reply #1 on: August 23, 2004, 09:36:26 AM »

For a beginning I suggest to stop running as root !
Never again :))
Logged

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #2 on: August 23, 2004, 10:48:17 AM »

I was trying  to  resolve de the problem, I don't  use amule as root  :baby:

I've compiled the source package and installed form it, and amule didn't work due to the same problem. As normal user, the first time I run amule, it says:

Code: [Select]
12:07:56: Directory '' couldn't be created (error 2: No existe el fichero o el directorio)
12:07:56: Directory '' couldn't be created (error 2: No existe el fichero o el directorio)
[Accept]

After that, the same message refering to localization appears, and, after all, the output shows:

Code: [Select]
Initialising aMule
Saving userhash: 02D297A3FA0E06F4E24A268FAB256F97
Userhash loaded: 02D297A3FA0E06F4E24A268FAB256F97
*** UDP socket at 83
*** TCP socket at 80
*** UDP socket at 1025
No cryptkey.dat found, creating
Serverlist loaded.
External connections disabled in .eMule
*** reading servers
Loading temp files from /*.part.met.
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 11915 error_code 2 request_code 45 minor_code 0

But I'm not going to change the / permissions, and I don't know how to change preferences.dat (or the concerned file) with a common editor in orther to force amule seek the temp files from /home/user/.aMule/Temp/. (I read in a post that permissions could be the problem in my case, but I think not, afterall).

Any light about this case?  ;(
« Last Edit: August 23, 2004, 12:10:39 PM by zeppelin »
Logged

lfroen

  • Guest
Re: amule crashes after start
« Reply #3 on: August 27, 2004, 08:25:31 AM »

Seems that mule can't read it's prefeences. Check permissions etc. File is ~/.eMule
Logged

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #4 on: August 27, 2004, 02:57:21 PM »

I changed the temp folder and shares folder on ~/.eMule. The permissions of directories under /home/eMule are 775. The permissions of files are 774. Permissions of .eMule are 777.
aMule loaded theese preferences but it didn't work, aMule crashes like it did before.
Another problem is a warning announcing me that the directory I've selected for online signature does not exist. I've edited .eMule and this option is 0 (false).

The new output:
Code: [Select]
Initialising aMule
Userhash loaded: 02D297A3FA0E06F4E24A268FAB256F97
*** UDP socket at 83
*** TCP socket at 80
*** UDP socket at 1025
Serverlist loaded.
External connections disabled in .eMule
*** reading servers
Loading temp files from /home/eMule/temp/*.part.met.
Loading 001.part.met...  - filename Shrek.2.Spanish.XviD.MP3.SCREENER.SEDG.avi - Done.
Loading 007.part.met...  - filename [GAME] The Sims - Linux.iso - Done.
Adding file /home/eMule/temp/007.part.met to shares
Adding file /home/eMule/temp/001.part.met to shares
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 2678 error_code 2 request_code 45 minor_code 0
« Last Edit: August 27, 2004, 03:11:30 PM by zeppelin »
Logged

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #5 on: September 04, 2004, 07:01:31 PM »

No solution to this problem? ;(
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: amule crashes after start
« Reply #6 on: September 04, 2004, 09:35:52 PM »

hmmm never sean anything like that before

what system are you using? post your versions of installed wxgtk rpms

on rpms based system
rpm -qa | grep wx

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #7 on: September 04, 2004, 10:18:44 PM »

Debian Sid 2.6.7

$ dpkg -l |grep wx

ii  libwxbase2.4   2.4.2.6        wxBase library (runtime) - non-GUI support c
ii  libwxbase2.4-dev 2.4.2.6        wxBase library (development) - non-GUI suppo
ii  libwxgtk2.4    2.4.2.6        wxWindows Cross-platform C++ GUI toolkit (GT
ii  libwxgtk2.4-dev 2.4.2.6        wxWindows Cross-platform C++ GUI toolkit (GT
ii  wxwin2.4-headers 2.4.2.6        wxWindows Cross-platform C++ GUI toolkit (he

thanks!
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: amule crashes after start
« Reply #8 on: September 04, 2004, 10:25:35 PM »

hmm debain packages are ok...
so no problem with taht....

strange
have you tryed moving .eMule file and .aMule directory? and restarting aMule?
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #9 on: September 05, 2004, 11:46:14 AM »

I suppose so, but it is not a hard task -> I'll do it again and comment you.
thanks


It didn't work  :(
« Last Edit: September 05, 2004, 11:59:05 AM by zeppelin »
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: amule crashes after start
« Reply #10 on: September 05, 2004, 12:02:01 PM »

hmmmm
what you could to and check if its a wxGTK error is..remove your debian wxGTK packages and compile wxGTK yourself like shown in the howto...

Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 2678 error_code 2 request_code 45 minor_code 0

but maybe its not a wx-error since it sais Gdk error whatever taht is...
have you tryed google? for something simular?
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #11 on: September 05, 2004, 05:05:19 PM »

ok, compiled wxWidgets as said on HowTo and... nothing  ;(

I'm going to try compliling libcrypto too, to know if it were the problem.
I will google too.
Logged

maddeneye

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 8
Re: amule crashes after start
« Reply #12 on: September 08, 2004, 01:58:06 PM »

Zepp, I've just started using amule the past few days on my debian linux. I apt-get it from following these instructions:

#> vi /etc/apt/sources.list
deb http://ftp.drazzib.com/debian ./
#> apt-get install amule

This is by one of the forum members. The thread is here:

http://www.amule.org/amule/thread.php?threadid=2945&page=2&sid=

Why don't you uninstall and then apt-get this version. I had no problems except for needing to update a library.

Hope this helps.
Logged

zeppelin

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: amule crashes after start
« Reply #13 on: September 09, 2004, 02:21:08 AM »

I think there is not any amule package available on that repositorie. It could be deleted :S
Logged

maddeneye

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 8
Re: amule crashes after start
« Reply #14 on: September 09, 2004, 08:09:19 AM »

I hope you had added the source line "deb http://ftp.drazzib.com/debian ./" to your source.list and apt-get update first before you apt-get install amule. In any case, if you wish I can email you the deb file - I still have it in my cache:

amule_2.0.0rc5-0+cvs20040816_i386.deb

it is about 2MB. You can use dpkg to install. If you need it, pm me and I will email it to you. Warning though - I only know it worked for me. Don't know if it will work for you.
Logged
Pages: [1] 2 3