aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Instabile 1.2.0  (Read 2518 times)

Guest

  • Guest
Instabile 1.2.0
« on: December 04, 2003, 01:34:55 PM »

Also seit gestern Abend habe ich das Problem gehabt, dass aMule mit nur noch wenigen Clients connected. Da kommt ständig eine Meldung dieser Art:
2003-12-04 12:45:56: Client 'xxxx' (IP:xxx.xxx.xxx.xxx) caused an error: 0. Disconnecting client!

Deswegen habe ich mir die 1.2.0 installiert (inklusive der 2.4.2 der wx...). Aber diese stürzt mir ständig ab (Backtrace folgt unten) und der Fehler ist immernoch.
Meine Konfiguration: SuSE 8.2 auf aktuellem Stand, letzte aktualisierung am Mittwoch (danach funktionierte noch alles über 24 h lang richtig, dürfte es also nicht sein). Connection über einen Linux-Router (konfiguration seit ca. 3 Monaten nicht geändert).

Bei Razorback und anderen Servern bekomme ich folgende Meldung:
2003-12-04 12:44:56: Lost connection to Razorback (195.245.244.243:4661)
2003-12-04 12:44:56: Error in serversocket: Razorback (195.245.244.243:4661): 2

Eine Verbindung zu anderen Servern funktioniert aber.

Hier der Backtrace:
OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

  • amule [0x818ca89]
  • [1] /usr/lib/libwx_gtk-2.4.so.0(wxFatalSignalHandler+0x26)
[0x4039ff42]
[2] /lib/libpthread.so.0 [0x405c41ec]
[3] /lib/libc.so.6 [0x406323a8]
[4] amule [0x8083114]
[5] amule [0x80bbf83]
[6] amule [0x80be5a7]
[9] amule [0x818ee57]
[10] /usr/lib/libwx_gtk-2.4.so.0(_ZN12wxEvtHandler16SearchEventTableER12wxEventTableR7wxEvent+0xb6) [0x402d5e62]
[11] /usr/lib/libwx_gtk-2.4.so.0(_ZN12wxEvtHandler12ProcessEventER7wxEvent+0x83) [0x402d5c8f]
[12] /usr/lib/libwx_gtk-2.4.so.0(_ZN12wxEvtHandler20ProcessPendingEventsEv+0x57) [0x402d5bcb]
[13] /usr/lib/libwx_gtk-2.4.so.0(_ZN9wxAppBase20ProcessPendingEventsEv+0x61) [0x4028c759]
[14] /usr/lib/libwx_gtk-2.4.so.0 [0x4023a07b]
[15] /usr/lib/libglib-1.2.so.0 [0x408c9c2f]
[16] /usr/lib/libglib-1.2.so.0 [0x408c8abe]
[17] /usr/lib/libglib-1.2.so.0 [0x408c8f99]
[18] /usr/lib/libglib-1.2.so.0(g_main_run+0x44) [0x408c9234]
[19] /usr/lib/libgtk-1.2.so.0(gtk_main+0xbf) [0x407d936f]
[20] /usr/lib/libwx_gtk-2.4.so.0(_ZN5wxApp8MainLoopEv+0x16) [0x4023a9f2]
[21] /usr/lib/libwx_gtk-2.4.so.0(_ZN9wxAppBase5OnRunEv+0x18) [0x4028c610]
[22] /usr/lib/libwx_gtk-2.4.so.0(_Z7wxEntryiPPc+0x235) [0x4023b0cd]
[23] amule [0x8188d03]
[24] /lib/libc.so.6(__libc_start_main+0xc7) [0x4061e857]
[25] amule(_ZN17wxGenericTreeCtrlC2EP8wxWindowiRK7wxPointRK6wxSizelRK11wxValidatorRK8wxString+0xb9) [0x8061d11]
Abgebrochen
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Instabile 1.2.0
« Reply #1 on: December 05, 2003, 08:12:48 AM »

hi,

2003-12-04 12:45:56: Client 'xxxx' (IP:xxx.xxx.xxx.xxx) caused an error: 0. Disconnecting client!  <- das kannst du in preferences -> tweaks -> verbose austellen ..

die server meldungen gehen dann auch weg (was du da siehst war nicht amule, sondern razorback problem)

poste mal mehr infos zu deinem system ..  kde oder gnome .. was sagt get-info.sh ? (zu finden aufer HP unter dl's)

gruss
delta

Guest

  • Guest
Instabile 1.2.0
« Reply #2 on: December 05, 2003, 03:14:00 PM »

Ok, als erstes:
Ich habe mir jetzt (wieder) xMule (V. 1.7.1) installiert - diese stürzt ausnahmsweise nicht ab (war der Grund, warum ich auf aMule umgestiegen bin) und bringt auch diese ganzen Client-Fehlermeldungen nicht (stabil Connecten zu einem Server kann ich aber auch damit nicht, Verbindungs-Abbruch nach ein paar Minuten). Ok, xMule ist nicht euer Problem, wollte ich nur wegen der Stabilität und dem gleichen Problem mit den Server-Connects erwähnen.

Und hier die Infos:
I.   Development Environment

     A. Compiler Info
        Reading specs from /usr/local/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/specs Configured with: ./configure Thread model: posix gcc version 3.2.1

     B. wxWindows Info
        Version: 2.4.2
        -L/usr/local/lib -pthread -lwx_gtk-2.4

     C. GTK Info
        GTK 1: 1.2.10
        GTK 2: 2.2.1

II.  System Environment

     A. CPU Info
        Type:  AuthenticAMD
        Model: AMD Athlon(tm) Processor
        Speed: 1343.106
        BMips: 2680.42
        Flags: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow

     B. Memory Info
        Total:   514828 kB
        Unused:  303088 kB

     C. Kernel Info
        Version: 2.4.20-4GB-athlon

     D. Library Info
/usr/src/get-info.sh: line 33: ldconfig: command not found
        wxWindows library:



Wollte allerdings nochmal erwähnen, das aMule bis vor der Installation von 1.2.0 gut lief (außer dem einen beschriebenen Problem)
Logged