aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: Webserver  (Read 7673 times)

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Webserver
« on: October 27, 2004, 04:48:36 PM »

Pues finalmente he conseguido instalar el amule rc7 gracias al port para freebsd que hay en los foros  :D :D :D :D pero no soy capaz de hacer que el webserver funcione, o almenos no soy capaz de hacer que muestre nada.

Tengo el amule.tmpl y webserver dentro de ~/.aMule, y ejecuto amuleweb en un terminal, y se abre una ventana que me empieza a pedir la ip del cliente (localhost para mi caso), el puerto y la contraseña.

Los mensajes que me saca por pantalla dicen que todo esta bien, y que esta a la escucha por el puerto que quiero.

El caso es que yo supongo que todo esta ok, y que debería funcionar, en cambio si voy al navegador (firefox 1.0Pr por si influyera aunque no creo) y voy a http://localhost:1144 me dice que no.

Porque?

Cuando instalé el amule hice make configure y dejé todas las opciones marcadas.
Logged
First of all, I apologize for my bad english. :D

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Webserver
« Reply #1 on: October 27, 2004, 05:22:14 PM »

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Webserver
« Reply #2 on: October 27, 2004, 10:33:54 PM »

I'm not sure if I have to reply in english or spanish, but I will try.

Before post my question I did a search in the forum, and I found some anwers (like the link you suggested me). I've try everything I found, but it doesn't work.

==========

Y para los que solo conozcan la lengua de Cervantes (y ya puestos para explicarme bien, que lo mio no es el inglés):

Antes de postear mi consulta que buscado en los foros, y he encontrado varias respuestas (entre otras el link que me has sugerido). He intentado todo lo que he encontrado, pero no funciona.
Logged
First of all, I apologize for my bad english. :D

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Webserver
« Reply #3 on: October 27, 2004, 11:08:17 PM »

Creo que el correcto seria http://localhost:4711

Saludos!
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Webserver
« Reply #4 on: October 28, 2004, 05:42:59 PM »

Es que habia cambiado la configuración del puerto en el amule, por eso he puesto 1144. De todos modos, tb había probado con 4711, y sigo igual.
Logged
First of all, I apologize for my bad english. :D

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Webserver
« Reply #5 on: October 28, 2004, 05:52:14 PM »

Please, paste the output of amuleweb here. Also, paste the log on aMule window, including the authentication messages.
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Webserver
« Reply #6 on: October 29, 2004, 03:03:03 PM »

Quote
Creating client...
Now, doing connection....
Using host 'localhost.localdomain' port:4712
Trying to connect (timeout = 10 sec)...
Succeeded! Connection established.

---------------------------------
|       aMule Web Server        |
---------------------------------


Use 'Help' for command list

Web Server: Started

WSThread: Thread started
WSThread: created service
WSThread: created socket listening on :4711

Quote
29/10/2004 15:05:33: Remote command: PREFERENCES GETWSPORT

and http://localhost:4711 doesn't work
« Last Edit: October 29, 2004, 03:04:26 PM by darksidex »
Logged
First of all, I apologize for my bad english. :D

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Webserver
« Reply #7 on: October 29, 2004, 06:03:18 PM »

darksidex,

Looks like all is fine. Paste here:

$ netstat -nltp
$ iptables -n -L
$ cat /etc/hosts | grep -i local

Is there iptables in FreeBSD? Maybe not. In this case, list you firewall settings here.
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Webserver
« Reply #8 on: October 29, 2004, 11:37:16 PM »

netstat -nptl tcp:

Quote
Active Internet connections
Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)
tcp4       0     49  192.168.1.1.34662      80.37.164.149.4474     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      62.42.40.82.1812       ESTABLISHED
tcp4       0     18  192.168.1.1.34662      81.60.96.191.4195      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      81.44.4.238.27357      ESTABLISHED
tcp4       0     18  192.168.1.1.34662      62.174.95.191.3457     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      81.44.10.6.25888       ESTABLISHED
tcp4       0      0  192.168.1.1.34662      81.34.37.24.28263      ESTABLISHED
tcp4       0      0  192.168.1.1.57045      83.129.187.63.4222     ESTABLISHED
tcp4       0      0  192.168.1.1.57042      213.60.135.46.4662     ESTABLISHED
tcp4       0      0  192.168.1.1.57041      140.105.221.159.4662   SYN_SENT
tcp4       0      0  192.168.1.1.57040      69.148.77.79.4662      ESTABLISHED
tcp4       0      0  192.168.1.1.57039      219.94.58.246.4694     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.59.94.162.3388      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.33.195.214.2537     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      217.126.179.238.61792  ESTABLISHED
tcp4       0      0  192.168.1.1.57038      80.25.167.150.4662     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      81.39.87.159.1057      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.24.138.123.1888     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      83.33.179.143.3726     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      81.38.59.210.3650      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      83.36.82.68.3121       ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.26.191.112.4155     ESTABLISHED
tcp4       0      0  192.168.1.1.57036      82.149.231.177.80      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      81.33.250.209.15634    ESTABLISHED
tcp4       0      0  192.168.1.1.57034      82.149.231.177.80      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      80.35.232.57.12181     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      217.124.34.207.4747    ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.35.226.5.4263       ESTABLISHED
tcp4       0      0  192.168.1.1.34662      84.120.5.64.4646       ESTABLISHED
tcp4       0      0  192.168.1.1.34662      62.174.206.89.28537    ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.28.76.180.50252     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.28.165.250.3303     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      83.39.137.63.1878      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      200.117.141.253.1060   ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.235.70.229.4283     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      80.59.57.186.2598      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      62.42.75.233.3376      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      81.203.68.17.3210      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.32.16.160.3685      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      213.60.76.89.3284      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      62.174.74.46.4153      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      213.98.8.125.56674     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      217.225.216.222.1649   TIME_WAIT
tcp4       0      0  192.168.1.1.34662      80.34.246.240.30535    TIME_WAIT
tcp4       0      0  192.168.1.1.34662      83.36.107.68.4338      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      217.125.56.82.2875     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      81.60.247.132.2401     ESTABLISHED
tcp4       0      0  192.168.1.1.34662      80.32.50.113.60684     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      83.213.52.129.28811    TIME_WAIT
tcp4       0      0  192.168.1.1.34662      84.121.48.39.1393      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      83.38.234.6.4440       FIN_WAIT_1
tcp4       0      0  192.168.1.1.34662      80.34.100.59.3540      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      81.44.234.129.4217     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      80.38.166.58.2044      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      83.37.229.79.4560      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      81.36.237.53.1200      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      82.158.21.233.4150     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      82.223.80.16.57183     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      81.97.187.117.4336     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      80.25.73.248.15699     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      213.37.241.191.4516    TIME_WAIT
tcp4       0      0  192.168.1.1.34662      82.198.114.55.3788     TIME_WAIT
tcp4       0      0  192.168.1.1.34662      62.175.32.36.1939      TIME_WAIT
tcp4       0      0  192.168.1.1.34662      80.28.64.98.1520       TIME_WAIT
tcp4       0   3900  192.168.1.1.57029      82.82.204.169.4662     ESTABLISHED
tcp4       0      0  127.0.0.1.4712         127.0.0.1.57028        ESTABLISHED
tcp4       0      0  127.0.0.1.57028        127.0.0.1.4712         ESTABLISHED
tcp4       0      0  192.168.1.1.34662      62.42.64.71.4355       FIN_WAIT_2
tcp4       0      0  192.168.1.1.56981      81.67.172.184.30777    ESTABLISHED
tcp4       0   7117  192.168.1.1.34662      80.38.83.70.62806      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      67.71.69.210.4093      ESTABLISHED
tcp4       0   1300  192.168.1.1.56884      62.57.37.136.4661      ESTABLISHED
tcp4       0      0  192.168.1.1.34662      200.117.197.29.1583    ESTABLISHED
tcp4       0   4682  192.168.1.1.56853      82.130.166.126.4662    ESTABLISHED
tcp4       0      0  192.168.1.1.56838      66.79.163.221.5222     ESTABLISHED
tcp4       0      0  192.168.1.1.56837      207.46.107.156.1863    ESTABLISHED
tcp4       0      0  192.168.1.1.56835      216.155.193.172.5050   ESTABLISHED
tcp4       0      0  192.168.1.1.56834      195.85.200.12.6667     ESTABLISHED
tcp4       0   4688  192.168.1.1.56790      82.158.72.163.4662     ESTABLISHED
tcp4       0      0  192.168.1.1.56771      66.35.250.209.80       CLOSE_WAIT
tcp4       0      0  192.168.1.1.56766      192.168.1.100.280      CLOSE_WAIT
tcp4       0      0  192.168.1.1.56763      192.168.1.100.280      CLOSE_WAIT
tcp4       0      0  192.168.1.1.56758      192.168.1.100.280      CLOSE_WAIT
tcp4       0      0  127.0.0.1.6880         *.*                    LISTEN
tcp4       0      0  192.168.1.1.34662      219.140.94.223.3918    ESTABLISHED
tcp4       0  33948  192.168.1.1.34662      222.66.240.38.2772     FIN_WAIT_1
tcp4       0      0  192.168.1.1.53176      62.241.53.4.4242       ESTABLISHED
tcp4       0      0  127.0.0.1.25           *.*                    LISTEN

iptables doesn't existis, and I dont't have configure the firewall yet.

cat /etc/hosts | grep -i local

Quote
::1                     localhost.localdomain localhost
127.0.0.1               localhost.localdomain localhost
192.168.1.1             localhost.localdomain localhost
192.168.1.1             localhost.localdomain.
Logged
First of all, I apologize for my bad english. :D

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Webserver
« Reply #9 on: October 30, 2004, 01:36:09 AM »

Was amuleweb running while you did $ netstat -nptl? I guess (and hope) not. It would be nice if it was.

paste $ netstat -nptl | grep -i listen

Anyway, before that, try to remove these lines from /etc/hosts:
::1 localhost.localdomain localhost
192.168.1.1 localhost.localdomain localhost
192.168.1.1 localhost.localdomain.

Just leave this one:
127.0.0.1 localhost.localdomain localhost

See if it does any difference.
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Webserver
« Reply #10 on: November 02, 2004, 02:49:30 PM »

I have to say yes, amulewebserver was running when I did netstat...

I will remove those lines from /etc/hosts as soon as posible (now I have boot my computer under windows) and I will post the results.

Thanks for the anwers.
Logged
First of all, I apologize for my bad english. :D

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
It doesn't work
« Reply #11 on: November 02, 2004, 03:22:42 PM »

I have reboot my computer under FBSD, I have delete those lines, and It doesn't work  ;( ;( ;(
Logged
First of all, I apologize for my bad english. :D

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Webserver
« Reply #12 on: November 02, 2004, 04:42:13 PM »

What about $ netstat -nptul | grep -i listen? I did not see the amuleweb socket in your previous print. Look:

Code: [Select]
$ netstat -nptul | grep -i amule
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp        0      0 0.0.0.0:4711            0.0.0.0:*               LISTEN      22102/amuleweb
tcp        0      0 0.0.0.0:4712            0.0.0.0:*               LISTEN      22100/amule
tcp        0      0 0.0.0.0:8662            0.0.0.0:*               LISTEN      22100/amule
udp        0      0 0.0.0.0:4672            0.0.0.0:*                           22100/amule
udp        0      0 0.0.0.0:8665            0.0.0.0:*                           22100/amule
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Webserver
« Reply #13 on: November 07, 2004, 06:28:23 PM »

I'm sorry, but I needed the windows partition until today

netstat -ntulp tcp
Code: [Select]
Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)
tcp4       0         0            *.4711                          *.*                    LISTEN
« Last Edit: November 07, 2004, 06:28:46 PM by darksidex »
Logged
First of all, I apologize for my bad english. :D

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Webserver
« Reply #14 on: November 07, 2004, 10:05:10 PM »

Well, I see no problem with your configuration, except that you say it does not work. ?(

Are you sure you are running aMule before amuleweb? And that both are up at the same time when you try the web browser? I can't understand what is happening.
Logged
Pages: [1] 2