aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule 2.3.2 compiled with wxGTK2 v3.0.3 and Boost 1.65 // Ubuntu 18.04.3 LTS  (Read 4796 times)

iconoclasthero

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

Not sure if this is what is necessary:

Code: [Select]
#1913 0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
---Type <return> to continue, or q <return> to quit---q
Quit
(gdb) thread apply all bt

Thread 14 (Thread 0x7fffc1c99700 (LWP 15845)):
#0  0x00007ffff4f8ff85 in futex_abstimed_wait_cancelable (private=<optimized out>, abstime=0x7fffc1c987f0, expected=0, futex_word=0x555556324e00) at ../sysdeps/unix/sysv/linux/futex-internal.h:205
#1  0x00007ffff4f8ff85 in __pthread_cond_wait_common (abstime=0x7fffc1c987f0, mutex=0x5555560f0b50, cond=0x555556324dd8) at pthread_cond_wait.c:539
#2  0x00007ffff4f8ff85 in __pthread_cond_timedwait (cond=0x555556324dd8, mutex=0x5555560f0b50, abstime=0x7fffc1c987f0) at pthread_cond_wait.c:667
#3  0x00007ffff5ec1448 in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#4  0x00007ffff5ec2ad5 in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#5  0x00005555558d1993 in  ()
#6  0x00007ffff5ec2d52 in wxThread::CallEntry() () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#7  0x00007ffff5eca63c in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#8  0x00007ffff4f896db in start_thread (arg=0x7fffc1c99700) at pthread_create.c:463
#9  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 11 (Thread 0x7fffc3fff700 (LWP 15842)):
#0  0x00007ffff4f8f9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555555ddba10) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007ffff4f8f9f3 in __pthread_cond_wait_common (abstime=0x0, mutex=0x555555ddb9c0, cond=0x555555ddb9e8) at pthread_cond_wait.c:502
#2  0x00007ffff4f8f9f3 in __pthread_cond_wait (cond=0x555555ddb9e8, mutex=0x555555ddb9c0) at pthread_cond_wait.c:655
#3  0x00005555558f72f8 in  ()
#4  0x00005555558fb6cc in  ()
#5  0x00007ffff5ec2d52 in wxThread::CallEntry() () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#6  0x00007ffff5eca63c in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#7  0x00007ffff4f896db in start_thread (arg=0x7fffc3fff700) at pthread_create.c:463
#8  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 10 (Thread 0x7fffd8d08700 (LWP 15841)):
#0  0x00007ffff4f8f9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555555ddba10) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007ffff4f8f9f3 in __pthread_cond_wait_common (abstime=0x0, mutex=0x555555ddb9c0, cond=0x555555ddb9e8) at pthread_cond_wait.c:502
#2  0x00007ffff4f8f9f3 in __pthread_cond_wait (cond=0x555555ddb9e8, mutex=0x555555ddb9c0) at pthread_cond_wait.c:655
#3  0x00005555558f72f8 in  ()
---Type <return> to continue, or q <return> to quit---
#4  0x00005555558fb6cc in  ()
#5  0x00007ffff5ec2d52 in wxThread::CallEntry() () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#6  0x00007ffff5eca63c in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#7  0x00007ffff4f896db in start_thread (arg=0x7fffd8d08700) at pthread_create.c:463
#8  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 9 (Thread 0x7fffd9509700 (LWP 15840)):
#0  0x00007ffff4f8f9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555555ddba14) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007ffff4f8f9f3 in __pthread_cond_wait_common (abstime=0x0, mutex=0x555555ddb9c0, cond=0x555555ddb9e8) at pthread_cond_wait.c:502
#2  0x00007ffff4f8f9f3 in __pthread_cond_wait (cond=0x555555ddb9e8, mutex=0x555555ddb9c0) at pthread_cond_wait.c:655
#3  0x00005555558f72f8 in  ()
#4  0x00005555558fb6cc in  ()
#5  0x00007ffff5ec2d52 in wxThread::CallEntry() () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#6  0x00007ffff5eca63c in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#7  0x00007ffff4f896db in start_thread (arg=0x7fffd9509700) at pthread_create.c:463
#8  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7fffd9d0a700 (LWP 15839)):
#0  0x00007ffff4cb2bb7 in epoll_wait (epfd=13, events=0x7fffd9d09100, maxevents=128, timeout=-1) at ../sysdeps/unix/sysv/linux/epoll_wait.c:30
#1  0x00005555558f25cb in  ()
#2  0x00005555558f71a9 in  ()
#3  0x00005555558fb6cc in  ()
#4  0x00007ffff5ec2d52 in wxThread::CallEntry() () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#5  0x00007ffff5eca63c in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#6  0x00007ffff4f896db in start_thread (arg=0x7fffd9d0a700) at pthread_create.c:463
#7  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fffda50b700 (LWP 15838)):
#0  0x00007ffff4f93c60 in __GI___nanosleep (requested_time=0x7fffda50a910, remaining=0x0) at ../sysdeps/unix/sysv/linux/nanosleep.c:28
---Type <return> to continue, or q <return> to quit---
#1  0x00007ffff5ece1bc in wxMicroSleep(unsigned long) () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#2  0x00005555557a804a in  ()
#3  0x00007ffff5ec2d52 in wxThread::CallEntry() () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#4  0x00007ffff5eca63c in  () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#5  0x00007ffff4f896db in start_thread (arg=0x7fffda50b700) at pthread_create.c:463
#6  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fffe89aa700 (LWP 15813)):
#0  0x00007ffff4ca5bf9 in __GI___poll (fds=0x7fffe400c500, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ffff37035c9 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffff3703962 in g_main_loop_run () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffff162a0e6 in  () at /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007ffff372b195 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ffff4f896db in start_thread (arg=0x7fffe89aa700) at pthread_create.c:463
#6  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fffe91ab700 (LWP 15812)):
#0  0x00007ffff4ca5bf9 in __GI___poll (fds=0x7fffe4007d10, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ffff37035c9 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffff37036dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffff3703721 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffff372b195 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ffff4f896db in start_thread (arg=0x7fffe91ab700) at pthread_create.c:463
#6  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fffe99ac700 (LWP 15811)):
#0  0x00007ffff4ca5bf9 in __GI___poll (fds=0x555555e69fd0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ffff37035c9 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffff37036dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#3  0x00007fffe99b436d in  () at /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so
#4  0x00007ffff372b195 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ffff4f896db in start_thread (arg=0x7fffe99ac700) at pthread_create.c:463
#6  0x00007ffff4cb288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7ffff7fa2f00 (LWP 15804)):
#0  0x00007ffff6666dcb in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#1  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#2  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#3  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#4  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#5  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#6  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#7  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#8  0x00007ffff6666df5 in wxWindow::DoClientToScreen(int*, int*) const () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0

Logged

iconoclasthero

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

361 views...is there somewhere else I should be asking this question?  aMule keeps crashing and I just installed eMule on WINE to see if that is somehow better than the native application.  Any help is appreciated!
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1521
  • Unofficial Debian Packager
    • http://vollstreckernet.de

Have you tried the latest source. There have been changes in exactly this function.
Logged
Homefucking is killing prostitution

iconoclasthero

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

Have you tried the latest source. There have been changes in exactly this function.

Thanks for the response:

First, what is the latest source?
Second, where is the latest source?

I went to amule.org and the second most recent post is from 2016.09.16 which announces the release of 2.3.2.  If you go to [Download] it takes you to the Source Forge page to download the most recent version from 2016.09.17 which is also 2.3.2, the same version I stated I used in the subject of the OP.

If I am missing a beta or something else, please let me know where I may find it.

ih



Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1521
  • Unofficial Debian Packager
    • http://vollstreckernet.de

Latest source can be found on github: https://github.com/amule-project/amule/
Logged
Homefucking is killing prostitution

iconoclasthero

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

I ran
Code: [Select]
dpkg-buildpackage -us -uc -b -rfakerootand got these packages
Code: [Select]
amule-common_2.3.2+git-20190521_amd64.deb
amule-skin-gnome_2.3.2+git-20190521_amd64.deb
amule-skin-kde4_2.3.2+git-20190521_amd64.deb
amule-skin-mac-gray_2.3.2+git-20190521_amd64.deb
amule-skin-papirus_2.3.2+git-20190521_amd64.deb
amule-skin-priscilla_2.3.2+git-20190521_amd64.deb
amule-skin-tango_2.3.2+git-20190521_amd64.deb
amule-skin-xfce_2.3.2+git-20190521_amd64.deb
amule_2.3.2+git-20190521_amd64.deb
amule-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-ed2k-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-ed2k_2.3.2+git-20190521_amd64.deb
amule-cas-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-cas_2.3.2+git-20190521_amd64.deb
amule-wxcas_2.3.2+git-20190521_amd64.deb
amule-wxcas-dbgsym_2.3.2+git-20190521_amd64.ddeb
amuleweb_2.3.2+git-20190521_amd64.deb
amuleweb-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-remote-gui_2.3.2+git-20190521_amd64.deb
amule-remote-gui-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-daemon_2.3.2+git-20190521_amd64.deb
amule-daemon-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-alc_2.3.2+git-20190521_amd64.deb
amule-alc-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-alcc_2.3.2+git-20190521_amd64.deb
amule-alcc-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-cmd_2.3.2+git-20190521_amd64.deb
amule-cmd-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-plasmamule_2.3.2+git-20190521_amd64.deb
amule-plasmamule-dbgsym_2.3.2+git-20190521_amd64.ddeb
amule-utils_2.3.2+git-20190521_amd64.deb
amule-utils-gui_2.3.2+git-20190521_amd64.deb
amule-theme-default_2.3.2+git-20190521_amd64.deb
amule-xas_2.3.2+git-20190521_amd64.deb
amule-i18n-ar_2.3.2+git-20190521_amd64.deb
amule-i18n-ast_2.3.2+git-20190521_amd64.deb
amule-i18n-bg_2.3.2+git-20190521_amd64.deb
amule-i18n-ca_2.3.2+git-20190521_amd64.deb
amule-i18n-cs_2.3.2+git-20190521_amd64.deb
amule-i18n-da_2.3.2+git-20190521_amd64.deb
amule-i18n-de_2.3.2+git-20190521_amd64.deb
amule-i18n-el_2.3.2+git-20190521_amd64.deb
amule-i18n-en-gb_2.3.2+git-20190521_amd64.deb
amule-i18n-es_2.3.2+git-20190521_amd64.deb
amule-i18n-et-ee_2.3.2+git-20190521_amd64.deb
amule-i18n-eu_2.3.2+git-20190521_amd64.deb
amule-i18n-fi_2.3.2+git-20190521_amd64.deb
amule-i18n-fr_2.3.2+git-20190521_amd64.deb
amule-i18n-gl_2.3.2+git-20190521_amd64.deb
amule-i18n-he_2.3.2+git-20190521_amd64.deb
amule-i18n-hr_2.3.2+git-20190521_amd64.deb
amule-i18n-hu_2.3.2+git-20190521_amd64.deb
amule-i18n-it-ch_2.3.2+git-20190521_amd64.deb
amule-i18n-it_2.3.2+git-20190521_amd64.deb
amule-i18n-ja_2.3.2+git-20190521_amd64.deb
amule-i18n-ko-kr_2.3.2+git-20190521_amd64.deb
amule-i18n-lt_2.3.2+git-20190521_amd64.deb
amule-i18n-nn_2.3.2+git-20190521_amd64.deb
amule-i18n-nl_2.3.2+git-20190521_amd64.deb
amule-i18n-pl_2.3.2+git-20190521_amd64.deb
amule-i18n-pt-br_2.3.2+git-20190521_amd64.deb
amule-i18n-pt-pt_2.3.2+git-20190521_amd64.deb
amule-i18n-ru_2.3.2+git-20190521_amd64.deb
amule-i18n-sl_2.3.2+git-20190521_amd64.deb
amule-i18n-sq_2.3.2+git-20190521_amd64.deb
amule-i18n-sv_2.3.2+git-20190521_amd64.deb
amule-i18n-tr_2.3.2+git-20190521_amd64.deb
amule-i18n-uk_2.3.2+git-20190521_amd64.deb
amule-i18n-zh-cn_2.3.2+git-20190521_amd64.deb
amule-i18n-zh-tw_2.3.2+git-20190521_amd64.deb

I ran
Code: [Select]
$ sudo dpkg -i amule_2.3.2+git-20190521_amd64.deb
dpkg: warning: downgrading amule from 1:2.3.2-2 to 2.3.2+git-20190521
(Reading database ... 372463 files and directories currently installed.)
Preparing to unpack amule_2.3.2+git-20190521_amd64.deb ...
Unpacking amule (2.3.2+git-20190521) over (1:2.3.2-2) ...
dpkg: dependency problems prevent configuration of amule:
 amule depends on amule-common (= 2.3.2+git-20190521); however:
  Version of amule-common on system is 1:2.3.2-2.
 amule depends on amule-i18n-en-gb (= 2.3.2+git-20190521) | amule-i18n; however:
  Package amule-i18n-en-gb is not installed.
  Package amule-i18n is not installed.

dpkg: error processing package amule (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for menu (2.1.47ubuntu2.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 amule

I'm not clear which .deb is to be installed from the README file in the git clone.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1521
  • Unofficial Debian Packager
    • http://vollstreckernet.de

It says, it depends on "amule-i18n-en-gb (= 2.3.2+git-20190521) | amule-i18n" so it needs the named pkg, or some pkg that provides amule-i18n (little hint: all with i18n in their name do that). So just choose your lang.
Logged
Homefucking is killing prostitution

iconoclasthero

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

It says, it depends on "amule-i18n-en-gb (= 2.3.2+git-20190521) | amule-i18n" so it needs the named pkg, or some pkg that provides amule-i18n (little hint: all with i18n in their name do that. So just choose your lang.)

Ok, thanks...  But if there's not some sort of clear instructions for how to proceed from here, I'm going to have to pass on aMule at this time in favor of eMule over WINE.  At this point, I've downloaded and built the source from two different places so it isn't like I'm completely inept, but doing this broke APT/dpkg and I just don't have time to spend puzzing out what it is that you mean me to do for an application that may not necessarily resolve the problem.

//

I took one more crack at it:

I thought maybe I should try installing the debug packages, but that didn't work:
Code: [Select]
$ sudo dpkg -i amule-i18n-en-gb_2.3.2+git-20190521_amd64.deb amule-dbgsym_2.3.2+git-20190521_amd64.ddeb amule-daemon-dbgsym_2.3.2+git-20190521_amd64.ddeb amuleweb-dbgsym_2.3.2+git-20190521_amd64.ddeb amule-alc-dbgsym_2.3.2+git-20190521_amd64.ddeb amule-remote-gui-dbgsym_2.3.2+git-20190521_amd64.ddeb amule-wxcas-dbgsym_2.3.2+git-20190521_amd64.ddeb
(Reading database ... 372311 files and directories currently installed.)
Preparing to unpack amule-i18n-en-gb_2.3.2+git-20190521_amd64.deb ...
Unpacking amule-i18n-en-gb (2.3.2+git-20190521) over (2.3.2+git-20190521) ...
Selecting previously unselected package amule-dbgsym.
Preparing to unpack amule-dbgsym_2.3.2+git-20190521_amd64.ddeb ...
Unpacking amule-dbgsym (2.3.2+git-20190521) ...
Selecting previously unselected package amule-daemon-dbgsym.
Preparing to unpack amule-daemon-dbgsym_2.3.2+git-20190521_amd64.ddeb ...
Unpacking amule-daemon-dbgsym (2.3.2+git-20190521) ...
Selecting previously unselected package amuleweb-dbgsym.
Preparing to unpack amuleweb-dbgsym_2.3.2+git-20190521_amd64.ddeb ...
Unpacking amuleweb-dbgsym (2.3.2+git-20190521) ...
Selecting previously unselected package amule-alc-dbgsym.
Preparing to unpack amule-alc-dbgsym_2.3.2+git-20190521_amd64.ddeb ...
Unpacking amule-alc-dbgsym (2.3.2+git-20190521) ...
Selecting previously unselected package amule-remote-gui-dbgsym.
Preparing to unpack amule-remote-gui-dbgsym_2.3.2+git-20190521_amd64.ddeb ...
Unpacking amule-remote-gui-dbgsym (2.3.2+git-20190521) ...
Selecting previously unselected package amule-wxcas-dbgsym.
Preparing to unpack amule-wxcas-dbgsym_2.3.2+git-20190521_amd64.ddeb ...
Unpacking amule-wxcas-dbgsym (2.3.2+git-20190521) ...
dpkg: dependency problems prevent configuration of amule-i18n-en-gb:
 amule-i18n-en-gb depends on amule (= 2.3.2+git-20190521) | amule-daemon (= 2.3.2+git-20190521) | amuleweb (= 2.3.2+git-20190521) | amule-alc (= 2.3.2+git-20190521) | amule-remote-gui (= 2.3.2+git-20190521) | amule-wxcas (= 2.3.2+git-20190521); however:
  Package amule is not installed.
  Package amule-daemon is not installed.
  Package amuleweb is not installed.
  Package amule-alc is not installed.
  Package amule-remote-gui is not installed.
  Package amule-wxcas is not installed.

dpkg: error processing package amule-i18n-en-gb (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-dbgsym:
 amule-dbgsym depends on amule (= 2.3.2+git-20190521); however:
  Package amule is not installed.

dpkg: error processing package amule-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-daemon-dbgsym:
 amule-daemon-dbgsym depends on amule-daemon (= 2.3.2+git-20190521); however:
  Package amule-daemon is not installed.

dpkg: error processing package amule-daemon-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amuleweb-dbgsym:
 amuleweb-dbgsym depends on amuleweb (= 2.3.2+git-20190521); however:
  Package amuleweb is not installed.

dpkg: error processing package amuleweb-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-alc-dbgsym:
 amule-alc-dbgsym depends on amule-alc (= 2.3.2+git-20190521); however:
  Package amule-alc is not installed.

dpkg: error processing package amule-alc-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-remote-gui-dbgsym:
 amule-remote-gui-dbgsym depends on amule-remote-gui (= 2.3.2+git-20190521); however:
  Package amule-remote-gui is not installed.

dpkg: error processing package amule-remote-gui-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-wxcas-dbgsym:
 amule-wxcas-dbgsym depends on amule-wxcas (= 2.3.2+git-20190521); however:
  Package amule-wxcas is not installed.

dpkg: error processing package amule-wxcas-dbgsym (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 amule-i18n-en-gb
 amule-dbgsym
 amule-daemon-dbgsym
 amuleweb-dbgsym
 amule-alc-dbgsym
 amule-remote-gui-dbgsym
 amule-wxcas-dbgsym

So I tried leaving the debug packages where they were (since apparently I have to call them by package name instead of by file name):
Code: [Select]
$ sudo dpkg -i amule-i18n-en-gb_2.3.2+git-20190521_amd64.deb amule_2.3.2+git-20190521_amd64.deb  amule-daemon_2.3.2+git-20190521_amd64.deb amuleweb_2.3.2+git-20190521_amd64.deb amule-alc_2.3.2+git-20190521_amd64.deb amule-remote-gui_2.3.2+git-20190521_amd64.deb amule-wxcas_2.3.2+git-20190521_amd64.deb
(Reading database ... 372324 files and directories currently installed.)
Preparing to unpack amule-i18n-en-gb_2.3.2+git-20190521_amd64.deb ...
Unpacking amule-i18n-en-gb (2.3.2+git-20190521) over (2.3.2+git-20190521) ...
Selecting previously unselected package amule.
Preparing to unpack amule_2.3.2+git-20190521_amd64.deb ...
Unpacking amule (2.3.2+git-20190521) ...
Selecting previously unselected package amule-daemon.
Preparing to unpack amule-daemon_2.3.2+git-20190521_amd64.deb ...
Unpacking amule-daemon (2.3.2+git-20190521) ...
Selecting previously unselected package amuleweb.
Preparing to unpack amuleweb_2.3.2+git-20190521_amd64.deb ...
Unpacking amuleweb (2.3.2+git-20190521) ...
Selecting previously unselected package amule-alc.
Preparing to unpack amule-alc_2.3.2+git-20190521_amd64.deb ...
Unpacking amule-alc (2.3.2+git-20190521) ...
Selecting previously unselected package amule-remote-gui.
Preparing to unpack amule-remote-gui_2.3.2+git-20190521_amd64.deb ...
Unpacking amule-remote-gui (2.3.2+git-20190521) ...
Selecting previously unselected package amule-wxcas.
Preparing to unpack amule-wxcas_2.3.2+git-20190521_amd64.deb ...
Unpacking amule-wxcas (2.3.2+git-20190521) ...
dpkg: dependency problems prevent configuration of amule:
 amule depends on amule-common (= 2.3.2+git-20190521); however:
  Package amule-common is not installed.

dpkg: error processing package amule (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amuleweb:
 amuleweb depends on amule-web-templates; however:
  Package amule-web-templates is not installed.

dpkg: error processing package amuleweb (--install):
 dependency problems - leaving unconfigured
Setting up amule-i18n-en-gb (2.3.2+git-20190521) ...
Setting up amule-daemon (2.3.2+git-20190521) ...
Setting up amule-alc (2.3.2+git-20190521) ...
Setting up amule-remote-gui (2.3.2+git-20190521) ...
Setting up amule-wxcas (2.3.2+git-20190521) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for menu (2.1.47ubuntu2.1) ...
Errors were encountered while processing:
 amule
 amuleweb

So I tried ignoring the errors above, deleted an old ~/.aMule/mulelock, and ran it:

Code: [Select]
$ amule

(amule:16629): Gtk-WARNING **: 11:19:25.944: Unable to locate theme engine in module_path: "hcengine",
 2019-12-09 11:19:25: amuleAppCommon.cpp(335): Initialising aMule SVN compiled with wxGTK2 v3.0.4 (Debugging) (Snapshot: rev. gd157fe85d)
 2019-12-09 11:19:25: amuleAppCommon.cpp(382): Checking if there is an instance already running...
 2019-12-09 11:19:25: amuleAppCommon.cpp(413): No other instances are running.
 2019-12-09 11:19:30: ListenSocket.cpp(67): ListenSocket: Ok.
 2019-12-09 11:19:30: DownloadQueue.cpp(113): Loading temp files from /library3/torrent/downloading.
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 1 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 2 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 3 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 4 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 5 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 6 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 7 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 8 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 9 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 10 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 11 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 12 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 13 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(132): Loading PartFile 14 of 14
 2019-12-09 11:19:30: DownloadQueue.cpp(163): All PartFiles Loaded.
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/001.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/002.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/004.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/006.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/009.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/010.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/011.part.met to shares
 2019-12-09 11:19:30: SharedFileList.cpp(333): Adding file /library3/torrent/downloading/012.part.met to shares

An "aMule SVN rev. gd157fe85d" window appeared with all my files from eMule loaded in, but it is only marginally responsive at best...i.e., it is unusable.

Anyway, thanks for the help.


« Last Edit: December 09, 2019, 05:36:19 PM by iconoclasthero »
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1521
  • Unofficial Debian Packager
    • http://vollstreckernet.de

Ok, thanks...  But if there's not some sort of clear instructions for how to proceed from here

First point: From where?
Second Point: Clear instructions on using your package manager can be viewed on it's manpages or by just reading the output of the program itself.

I thought maybe I should try installing the debug packages, but that didn't work:
Code: [Select]
dpkg: dependency problems prevent configuration of amule-i18n-en-gb:
 amule-i18n-en-gb depends on amule (= 2.3.2+git-20190521) | amule-daemon (= 2.3.2+git-20190521) | amuleweb (= 2.3.2+git-20190521) | amule-alc (= 2.3.2+git-20190521) | amule-remote-gui (= 2.3.2+git-20190521) | amule-wxcas (= 2.3.2+git-20190521); however:
  Package amule is not installed.
  Package amule-daemon is not installed.
  Package amuleweb is not installed.
  Package amule-alc is not installed.
  Package amule-remote-gui is not installed.
  Package amule-wxcas is not installed.

dpkg: error processing package amule-i18n-en-gb (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-dbgsym:
 amule-dbgsym depends on amule (= 2.3.2+git-20190521); however:
  Package amule is not installed.

dpkg: error processing package amule-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-daemon-dbgsym:
 amule-daemon-dbgsym depends on amule-daemon (= 2.3.2+git-20190521); however:
  Package amule-daemon is not installed.

dpkg: error processing package amule-daemon-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amuleweb-dbgsym:
 amuleweb-dbgsym depends on amuleweb (= 2.3.2+git-20190521); however:
  Package amuleweb is not installed.

dpkg: error processing package amuleweb-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-alc-dbgsym:
 amule-alc-dbgsym depends on amule-alc (= 2.3.2+git-20190521); however:
  Package amule-alc is not installed.

dpkg: error processing package amule-alc-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-remote-gui-dbgsym:
 amule-remote-gui-dbgsym depends on amule-remote-gui (= 2.3.2+git-20190521); however:
  Package amule-remote-gui is not installed.

dpkg: error processing package amule-remote-gui-dbgsym (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amule-wxcas-dbgsym:
 amule-wxcas-dbgsym depends on amule-wxcas (= 2.3.2+git-20190521); however:
  Package amule-wxcas is not installed.

dpkg: error processing package amule-wxcas-dbgsym (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 amule-i18n-en-gb
 amule-dbgsym
 amule-daemon-dbgsym
 amuleweb-dbgsym
 amule-alc-dbgsym
 amule-remote-gui-dbgsym
 amule-wxcas-dbgsym

This can't work, because these packages just contain the debugging symbols for the packages, the program itself is still needed. That is what it tells you with the errors. It lists for every pkg what it is depending on.

Little hint: The "|" means "or".

So I tried leaving the debug packages where they were (since apparently I have to call them by package name instead of by file name):

If you install a pkg from a local file (using dpkg -i), you'll need the file-name. Everything else needs higher level tools like apt.

Code: [Select]
dpkg: dependency problems prevent configuration of amule:
 amule depends on amule-common (= 2.3.2+git-20190521); however:
  Package amule-common is not installed.

dpkg: error processing package amule (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of amuleweb:
 amuleweb depends on amule-web-templates; however:
  Package amule-web-templates is not installed.

dpkg: error processing package amuleweb (--install):
 dependency problems - leaving unconfigured
Setting up amule-i18n-en-gb (2.3.2+git-20190521) ...
Setting up amule-daemon (2.3.2+git-20190521) ...
Setting up amule-alc (2.3.2+git-20190521) ...
Setting up amule-remote-gui (2.3.2+git-20190521) ...
Setting up amule-wxcas (2.3.2+git-20190521) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for menu (2.1.47ubuntu2.1) ...
Errors were encountered while processing:
 amule
 amuleweb

So you managed to install 18n-en-gb, daemon, alc, remote-gui and wxcas at this point. amule itself has another dep to install (it tells you that).

So I tried ignoring the errors above, deleted an old ~/.aMule/mulelock, and ran it:

No point on that. If a package has errors of any type while installing, it is not installed.
Logged
Homefucking is killing prostitution

Bollya

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2

hi, a silly question.

why compile it if it is packaged in Ubuntu and works?  ::)
Logged