aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Error  (Read 4695 times)

d_k

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Error
« on: December 24, 2004, 07:13:15 PM »

Witam wsztstkich

Po zainstalowaniu aMule-2.0.0rc8-5mdk-10.1.i586.rpm próbowaBem uruchomi Amule i co[ mi nie idzie , wyrzuca mi taki komunikat:
Code: [Select]
[daniel@localhost daniel]$ amule
Initialising aMule
Saving userhash: 788F734AEF0ED30F4B07044894176FA1
Userhash loaded: 788F734AEF0ED30F4B07044894176FA1
*** UDP socket at 4665
No cryptkey.dat found, creating
*** reading servers

--------------------------------------------------------------------------------
OOPS! Houston, we have a situation: seems like aMule crashed!
Please, post these lines on the backtrace forum on [URL]http://www.amule.org/[/URL]
aMule version is: 2.0.0rc8 using wxGTK2 v2.5.3 (Unicoded)
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

[0] CamuleApp::OnFatalException() in amule[0x8243b63]
[1] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.5.so.3[0x40553143]
[2] CDirIterator::CDirIterator(wxString) in amule[0x80fa702]
[3] CDownloadQueue::Init() in amule[0x8133188]
[4] CamuleApp::OnInit() in amule[0x8246cf9]
[5] CamuleGuiApp::OnInit() in amule[0x824cdef]
[6] wxAppConsole::CallOnInit() in amule[0x824caf1]
[7] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.5.so.3[0x40503b77]
[8] __libc_start_main in /lib/tls/libc.so.6[0x40cf6ea0]
[9] wxMemoryDC::SetPen(wxPen const&) in amule[0x80cf4a1]

--------------------------------------------------------------------------------
Aborted
[daniel@localhost daniel]$

Czy wi kto[ o co mu chodzi??

prosze o pomoc
pzdr d_k
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Error
« Reply #1 on: December 24, 2004, 10:34:06 PM »

zaraz po wlaczeniu?

czy wxgtk jest ten samy jak w tym pack czy jakis inny ?

d_k

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Re: Error
« Reply #2 on: December 25, 2004, 12:57:58 PM »

Witam

W konsoli wpisuje mule no i amule wskakuje dosBownie na sekund i tyle go widziaBem , a w konsoli zostaje to co wkleiBem.

Amule instalowaBem z tej strony w razem z amule byBa spakowana wxgtk, i instalowaBem tylko to , jak odinstalowaBem to amule i zainstalowaBem to samo z plf ( ale to z plf mniej wa|y ) to wystarowaBo i tamto niby dziala tylko tam zle sie wy[wietlaj polskie znaki. PróbowaBe dodatkowo usunc rcznie ustawienia amule z systemu ale chyba gdzie[ zostaje bo po reinstalacji pamieta ustawienia.

PS Za pierwszym razem wystartowaBeo , zmieniBem tylko katalog temp i incoming
i wtedy wszystko padBo, my[laBem |e jak usun ustawienia z ./aMule to po reinstalacji bdzie dziaBaBo, ale nie dziaBa,  w aMule-2.0.0rc8 z zasobów plf zieniBem te katalogi i dziaBa, tak|e teraz caBkiem zgBupiaBem.
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Error
« Reply #3 on: December 25, 2004, 06:05:54 PM »

zrob:

rpm -qa | grep wx
rpm -qa | grep libwx

d_k

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Re: Error
« Reply #4 on: December 26, 2004, 05:43:35 PM »

[daniel@localhost daniel]$ rpm -qa | grep wx
wxGTK2.5-2.5.1-5mdk
libwxgtk2.5_1-2.5.1-5mdk
libwxgtk-gtk2u_2.5_3-2.5.3-5mdk
wxGTK2.5-2.5.1-5.1.101mdk
libwxgtk2.5_1-2.5.1-5.1.101mdk
[daniel@localhost daniel]$ rpm -qa | grep libwx
libwxgtk2.5_1-2.5.1-5mdk
libwxgtk-gtk2u_2.5_3-2.5.3-5mdk
libwxgtk2.5_1-2.5.1-5.1.101mdk
[daniel@localhost daniel]$
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Error
« Reply #5 on: December 26, 2004, 07:13:19 PM »

hi,

wyrzuc z kompa:

wxGTK2.5-2.5.1-5mdk
wxGTK2.5-2.5.1-5.1.101mdk
libwxgtk2.5_1-2.5.1-5mdk
libwxgtk2.5_1-2.5.1-5.1.101mdk

i zostaw tylko:

libwxgtk-gtk2u_2.5_3-2.5.3-5mdk

tak zeby po

rpm -qa | grep wx
rpm -qa | grep libwx

tylko libwxgtk-gtk2u_2.5_3-2.5.3-5mdk sie pokazalo

wtedy powinno dzialac

d_k

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Re: Error
« Reply #6 on: December 26, 2004, 11:07:04 PM »

usunoBem i nic z tego , i wywala takie co[


[daniel@localhost daniel]$ rpm -qa | grep wx
libwxgtk-gtk2u_2.5_3-2.5.3-5mdk
[daniel@localhost daniel]$ rpm -qa | grep libwx
libwxgtk-gtk2u_2.5_3-2.5.3-5mdk
[daniel@localhost daniel]$ amule
Initialising aMule
Userhash loaded: 788F734AEF0ED30F4B07044894176FA1
*** UDP socket at 4665
*** reading servers

--------------------------------------------------------------------------------
OOPS! Houston, we have a situation: seems like aMule crashed!
Please, post these lines on the backtrace forum on http://www.amule.org/
aMule version is: 2.0.0rc8 using wxGTK2 v2.5.3 (Unicoded)
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

  • CamuleApp::OnFatalException() in amule[0x8243b63]
  • [1] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.5.so.3
[0x40553143]
[2] CDirIterator::CDirIterator(wxString) in amule[0x80fa702]
[3] CDownloadQueue::Init() in amule[0x8133188]
[4] CamuleApp::OnInit() in amule[0x8246cf9]
[5] CamuleGuiApp::OnInit() in amule[0x824cdef]
[6] wxAppConsole::CallOnInit() in amule[0x824caf1]
[7] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.5.so.3[0x40503b77]
[8] __libc_start_main in /lib/tls/libc.so.6[0x40cf6ea0]
[9] wxMemoryDC::SetPen(wxPen const&) in amule[0x80cf4a1]

--------------------------------------------------------------------------------
Aborted
[daniel@localhost daniel]$
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Error
« Reply #7 on: December 26, 2004, 11:13:40 PM »

dziwne dziwne ..

mv .aMule .aMule2

mv .eMule .eMule2

i startuj teraz

d_k

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Re: Error
« Reply #8 on: December 27, 2004, 09:43:13 PM »

Witam

Teraz mam tak

[CODE][daniel@localhost daniel]$ rpm -qa | grep wx
libwxgtk-gtk2u_2.5_3-2.5.3-5mdk
libwxgtk2.5_1-2.5.1-5.1.101mdk
wxGTK2.5-2.5.1-5.1.101mdk
[daniel@localhost daniel]$ rpm -qa | grep libwx
libwxgtk-gtk2u_2.5_3-2.5.3-5mdk
libwxgtk2.5_1-2.5.1-5.1.101mdk
[daniel@localhost daniel]$[\CODE]

i dziaBa, nie wiem dlaczego , chyba co[ mu nie graBo w moim sytemie.
pzdr
d_k
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Error
« Reply #9 on: December 27, 2004, 09:50:07 PM »

jak dziala to dobrze ;)