aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Supporto per le nuove librerie GTK...  (Read 3399 times)

Sloteel

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Supporto per le nuove librerie GTK...
« on: December 28, 2004, 11:07:47 AM »

Magari sono l'unico qui con questo problema, ma adesso come adesso non posso usare amule perchè l'ultimo audacity vuole le GTK 2.5.x e il mulo si ostina (ci credo, se no che mulo è?) a funzionare solo con le 2.4.x...
Diciamo che mi farebbe proprio piacere poter tornare ad utilizzare il mulo senza disinstallare audacity ogni volta, magari se nella rc9 (sognando la 2.0.0 "stable") ci fosse il supporto per questo...

Grazie :baby:
Logged

Frankk

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 142
    • http://frankk.no-ip.com
Re: Supporto per le nuove librerie GTK...
« Reply #1 on: December 28, 2004, 11:13:13 AM »

aMule può essere compilato senza problemi sia per le 2.4.2 sia per le 2.5.3
Se hai installato dei pacchetti precompilati assicurati che siano compilati per la versione versione esatta di wxGTK che hai tu. In ogni caso non è detto che funzioni perchè tocca vedere che flag sono stati usati per compilare le wxgtk che hai tu. Comunque la cosa di sicuro migliore è che tu ti compili amule sulle tue wxgtk.
Qui trovi una guida:
http://www.amule.org/wiki/index.php/Compilation_Installation#Step_4:_aMule
Salta i passi riguardanti wxgtk wxbase e crypto e vai direttamente alla compilazione di aMule.

Ciao.
Frankk
Logged

King_Central

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
RE: Supporto per le nuove librerie GTK...
« Reply #2 on: January 14, 2005, 06:45:37 PM »

Ciao, senti io ho SuSE 9.2 e ho quindi dovuto togliere le gtk 2.5.3... mi hanno cmq detto in giro che sono buggate e abbastanza instabilili, da non preferirsi alle precedenti.
In ogni caso se installi dai sorgenti e forzi un installazione funziona tutto anche sulle wxgtk più recenti.
Logged

a-snu

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 21
  • è una questione di qualità ... decidersi di farla finita con qualcuno qualcosa ... una formalitÃ
    • http://www.romastyle.info
Re: Supporto per le nuove librerie GTK...
« Reply #3 on: January 14, 2005, 07:34:26 PM »

io sto usando il mulo con le wxGTK-2.5.3 con le flags gtk2 ed unicode attivate ... va una spada ed è integratissimo nel tema di gnome che ho installato

uso gentoo ed un ebuild moficato per amule adatto alle wxGTK-2.5.3 [lo trovi nel forum]
Logged
è una questione di qualità ... decidersi di farla finita con qualcuno qualcosa ... una formalità