aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: 10-11 Feb crash at start  (Read 4947 times)

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
10-11 Feb crash at start
« on: February 11, 2005, 04:58:14 PM »

This is the error at the start of aMule-cvs:

Code: [Select]
Oops, aMule crashed!
Hey, stop crying! You wanted the edge, and now you fell down?!
Please, post the following lines, on the aMule Crashes forum on:
    [URL]http://forum.amule.org/board.php?boardid=67&sid=/[/URL]
You should also try to generate a real backtrace of this error, please read:
    [URL]http://www.amule.org/wiki/index.php/Backtraces[/URL]
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

aMule version is: CVS using wxGTK1 v2.4.2 (Snapshot: Fri Feb 11 07:01:15 CET 2005)

[0] CamuleApp::OnFatalException() in amule[0x827e7c2]
[1] wxFatalSignalHandler in /usr/lib/libwx_gtk-2.4.so[0xb7e6debb]
[2] ?? in [0xffffe420]
[3] CPartFile::LoadSourceSeeds() in amule[0x81f0674]
[4] CDownloadQueue::LoadSourceSeeds() in amule[0x8137d35]
[5] CamuleApp::OnInit() in amule[0x827a6c8]
[6] CamuleGuiApp::OnInit() in amule[0x8284af1]
[7] wxEntry(int, char**) in /usr/lib/libwx_gtk-2.4.so[0xb7ccd59e]

--------------------------------------------------------------------------------
Network configuration failed! You can't configure UDP(TCP+3) port and UDP (extended eMule) port at the same port number. Please, change one of them.Aborted
/CODE]

What is
[CODE]Network configuration failed! You can't configure UDP(TCP+3) port and UDP (extended eMule) port at the same port number. Please, change one of them.
In the previous version I didn't see this warning  ?(

Truzzone  :(
« Last Edit: March 14, 2005, 04:29:37 PM by Truzzone »
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: 10-11 Feb crash at start
« Reply #1 on: February 11, 2005, 06:58:45 PM »

Network configuration failed! You can't configure UDP(TCP+3) port and UDP (extended eMule) port at the same port number. Please, change one of them.Aborted


you ahve a big time error in your amule settings,
go to your .eMule file and change the port nr for the UDP port!!!! then restart amule

you have the UDP port 3ports higher then your TCP port, this blocks the 2nd UDP port and so it crashes

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
Re: 10-11 Feb crash at start
« Reply #2 on: February 11, 2005, 07:17:45 PM »

Hi,
thanks for your reply.
I correct the port but aMule still crash.  :(
I returned to cvs-20050124 version, it work great.

Truzzone  :)
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: 10-11 Feb crash at start
« Reply #3 on: February 11, 2005, 07:29:44 PM »

ok, can you try to restart the "new" cvs again, and first!! delete the .eMule file in your home dir??
and see if it starts then

thnx for the help
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5822
Re: 10-11 Feb crash at start
« Reply #4 on: February 11, 2005, 07:31:40 PM »

I think I know what happens ;) If you still get that crash, go to your temp folder, and delete all "*.part.met.seeds"
Logged

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
RE: 10-11 Feb crash at start
« Reply #5 on: February 11, 2005, 08:00:39 PM »

I delete all .seeds in temp dir but remain the Oops always this at startup aMule-cvs:
Code: [Select]
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

aMule version is: CVS using wxGTK1 v2.4.2 (Snapshot: Fri Feb 11 07:01:15 CET 2005)

[0] CamuleApp::OnFatalException() in amule[0x827e7c2]
[1] wxFatalSignalHandler in /usr/lib/libwx_gtk-2.4.so[0xb7e6debb]
[2] ?? in [0xffffe420]
[3] CamuleApp::OnInit() in amule[0x827a6ae]
[4] CamuleGuiApp::OnInit() in amule[0x8284af1]
[5] wxEntry(int, char**) in /usr/lib/libwx_gtk-2.4.so[0xb7ccd59e]

--------------------------------------------------------------------------------
Aborted

Truzzone  ?(
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5822
Re: 10-11 Feb crash at start
« Reply #6 on: February 11, 2005, 08:17:10 PM »

gdb?
Logged

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
Re: 10-11 Feb crash at start
« Reply #7 on: February 11, 2005, 08:21:02 PM »

Quote
Originally posted by Kry
gdb?

What is gbd?
Sorry  :rolleyes:
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5822
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: 10-11 Feb crash at start
« Reply #9 on: February 11, 2005, 10:15:05 PM »

did you also delte the .eMule FILE like i said??
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Truzzone

  • Hero Member
  • *****
  • Karma: 2
  • Offline Offline
  • Posts: 1236
Re: 10-11 Feb crash at start
« Reply #10 on: March 14, 2005, 04:26:54 PM »

Quote
Originally posted by stefanero
did you also delte the .eMule FILE like i said??

Yeah! I delete the old .eMule config file in my home, run new aMule-cvs-20050309 and re-config the preferences, this version is more light than previous.  :D

[Edit]
Thanks for yours support & work
[/Edit]
« Last Edit: March 14, 2005, 04:32:40 PM by Truzzone »
Logged
"Tanta gente crede che dal momento che ha l'ADSL a 4Mega, deve scaricare a 4Mega altrimenti qualcosa non va. O è colpa dell'ISP o di aMule. La questione è invece ben diversa"