aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule 2.0.0rc8 e CVS - Disconnessione dopo 5 minuti  (Read 2788 times)

starnav

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
aMule 2.0.0rc8 e CVS - Disconnessione dopo 5 minuti
« on: February 15, 2005, 03:12:19 PM »

Salve a tutti, ho un grandissimo problema..

Uso debian sid, e sto cercando di fare l'upgrade di aMule..
attualmente sono costretto a usare la rc7, perchè la rc8 precompilata scaricata da apt, ad ogni avvio di amule, dopo 5 minuti (spesso sono precisi al secondo) vengo disconnesso con questo errore:

: Errore nel socket del server: Razorback 2(195.245.244.243:4661): 7
: Persa connessione a Razorback 2(195.245.244.243:4661)

anche riconnettendomi dopo un tempo a random mi disconnette, e alla lunga finisco nella blacklist.

La rc8 di apt è precompilata con wxWidgets 2.5.3
mentre la rc7 con le 2.4.2

pensando fosse un problema di versione quindi mi sono ricompilato a mano la rc8 dai sorgenti utilizzando le wxWidgets 2.4.2, ma mi disconnette cmq dopo 5 minuti...

Ho provato allora a prendere i sorgenti CVS di oggi 15 febbraio e l'ho ricompilato sempre con le 2.4.2, ma inutilmente dato che il problema persiste..

reinstallando la rc7 precompilata di apt, funziona tutto tranquillamente senza disconnessioni continue.

Altri hanno avuto esperienze del genere?  ?(
se il problema è nella rc8, e nella CVS probabilmente rimarrà anche nella 2.0.0final giusto?
sono destinato a rimanere sempre con la rc7 perchè è l'ultima versione funzionante?
premetto che in passato ho usato tutte le altre versioni di amule e non mi hanno mai dato problemi :(
Logged

starnav

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: aMule 2.0.0rc8 e CVS - Disconnessione dopo 5 minuti
« Reply #1 on: March 31, 2005, 06:48:37 PM »

Mi rispondo da solo:
ho abbassato le "nuove connessioni massime per 5 secondi" da 20 (default) a 13 e funziona addirittura meglio di prima, ora riesce a connettermi tutti i client, mentre prima avevo problemi di "troppe connessioni" verso alcuni utenti

probabilmente esiste un limite massimo di connessioni su linux e oltre al quale le nuove vengono droppate e da qui i problemi di disconnessione.
Logged