aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Display Problems with (Bulgarian) Translation  (Read 5216 times)

asg

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Display Problems with (Bulgarian) Translation
« on: February 19, 2005, 04:38:58 AM »

After I switched to Bulgarian, aMule fonts and the gui got messed up. I provide a snapshot from after the change (see the attachment).

I don't know whether this apply to the bulgarian translation only or is a general i18n bug. I think one would also expect to be able to change the language settings in the config file.  Well ~/.aMule/preferences.dat is a binary file, which is quite strange to me under Linux. I mean one would rather expect a text file with a .conf extension. As you can see in the screenshot, it is not possible to change the language from the gui, because the preferences icon is not visable (just to make another point on a text based configuration).

Additional Info:
I installed aMule via RPM-package for FC3 provided by freshrpms.net
The system language is English with installed support for German and Bulgarian
I'm using Fedora Core 3 with every offically released patch installed

Sorry if I'm double-posting, but the search system for your forums is quite unfortunate in my humble opinion. Your bug submitting system (Mantis or whatever it is called) is also poor.

Best regards
Anton
« Last Edit: February 19, 2005, 04:39:48 AM by asg »
Logged

thedude0001

  • evil bugfinder ;)
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 829
RE: Display Problems with (Bulgarian) Translation
« Reply #1 on: February 19, 2005, 06:53:58 AM »

Quote
Originally posted by asg
I don't know whether this apply to the bulgarian translation only or is a general i18n bug. I think one would also expect to be able to change the language settings in the config file.  Well ~/.aMule/preferences.dat is a binary file, which is quite strange to me under Linux. I mean one would rather expect a text file with a .conf extension. As you can see in the screenshot, it is not possible to change the language from the gui, because the preferences icon is not visable (just to make another point on a text based configuration).

OK, this is a little iritating and it's not very Linux conform, you have a point there  :)

Amules config files are still based on the original emule config files. In ~/.aMule/preferences.dat there is only your userhash stored which amule uses to identify to other clients (in combination with cryptkey.dat which is used for secure identification). Your config is saved as plain text in ~/.eMule as plain text. As I said, this is emule legacy, discussions are rising and falling like the tides if we should keep these filenames or make a break somehow. This will be changed at some point, only the exact point of time when his will happen is a little uncertain...  ;)
Logged
Das Schlimme auf dieser Welt ist
daß die Dummen so selbstsicher sind
und die Gescheiten so voller Zweifel.

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Display Problems with (Bulgarian) Translation
« Reply #2 on: February 19, 2005, 11:27:51 AM »

Check:

http://www.amule.org/wiki/index.php/Preferences.dat_file

Unless you want to drop eMule compatibility (if you do, you are alone at that point :P) this binary files will remain as they are.
The only thing that's "non-linux-conform" is the ~/.eMule file. And that is scheduled to be changed in some future, so no worries ;)

Greets!
Logged

asg

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Hmmm
« Reply #3 on: February 26, 2005, 09:44:29 AM »

Thanks for the info. I'll check the preferences in ~/.eMule to see whether there is a setting there which make it possible to change the language when I reinstall aMule. Even if there is such a possibility, the i18n-issue I mentioned remains (still no reaction from you whether it is aMule related or not).

I switched to giFT in the mean time as it seems to be a "native" linux p2p-client. Unfortunately they do not support the eDonkey network yet.
Logged

thedude0001

  • evil bugfinder ;)
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 829
Re: Display Problems with (Bulgarian) Translation
« Reply #4 on: February 26, 2005, 02:58:21 PM »

Umm, sorry for not really answering your question...
Check the ~/.eMule file, there's a line with 'Language=n'. Set it to 'Language=7' and amule should start up with the default english language. Taking a closer look at your screenshot I think you are missing a font that amule wants to use for the translation. But to be honest i don't really have an idea which font this could be  :(
Logged
Das Schlimme auf dieser Welt ist
daß die Dummen so selbstsicher sind
und die Gescheiten so voller Zweifel.

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Display Problems with (Bulgarian) Translation
« Reply #5 on: February 26, 2005, 03:51:02 PM »

the fonts come from your gtk-theme not from aMule or wxWidgets.
just get a gtk-theme switcher either for gtk1.2 or gtk2 depending on with what your amule runs, and you should be able to set your fonts.

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

asg

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Thanks
« Reply #6 on: February 28, 2005, 02:10:30 AM »

Thanks to both of you. These are satisfying answers.

@thedude0001: ~/.eMule was not removed after uninstalling aMule, so I was able to take a look at it. The language value was 3, I'll change that to 7. Thanks once again

@stefanero: I believe, I'll stuck with the default english language as it looks like too much effort just for an incomplete bulgarian translation. I'll try though to improve my knowlege on GTK+ and wxGTK, because I don't quite make the difference (both of them are sets of widgets, aren't they) and I don't understand the link between fonts and widgets (I thought widgets are simply put about what windows look like, and that there is a font server provided with X and a font engine (freetype2) to take care of how a font is being displayed). Further more Gnome is switching just fine between English, German and Bulgarian on my platform without switching the theme (I'm not sure whether it changes the font, it looks quite the same to me in every language, so I thought it uses a font capable of displaying characters in unicode or so). Because of my insufficient knowlege on this topic, I wasn't able to understand your point, so I would appreciate some help on the matter, if you of course could find the time for it (I'll understand if you could not)

Kind regards
Anton

________________________
Who needs Windows and Gates In a world without walls and fences
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Display Problems with (Bulgarian) Translation
« Reply #7 on: February 28, 2005, 07:25:46 AM »

hey

well its not that hard of an issue, it just takes some time and not to have the fear of compiling amule yourself.

the problem is of course that bulgarien language has some unicode letters, that are not standart ascii. and those are the display problems you get.

1.st you should remove all wx-packages on your system. you can check with
rpm -qa | grep wx
the once which are installed, doing that you will have to remove amule aswell.
2.nd download wxGTK 2.5.4 from http://www.wxwidgets.org
untar it and compile it with
./configure --enable-unicode --prefix=/usr/
at the end it should look kinda like this
Quote
Which GUI toolkit should wxWidgets use?                 GTK+ 2
  Should wxWidgets be compiled into single library?       no
  Should wxWidgets be compiled in debug mode?             yes
  Should wxWidgets be linked as a shared library?         yes
  Should wxWidgets be compiled in Unicode mode?           yes
  What level of wxWidgets compatibility should be enabled?
                                       wxWidgets 2.2      no
                                       wxWidgets 2.4      yes

now do make

and as ROOT
-make install
-ldconfig

4.th since wxWidgets is now installed in a unicode capable version download amule-cvs, since its the best version atm
http://amule.hirnriss.net
unbzip it and do
./configure and add the options you like ( webserver, amulecmd whatever you need)
then do
make
and as root
make install

when you are done, you should have a fully unicode enabled gtk2 amule. this should fix your display problems with the fonts of course aswell.

hope that helps
stefanero

PS. since you said the bulgarian translatiion is incomplete you are more then welcome to complete it if you find the time.
http://www.amule.org/wiki/index.php/Translations  -- this is a wiki page on howto do it.
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

asg

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Re: Display Problems with (Bulgarian) Translation
« Reply #8 on: March 10, 2005, 03:56:52 PM »

@stefanero

Thank you very much for your reply. Sorry for doing this so late, but I was busy on personal matters lately. Compling software is not a problem, I use rpms rather for the ease of uninstalling. Enabling unicode in wxGTK is reported to cause problems in the stable release. I'll get the development release upon your suggestion and try out your solution later.

As for the bulgarian translation - I'll get my greedy eyes on that

Kind regards
Anton
Logged

asg

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
it works
« Reply #9 on: March 10, 2005, 06:25:28 PM »

It works fine now

./configure commands used:
for wxGTK 2.5.4: ./configure --with-gtk --enable-gtk2 --enable-unicode --prefix=/usr/
        debug is not enabled
for aMule cvs 10.3.05: ./configure --enable-profile --enable-amulecmdgui --enable-wxcas --enable-utf8-systray

I wasn't sure which of these the configure script defaults to (./configure --help does not provide info on that), so I used everything I thought I would need.

With wxcas enabled one should also install gd. There is a warning if one doesn't.

I'm proceeding to the translation Wiki now  :)

Thanks a lot for your help
Cheers
Anton
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: Display Problems with (Bulgarian) Translation
« Reply #10 on: March 10, 2005, 06:41:05 PM »

no problem glad to hear it worked :)

thnx for the translation already ;)

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."