aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2] 3

Author Topic: aMule läuft nicht lange  (Read 2671 times)

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #15 on: December 20, 2019, 09:53:35 AM »

libboost-all-dev 1.65.1 scheint ein Metapaket zu sein, es schaufelt eine ganze Menge Paket drauf.
104 Pakete will er installieren, 307 MB.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1509
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #16 on: December 20, 2019, 10:09:38 AM »

Also bei debian und ubuntu wäre es libasio-dev
Logged
Homefucking is killing prostitution

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1509
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #17 on: December 20, 2019, 10:11:05 AM »

Theoretisch müsste er aber bevor er über die Version meckert noch sagen nach was genau er sucht, vielleicht fehlt eine andere Komponente.
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #18 on: December 20, 2019, 10:12:17 AM »

Ich habe mal das libbost-all installiert, scheint zu funktionieren.
Mal sehen ob ich dann nicht einige unnötige libs wieder runterhaue, ist doch recht bloat.
Derzeit lauft das make durch, mal sehen obs klappt.

EDIT: mit libasio-dev hats aber nicht geklappt.
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #19 on: December 20, 2019, 10:13:43 AM »

Bei der libasio-dev ist nur die 1:1.10.8-1 drauf
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #20 on: December 20, 2019, 10:35:51 AM »

Beim Start des amuled kam am Ende des Startvorganges noch:

2019-12-20 10:35:07: amuled: OnInit - Zeitmesser wird gestartet
 2019-12-20 10:35:07: Asio thread 1 started
 2019-12-20 10:35:07: Asio thread 3 started
 2019-12-20 10:35:07: Asio thread 4 started
 2019-12-20 10:35:07: Asio thread 2 started

Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #21 on: December 20, 2019, 10:37:11 AM »

Die GUI hat sich jetzt mehrfach beendet, kann man aber gleich wiede starten.
Ich lasse den amuled mal laufen wie er sich tut.
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #22 on: December 20, 2019, 01:48:09 PM »

Also der amuled läuft immer noch problemlos gestartet um 10:34, jetzt ist es 13:47.
Allerdings ist es nicht möglich amuled und das GUI zusammen länger laufen zu lassen.
Die GUI beendet sich mit einer Fehlermeldungs dass der amuled geschlossen wurde oder so was aber nicht stimmt, der amuled ist ganz normal weitergelaufen.
Wenn das aber das einzige Problem bleibt und alle bisherigen Geschichte sind kann ich damit leben.  :)
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #23 on: December 20, 2019, 11:03:05 PM »

Es läuft jetzt seit 10:34.
Gut so.
Welchen Grund könnte es denn haben dass das GUI relativ schnell den Kontakt zum amuled verliert und sich deshalb beendet?
Das Problem gibts so erst seit ich auf boost umgestellt habe, in den vorigen Versionen war das nicht.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1509
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #24 on: December 21, 2019, 12:29:17 PM »

Da kann ich nur spekulieren. Gibt es Meldungen auf der Konsole bei den beiden Programmen? Vielleicht hilft es auch, die GUI ohne boost zu verwenden.
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #25 on: December 21, 2019, 12:35:29 PM »

Beim amuled nicht, nix zu sehen, ich werde mal das GUI aus der Shell starten.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1509
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMule läuft nicht lange
« Reply #26 on: December 21, 2019, 12:55:46 PM »

Schreibt der daemon vielleicht ein logfile statt auf die konsole?
Logged
Homefucking is killing prostitution

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #27 on: December 21, 2019, 12:56:34 PM »

Code: [Select]
schutti@hell ~ $ amulegui

(amulegui:7049): Gtk-WARNING **: 12:36:00.687: Unable to locate theme engine in module_path: "adwaita",
 2019-12-21 12:36:00 (remote-GUI): Initialising aMuleGUI SVN compiled with wxGTK2 v3.0.4 and Boost 1.65 (Snapshot: rev. 11407)
 2019-12-21 12:36:00 (remote-GUI): Checking if there is an instance already running...
 2019-12-21 12:36:00 (remote-GUI): No other instances are running.
 2019-12-21 12:36:01 (remote-GUI): Asio thread 2 started
 2019-12-21 12:36:01 (remote-GUI): Asio thread 1 started
 2019-12-21 12:36:01 (remote-GUI): Asio thread 3 started
 2019-12-21 12:36:01 (remote-GUI): Asio thread 4 started
 2019-12-21 12:36:03 (remote-GUI): Verbinde...
 2019-12-21 12:36:03 (remote-GUI): Gehe in Ereignisschleife...
 2019-12-21 12:36:03 (remote-GUI): EC-Ereignissteuerung für entfernte Benutzeroberfläche
 2019-12-21 12:47:37 (remote-GUI): EC-Ereignissteuerung für entfernte Benutzeroberfläche
 2019-12-21 12:47:37 (remote-GUI): Beende...
schutti@hell ~ $

Bis 12:36:03 ist alles normal, der Rest ist der Absturz.
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #28 on: December 21, 2019, 12:58:36 PM »

Aus dem Logfile:

Code: [Select]
2019-12-21 12:19:26: Neue externe Verbindung akzeptiert
 2019-12-21 12:19:26: Verbinde mit Client: amule-remote 0x0001
 2019-12-21 12:19:26: Zugang gewährt.
 2019-12-21 12:26:11: Externe Verbindung getrennt.
 2019-12-21 12:36:03: Neue externe Verbindung akzeptiert
 2019-12-21 12:36:03: Verbinde mit Client: amule-remote 0x0001
 2019-12-21 12:36:03: Zugang gewährt.
!2019-12-21 12:36:09: Kad verbunden (firewalled)
!2019-12-21 12:36:09: Kad verbunden (ok)
 2019-12-21 12:54:07: Externe Verbindung getrennt.
Logged

Schuttwegraeumer

  • Sr. Member
  • ****
  • Karma: 2
  • Offline Offline
  • Posts: 397
Re: aMule läuft nicht lange
« Reply #29 on: December 21, 2019, 01:03:27 PM »

Aus dem remotelogfile:

Code: [Select]
2019-12-21 12:36:00 (remote-GUI): Initialising aMuleGUI SVN compiled with wxGTK2 v3.0.4 and Boost 1.65 (Snapshot: rev. 11407)
 2019-12-21 12:36:00 (remote-GUI): Checking if there is an instance already running...
 2019-12-21 12:36:00 (remote-GUI): No other instances are running.
 2019-12-21 12:36:01 (remote-GUI): Asio thread 2 started
 2019-12-21 12:36:01 (remote-GUI): Asio thread 1 started
 2019-12-21 12:36:01 (remote-GUI): Asio thread 3 started
 2019-12-21 12:36:01 (remote-GUI): Asio thread 4 started
 2019-12-21 12:36:03 (remote-GUI): Verbinde...
 2019-12-21 12:36:03 (remote-GUI): Gehe in Ereignisschleife...
 2019-12-21 12:36:03 (remote-GUI): EC-Ereignissteuerung für entfernte Benutzeroberfläche
!2019-12-21 12:36:03 (remote-GUI): Gelungen! Verbindung aufgebaut zu aMule SVN
 
 2019-12-21 12:36:03 (remote-GUI):  - Dies ist aMule SVN compiled with wxGTK2 v3.0.4 and Boost 1.65 (Snapshot: rev. 11407), basierend auf eMule.
 2019-12-21 12:36:03 (remote-GUI):    Läuft auf Linux 5.3.0-24-generic x86_64
 2019-12-21 12:36:03 (remote-GUI):  - Besuche http://www.amule.org um zu sehen, ob eine neue Version verfügbar ist.
 
 2019-12-21 12:36:03 (remote-GUI): Bereit
 2019-12-21 12:47:37 (remote-GUI): EC-Ereignissteuerung für entfernte Benutzeroberfläche
!2019-12-21 12:47:37 (remote-GUI): Verbindungsfehler
 2019-12-21 12:47:37 (remote-GUI): Beende...
 2019-12-21 12:54:07 (remote-GUI): aMule Dialog zerstört.
Logged
Pages: 1 [2] 3