aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: memory corruption "gelibc detected"  (Read 2592 times)

jauch

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
memory corruption "gelibc detected"
« on: June 11, 2005, 03:22:34 PM »

Hello to all!!!

I use SuSE 9.3 and i have this problem when i try to run emule...

eduardo@linux:~> amule
/home/eduardo/.kde/share/config/gtkrc:37: error: unexpected identifier `gtk-alternative-button-order', expected keyword - e.g. `style'
Initialising aMule
Checking if there is an instance already running...
*** glibc detected *** malloc(): memory corruption: 0x085bec40 ***
Abortado

The same error if i try to use version 2.0.1 of amule...

Is a problem with amule? Or is some lib that i have in my system that is older? how i get a newer version of glibc?

Any ideas?

Thanks to all...
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: memory corruption "gelibc detected"
« Reply #1 on: June 11, 2005, 03:50:03 PM »

I guess you probably downloaded from version from aMule
there are seperate rpms for 9.1 - 9.2 and 9.3
check if you really have the right one...

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

jauch

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Version of rpm is ok...
« Reply #2 on: June 12, 2005, 01:23:00 AM »

This is the rpm package that i downloaded...

aMule-2.0.2-1.i586-SuSE_9.3.rpm

For me, this look correct... Maybe i'm wrong... I don't know much of linux...
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: memory corruption "gelibc detected"
« Reply #3 on: June 12, 2005, 01:37:28 AM »

and which wxgtk rpm did u dl?

jauch

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
wxgtk
« Reply #4 on: June 12, 2005, 12:37:07 PM »

i dl the wxgtk from the site of amule.

The version that was instaled was older that amule requieres...
Then i upgraded the version with that that i found in the amule page...

I think that maybe was something in others libs that my system uses...
Maybe the version of glibc instaled is incompatible with the amule 2.0.1 e 2.0.2...
But i think that  not... A friend have the same system installed (SuSE 9.3) and on his computer, the amule works fine...

When i have SuSE 9.2 the amule 2.0.1 don't work tooo...
But a older version (i don't remember the version) was function then ...

I begins to think tha are something wrong with my hardware...  ?(

I really don't know what to do to make amule function in my system...
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
RE: wxgtk
« Reply #5 on: June 12, 2005, 02:00:53 PM »

Quote
Originally posted by jauch
i dl the wxgtk from the site of amule.


thats for sure, but what about to tell us the name ?

jauch

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Genius!!!!!!!!!!
« Reply #6 on: June 12, 2005, 02:16:32 PM »

You're a genius!!!!

 :baby:

LOL

I think that i already have installed the correct version of wxgtk, but the version installed is to SuSE 8.2-9.0-9.1

I installed the version to SuSE 9.2-9.3 and now works fine!!!

Thanks!!!!

And excuse me for be dummy like this...  :] lol
Logged