aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Compilando amule con kadmelia  (Read 3243 times)

xerkan

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Compilando amule con kadmelia
« on: August 30, 2005, 07:49:34 PM »

Hoy e intentado compilar el amule del cvs (con fecha 30-08-05) añadiendole la opcion para el soporte de kadmelia pero este no se quiso compilar, las opciones del configure que use son estas:

Code: [Select]
./configure --prefix=/usr/ --disable-embedded_crypto --enable-amulecmd --enable-webserver --enable-optimise --enable-amule-daemon --disable-debug --enable-gtk2 --enable-kad-compile

Este lo hizo correctamente mostrandome al final estos parametros:

Code: [Select]
Configure script has finished system check.

  Configured aMule CVS for 'i686-pc-linux-gnu'.

  aMule enabled options:

  **** aMule Core ****
  Prefix where aMule should be installed?                    /usr/
  Should aMule be compiled with i18n support?                yes
  Should aMule be compiled in debug mode?                    no
  Should aMule be compiled with profiling?                   no
  Should aMule be compiled with optimizations?               yes
  Should aMule be compiled with taskbar icon support?        yes
  Should aMule be compiled with old GTK taskbar icon?        no
  Should aMule be linked against patched gsocket?            no
  Should aMule monolithic application be built?              yes
  Should aMule daemon version be built?                      no
  Should aMule remote gui be built? (EXPERIMENTAL)           no
  Should aMule Kademlia code be compiled?                    yes
  Crypto++ library/headers style?                            gentoo_debian

  **** aMule TextClient ****
  Should aMule Command Line Client be built?                 yes
  Should aMule GUI Client be built?                          no

  **** aMule WebServer ****
  Should aMule WebServer be built?                           yes
  Should aMule WebServer GUI be built?                       no

  **** aMule ED2K Links Handler ****
  Should aMule ED2K Links Handler be built?                  yes

  **** aMuleLinkCreator ****
  Should aMuleLinkCreator GUI version (alc) be built?        no
  Should aMuleLinkCreator for console (alcc) be built?       no

  **** aMule Statistics ****
  Should C aMule Statistics (CAS) be built?                  no
  Should aMule GUI Statistics (wxCas) be built?              no

  **** General Libraries and Tools ****
  Should ccache support be enabled?                          no
  Libraries aMule will use to build:
                                       wxWidgets             2.6.1
                                       crypto++              5.2.1
                                       libpng                1.2.8
                                       libgd                 2.0.33
                                       zlib                  1.2.2

pero al hacer el make me dio el siguiente error:

Code: [Select]
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -march=athlon-xp -O3  -ffast-math -pipe -DUSE_WX_TRAY -I/usr//lib/wx/include/gtk2-unicode-release-2.6 -I/usr//include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1   -DXTHREADS -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -D__GTK2__   -D__COMPILE_KAD__ -march=athlon-xp -O3  -ffast-math -pipe -I/usr/include -D__CRYPTO_DEBIAN_GENTOO__  -O2  -MT amule-Indexed.o -MD -MP -MF ".deps/amule-Indexed.Tpo" -c -o amule-Indexed.o `test -f 'kademlia/kademlia/Indexed.cpp' || echo './'`kademlia/kademlia/Indexed.cpp; \
then mv -f ".deps/amule-Indexed.Tpo" ".deps/amule-Indexed.Po"; else rm -f ".deps/amule-Indexed.Tpo"; exit 1; fi
if g++ -DHAVE_CONFIG_H -I. -I. -I..   -march=athlon-xp -O3  -ffast-math -pipe -DUSE_WX_TRAY -I/usr//lib/wx/include/gtk2-unicode-release-2.6 -I/usr//include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1   -DXTHREADS -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -D__GTK2__   -D__COMPILE_KAD__ -march=athlon-xp -O3  -ffast-math -pipe -I/usr/include -D__CRYPTO_DEBIAN_GENTOO__  -O2  -MT amule-Kademlia.o -MD -MP -MF ".deps/amule-Kademlia.Tpo" -c -o amule-Kademlia.o `test -f 'kademlia/kademlia/Kademlia.cpp' || echo './'`kademlia/kademlia/Kademlia.cpp; \
then mv -f ".deps/amule-Kademlia.Tpo" ".deps/amule-Kademlia.Po"; else rm -f ".deps/amule-Kademlia.Tpo"; exit 1; fi
In file included from /usr/include/crypto++/oaep.h:5,
                 from /usr/include/crypto++/rsa.h:10,
                 from CryptoPP_Inc.h:35,
                 from kademlia/kademlia/Kademlia.cpp:399:
/usr/include/crypto++/sha.h:28: error: la declaración no declara nada}
/usr/include/crypto++/sha.h:28: error: storage class specified for typename
/usr/include/crypto++/sha.h:28: error: error de decodificación before numeric
   constant
/usr/include/crypto++/sha.h:42: error: la declaración no declara nada}
/usr/include/crypto++/sha.h:42: error: storage class specified for typename
/usr/include/crypto++/sha.h:42: error: error de decodificación before numeric
   constant
In file included from /usr/include/crypto++/osrng.h:9,
                 from CryptoPP_Inc.h:37,
                 from kademlia/kademlia/Kademlia.cpp:399:
/usr/include/crypto++/rng.h:71: error: error de decodificación before numeric
   constant
/usr/include/crypto++/rng.h:71: error: missing ';' before right brace
/usr/include/crypto++/rng.h: En member function `unsigned int
   CryptoPP::MaurerRandomnessTest::BytesNeeded() const':
/usr/include/crypto++/rng.h:64: error: `n' undeclared (first use this function)
/usr/include/crypto++/rng.h:64: error: (Each undeclared identifier is reported
   only once for each function it appears in.)
/usr/include/crypto++/rng.h: At global scope:
/usr/include/crypto++/rng.h:73: error: `unsigned int CryptoPP::n' used prior to
   declaration
/usr/include/crypto++/rng.h:74: error: `V' was not declared in this scope
/usr/include/crypto++/rng.h:77: error: error de decodificación before `}' token
make[4]: *** [amule-Kademlia.o] Error 1
make[4]: Leaving directory `/home/daniel/amule-cvs/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/daniel/amule-cvs/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/daniel/amule-cvs/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/daniel/amule-cvs'
make: *** [all] Error 2

Probe a compilarlo sin la opcion del kadmelia y se compilo bien asi que creo que me falta algo por instalar en mi equipo o es algun fallo del soporte de kadmelia
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Compilando amule con kadmelia
« Reply #1 on: August 31, 2005, 12:24:23 AM »

usa --enable-embedded-crypto con configure ;)
Logged