aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Crash when setting AcceptExternalConnections=1  (Read 157 times)

darioamule

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
Crash when setting AcceptExternalConnections=1
« on: November 15, 2021, 05:07:46 PM »

Hello,
I've compiled amule 2.3.3 from source on mac m1 on BigSur. I linked it to wxWidgets 3.0.5. I can only manage to run the executable in src/ but I am okay with it. I can search, I can download, but low ID.

I did compile it by myself because the Universal binary that you provide seems not have UPNP working... anyway I noticed that in the logs of connection it was saying that AcceptExternalConnections=0, so I enabled it and it crashes with:

Follows content of Apple crash window:

-------------------------------------
Translated Report (Full Report Below)
-------------------------------------

Process:               amule [35773]
Path:                  /Users/USER/Downloads/*/amule
Identifier:            amule
Version:               ???
Code Type:             ARM-64 (Native)
Parent Process:        zsh [35584]
Responsible:           Terminal [49925]
User ID:               501

Date/Time:             2021-11-15 16:05:18.4863 +0000
OS Version:            macOS 12.0.1 (21A559)
Report Version:        12
Anonymous UUID:        63EA2F88-EB76-9A1C-58D1-A2B44D917973

Sleep/Wake UUID:       97B14182-E157-4E32-947B-7059BF26220F

Time Awake Since Boot: 230000 seconds
Time Since Wake:       2234 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

VM Region Info: 0 is not in any region.  Bytes before following region: 4378148864
      REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
      UNUSED SPACE AT START
---> 
      __TEXT                      104f54000-105328000    [ 3920K] r-x/r-x SM=COW  ...loads/*/amule

Application Specific Information:
abort() called


Thread 0 Crashed::  Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib                  0x1ba0119b8 __pthread_kill + 8
1   libsystem_pthread.dylib                 0x1ba04515c pthread_kill + 288
2   libsystem_c.dylib                       0x1b9f82314 abort + 164
3   libwx_baseu-3.0.0.5.0.dylib             0x105e4eff4 wxFatalSignalHandler + 40
4   libsystem_platform.dylib                0x1ba05c4e4 _sigtramp + 56
5   amule                                   0x1050948a8 MuleNotify::DownloadCtrlUpdateItem(void const*) + 44
6   amule                                   0x1050948a8 MuleNotify::DownloadCtrlUpdateItem(void const*) + 44
7   amule                                   0x1050b39f4 CPartFile::SetFileName(CPath const&) + 172
8   amule                                   0x1050a446c CPartFile::LoadPartFile(CPath const&, CPath const&, bool, bool) + 6468
9   amule                                   0x104f9eb90 CDownloadQueue::LoadMetFiles(CPath const&) + 1636
10  amule                                   0x104f62274 CamuleApp::OnInit() + 3416
11  amule                                   0x105018270 CamuleGuiApp::OnInit() + 28
12  libwx_osx_cocoau_core-3.0.0.5.0.dylib          0x10600d0d4 wxApp::CallOnInit() + 156
13  libwx_baseu-3.0.0.5.0.dylib             0x105dd0cb0 wxEntry(int&, wchar_t**) + 48
14  amule                                   0x1050176cc main + 24
15  dyld                                    0x1058190f4 start + 520

sorry had to cut...


Then Amule backtrace:

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.3.3 compiled with wxOSX Cocoa v3.0.5
Running on: Mac OS X (Darwin 21.1.0 arm64)

0x1053824a8 : theApp in /Users/dario/Downloads/aMule-2.3.3/src/amule
0x1050176b4 : main in /Users/dario/Downloads/aMule-2.3.3/src/amule
0x1050176b4 : main in /Users/dario/Downloads/aMule-2.3.3/src/amule

--------------------------------------------------------------------------------
zsh: abort      /Users/dario/Downloads/aMule-2.3.3/src/amule
Logged