aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Novato en apuros...  (Read 4857 times)

BossPetta

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
    • http://ervdesign.net
Novato en apuros...
« on: September 21, 2005, 03:46:10 PM »

Buenas... soy un recien llegado a Linux, (SuSE 9.2).
Me he bajado aMule para ver si puedo instalarlo, que para i es una aventura xDD.
El caso es que he descomprimido el paquete y no se si tengo que hacer algo más...
Le doy a un archivo llamado amule.desktop y me dice que no encuentra el ejecultable... es que tengo que hacer algo más???
Gracias a Todos!!!
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Novato en apuros...
« Reply #1 on: September 21, 2005, 04:29:42 PM »

si bajas un archivo .tar.gz o .tar.bz2, tienes que compilarlo, es decir, crear el ejecutable. ya que lo que has bajado es el codigo fuente.

si estas realmetne interesado en compilarlo, abre una consola (en KDE, por ejemplo, Inicio -> Sistema -> Konsole), accede al directorio descomprimido (algo asi como: cd ~/amule-cvs/) ejecuta configure con los switches que quieras (configure --enable-kad-compile --enable-optimise --disable-debug --disable-verbose mira en configure --help las opciones que tienes) y a continuacion ejecuta "make" si todo esto salio correctamente.

Si te da igual compialr o no compilar, es MUCHO mas recomendable, mientras seas como dices "un novato", que bajes los binarios directamente, es decir, el programa ya compilado. Pedes encontrarlo buscando algo asi como "amule-2.0.3_SuSE_9.2.rpm" (lo de .rpm es lo importante, y asegurate que es para SuSE 9.2). Seguramente en la pagina de SuSE o en rpmdrake o algun programa similar de suse puedes bajartelo directamente de manera "oficial". sino, ve a http://dl.amule.org

un saludo!
Logged

BossPetta

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
    • http://ervdesign.net
Conflictos...
« Reply #2 on: September 22, 2005, 12:24:36 AM »

Gracias "Jacobo221"
Todo bien. Me bajé el paquete rpm. Pero al instalarlo con YaST me ha soltado una cantidad tremenda de conflictos, mira:
#### YaST2 conflicts list - generated 2005-09-22 00:37:09 ####

Conflicto acroread 5.09-6
    Dependencias rotas de los elementos instalados:
        acroread requiere libcurl.so.2
    Resoluciý de conflictos:
        ( ) Instalar la versiý anterior 5.09-6 de acroread-7.0.1-2.1
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
Conflicto aMule 2.0.3-1
    Requisitos sin resolver:
        aMule requiere libwx_base-2.6.so.0
        aMule requiere libwx_base-2.6.so.0(WX_2.6)
        aMule requiere libwx_base_net-2.6.so.0
        aMule requiere libwx_base_net-2.6.so.0(WX_2.6)
        aMule requiere libwx_base_xml-2.6.so.0
        aMule requiere libwx_gtk_adv-2.6.so.0
        aMule requiere libwx_gtk_adv-2.6.so.0(WX_2.6)
        aMule requiere libwx_gtk_core-2.6.so.0
        4 mý...
            aMule requiere libwx_gtk_core-2.6.so.0(WX_2.6)
            aMule requiere libwx_gtk_html-2.6.so.0
            aMule requiere libwx_gtk_qa-2.6.so.0
            aMule requiere libwx_gtk_xrc-2.6.so.0
    Resoluciý de conflictos:
        ( ) No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_base-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_base-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_base-2.6.so.0(WX_2.6) no disponible
    Requerido por:
        aMule requiere libwx_base-2.6.so.0(WX_2.6)
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_base_net-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_base_net-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_base_net-2.6.so.0(WX_2.6) no disponible
    Requerido por:
        aMule requiere libwx_base_net-2.6.so.0(WX_2.6)
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_base_xml-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_base_xml-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_adv-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_gtk_adv-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_adv-2.6.so.0(WX_2.6) no disponible
    Requerido por:
        aMule requiere libwx_gtk_adv-2.6.so.0(WX_2.6)
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_core-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_gtk_core-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_core-2.6.so.0(WX_2.6) no disponible
    Requerido por:
        aMule requiere libwx_gtk_core-2.6.so.0(WX_2.6)
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_html-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_gtk_html-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_qa-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_gtk_qa-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
libwx_gtk_xrc-2.6.so.0 no disponible
    Requerido por:
        aMule requiere libwx_gtk_xrc-2.6.so.0
    Resoluciý de conflictos:
        ( ) Eliminar el paquete correspondiente
            No instalar aMule
        ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema

#### YaST2 conflicts list END ###

Bestial, no?? debo tener algo mal instalado o yo que se, el caso es que no se si darle a que continue o no... que hago??
Logged

novato

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 21
problemas
« Reply #3 on: September 22, 2005, 10:29:10 AM »

Hola:

Yo tengo la misma version de SuSE que tu, o sea la 9.2. Me paso lo mismo que a ti.
Lo que has de hacer (si no recuerdo mal, fue).

1º-Bajate de la pagina http://www.amule.org el rpm de la libGTK-2.6.0 (para SuSE9.2) y lo instalas con YaST.
2º-Prueba a instalar el amule-rpm para SuSE9.2

Una vez hecho esto no deberia darte problemas con las libGTK, solo con acrorad.
En Linux a veces (como en tu caso) es necesario instalar unos programas antes del que tu quieres, esto es asi porque dichos programas comparten o usan las mismas librerias, pero solo uno de los rpm las instala.
De modo que si el programa "B" necesita la libreria "yoquese"
y no está, necesitas instalar primero el programa "A" que si la instala y luego instalar el "B". A esto se le conoce con el nombre de "dependencias" y has de resolverlas en un orden determinado. Hay un programa que resuelve estas dependencias que es APT (mira en la pagina de "apt for SuSE", pero no tengo experiencia con el y me parece que da algo de problemas con YaST, asi que si quieres informate, pero lo que hagas es a tu cuenta y riesgo, yo no lo uso)

En cuanto al tema de acroread, yo me instale la ultima version y me seguia dando problemas de la dependencia, pero me harte y con un par de... le dije a YaST que ignorara el conflicto. No he tenido problemas con nada, pero...

Suerte

 ;)
Logged

novato

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 21
Conflicto con libcurl.so.2
« Reply #4 on: December 05, 2005, 08:18:08 AM »

Hola BossPeta:

Resulta que queriendo instalar un programa (no me acuerdo cual y de todas maneras no viene al caso), me volví a encontrar con esta dependencia y rebuscando vi que para instalarla parece que has de instalar el paquete "compat-curl2".
Pues nada, que vaya bien.

Saludos

P.D: Pido disculpas al moderador si considera que esto está fuera de tópico pero yo creo que no.
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Novato en apuros...
« Reply #5 on: December 05, 2005, 04:53:15 PM »

en absoluto. de hecho, veo que yo no respndi, cosa rara ya que trato de responder a todos los posts. por algun motivo el foro no me aviso de que este thread habia aparecido.

soy yo quien pide disculpas por no haber respondido :(
Logged