aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: CVS-20050927 crashes - mismatch?  (Read 2471 times)

Attila

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 77
    • Ljubljana Phonology
CVS-20050927 crashes - mismatch?
« on: September 27, 2005, 12:53:49 PM »

I compiled the above snapshot with no complaints. I'm running Debian Etch 2.6.8 with the 2.6 wxgtk libs. I've seen this problem around but no real solutions (I tried using gcc-3.3 and 3.4 instead of 4.0 but always the same results.
Here's the output of running it.
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.6 (no debug,ANSI,compiler with C++ ABI 102,wx containers,compatible with 2.4),
and your program used 2.6 (no debug,ANSI,compiler with C++ ABI 1002,wx containers,compatible with 2.4).

I'm not sure what is out of synch with what (gcc and c++?). There's some discussion of problems associated with the upgrade of gcc to 4.0. Not sure what to change at this point.
Any ideas?
Thanks,
Jonathan
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1479
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: CVS-20050927 crashes - mismatch?
« Reply #1 on: September 27, 2005, 01:26:07 PM »

Can you show me the output of apt-cache policy wx....
Logged
Homefucking is killing prostitution

Attila

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 77
    • Ljubljana Phonology
mismatch
« Reply #2 on: September 27, 2005, 03:05:48 PM »

This is all I have of wx...
Attila:/home/jdkaye# apt-cache policy wx2.6-headers
wx2.6-headers:
  Installed: 2.6.1.2
  Candidate: 2.6.1.2
  Version Table:
 *** 2.6.1.2 0
        650 http://ftp.rediris.es testing/main Packages
        600 http://ftp.rediris.es unstable/main Packages
        100 /var/lib/dpkg/status
     2.6.1.1-2 0
        500 http://www.vollstreckernet.de testing/wx Packages
Jonathan
Logged

Attila

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 77
    • Ljubljana Phonology
mismatch solved.
« Reply #3 on: October 15, 2005, 08:54:10 AM »

I'm running two systems: Debian Etch i386 and Debian Sid amd64. I noticed that while I was having the mismatch problem with Etch, I had no trouble compiling cvs's with Sid. I went through the configure output for both systems looking for differences and I found this:
Sid: checking for wxWidgets version >= 2.4.2... yes (version 2.6.1) : the one that works
Etch : checking for wxWidgets version >= 2.4.2... yes (version 2.6.0) : the one that doesn't so...
I downloaded the source for wxWidgets 2.6.1 for Etch. (I know there's a more recent version but why take chances) and compiled it with gcc-4.0. Then I got a fresh copy (yesterday's) of amule's cvs and compiled it also using gcc-4.0. It compiled with no complaints and now runs fine. Problem solved. :D
Cheers,
Jonathan
Logged