aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: low id and Smoothwall Express trouble  (Read 2382 times)

frednet

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
low id and Smoothwall Express trouble
« on: October 30, 2005, 03:19:25 PM »

I've spent hours trying to get a high ID through my Smoothwall Express firewall with both machines on my network running Debian and Gentoo but nothing seems to work.
The network is as follows

192.168.0.1      Smoothwall Express firewall      firewall.frednet
192.168.0.3      Debian machine                         debian.frednet
192.168.0.4      Gentoo machine                        athlonxp.frednet

As you can see, the ip addresses are static and my Smoothwall ports are setup like this
         source IP    source port          dest IP       dest port
TCP  192.168.0.3    4662             192.168.0.3     4662
TCP  192.168.0.4    4662             192.168.0.4     4662

But when I test port 4662 from the amule website from either machine I get this

Error: TCP port 4662 is unavailable. Make sure your firewall or router is allowing/forwarding this TCP service port and your ED2K client is running (i.e. aMule, eMule).
Detailed Error Message
 TCP Error 111 Connection refused
Explanation
 The port is available for connections but a connection was refused meaning there is nothing listening on that port. This most likely means you can use ED2K but your client is not currently running. Try running this test again with an ED2K client running to make sure you can really establish a connection. No info available; this TCP error probably indicates a problem with the networking on your system (i.e. the TCP/IP stack).
Your public address is glfd-cache-6.server.ntli.net (62.252.0.9)
Coding by uberpenguin, idea by deltaHF, which he found here

As I'm a newbie I haven't a clue what I'm doing wrong, does this mean the port is opened correctly? As far as I know aMule is working fine as I can download files on both machines even with a low ID.
Can anyone out there explain to me what I'm doing wrong?
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
RE: low id and Smoothwall Express trouble
« Reply #1 on: October 30, 2005, 06:48:01 PM »

Quote
Originally posted by frednet

As you can see, the ip addresses are static and my Smoothwall ports are setup like this
         source IP    source port          dest IP       dest port
TCP  192.168.0.3    4662             192.168.0.3     4662
TCP  192.168.0.4    4662             192.168.0.4     4662


should  be

         source IP    source port          dest IP       dest port
TCP  192.168.0.1    4662             192.168.0.3     4662
TCP  192.168.0.1    ANOTHER PORT HERE             192.168.0.4     ANOTHER PORT HERE

1st:

you always forward from teh smothwall express firewall to the maschine in teh LAN, so check that you setup with right IP addresses....

2nd:
you CANT forward teh SAME port twice, on hte 2nd pc change the mule port so that you can use a different one

3rd:
for mule to work correct you need 3 ports, 4662/tcp, 4665/udp, 4672/udp!
or the once you changed in prefs


hope that helps
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."