aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: 20051108 - problemi con amuleweb [risolto]  (Read 3157 times)

Karhandras

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 47
20051108 - problemi con amuleweb [risolto]
« on: November 15, 2005, 09:24:10 PM »

Salve a tutti,
ho installato la CVS scaricata qualche giorno fa, ma ho dei problemi con amuleweb php...

Con le versioni precedenti avevo lo stesso problema, ma almeno prima potevo usare quello di default !

Praticamente dopo aver configurato il file amule.conf, lancio amuled -f, con il webserver, e apro l'indirizzo del mio server:4711; insersco la pass e arrivo alla schermata dei download... da qui pero' su qualsiasi altra tab (ricerca, server ecc...) faccia click, mi ritorna alla schermata di login!

Ho provato a vedere l'output di amuled senza fare il fork, ma non mi da' indicazioni se non

Code: [Select]
~/.aMule $ amuled
amuled: OnInit - starting timer
Initialising aMule
Checking if there is an instance already running...
Loading temp files from /share/.aMule/Temp.
Loading PartFile 7 of 7
All PartFiles Loaded.
22:32:57: Errore: Impossibile ottenere il nome ufficiale dell'host (errore 0: Success)
ListenSocket: Ok.

*** TCP socket (ECServer) listening on 0.0.0.0:4712
*** Server UDP socket (TCP+3) at 0.0.0.0:64665
*** TCP socket (TCP) listening on 0.0.0.0:64662
*** Client UDP socket (extended eMule) at 0.0.0.0:64672
Adding file /share/.aMule/Temp/001.part.met to shares
Adding file /share/.aMule/Temp/003.part.met to shares
Adding file /share/.aMule/Temp/008.part.met to shares
Adding file /share/.aMule/Temp/009.part.met to shares
Adding file /share/.aMule/Temp/010.part.met to shares
Adding file /share/.aMule/Temp/011.part.met to shares
Empty dir /share/.aMule/Incoming/ shared
Template default not found, reverting to default

22:33:06: Errore: Impossibile ottenere il nome ufficiale dell'host (errore 0: Success)
22:33:09: Errore: Impossibile ottenere il nome ufficiale dell'host (errore 0: Success)

inoltre questi due errori non avvengono mentre si presenta il problema, ma prima.

Ho anche provato a far partire amuled e il webserver a parte, ma in questo caso non mi fa fare neanche il login, dandomi questo output
Code: [Select]
--------------------------------------
|          aMule Web Server          |
--------------------------------------

Use 'Help' for command list

Web Server: Started

WSThread: Thread started
aMuleweb$ WSThread: created socket listening on :4711
WCThread: Started a new WCThread
Processing request [original]:
No session opened - will request login
Session created - requesting login
Session is not logged and request have no password
Processing request [redirected]: login.html
WCThread: exited [WebSocket closed]
WCThread: Started a new WCThread
Processing request [original]:
Session ok, not logged in
Checking password
Password bad
Processing request [redirected]: login.html
WCThread: exited [WebSocket closed]
WCThread: Started a new WCThread
Processing request [original]:
Session ok, not logged in
Checking password
Password bad
Processing request [redirected]: login.html
WCThread: exited [WebSocket closed]


Qualche idea?
« Last Edit: November 15, 2005, 11:15:39 PM by Karhandras »
Logged

Karhandras

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 47
Re: 20051108 - problemi con amuleweb [risolto]
« Reply #1 on: November 15, 2005, 10:06:51 PM »

mi correggo, quando riesco a entrare, se faccio click sulla tab di KAD, non fa nulla... unica eccezzione a quanto detto sopra :)

A proposito... dovrebbe fare qualcosa?
Logged

Karhandras

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 47
Re: 20051108 - problemi con amuleweb [risolto]
« Reply #2 on: November 15, 2005, 11:15:24 PM »

Risolto tutto, il problema e', credo :P , che usando l'estensione 'fasterfox' di firefox si creano dei problemi riguardo alla sessione, cosi' ogni volta che si cambia pagina, la sessione risulta non registrata!

E' stato sufficiente disinstallare l'estensione per far funzionare il webserver.
Logged