aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: used to crash very often. Now it doesn't start anymore at all.  (Read 2029 times)

Ben1979

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
used to crash very often. Now it doesn't start anymore at all.
« on: January 25, 2006, 04:49:31 PM »

I am sure I have the latest versions of everything. After crashing all the time I even installed a recent CVS, and made it run. I already tried to find more stable substitutes for amule, spending a lot of time rehashing all files for different applications but ended up coming back to amule. Now this again! It doesn't start anymore. Please help, tell me what to do or fix it. Should I try again with a newer CVS?
Thanks.

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------Current version is: aMule CVS using wxGTK2 v2.6.2 (Unicoded) (Snapshot: Sat Dec 17 07:02:01 CET 2005)
Running on: Linux 2.6.12-10-386 i686

[2] CamuleApp::OnFatalException() in amule.cpp:1119
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.6.so.0[0xb79fd8b6]
[4] ?? in [0xffffe420]
[5] wxMBConv::cMB2WC(char const*, unsigned int, unsigned int*) const in /usr/lib/libwx_baseu-2.6.so.0[0xb79b8d25]
[6] wxString::wxString(char const*, wxMBConv&, unsigned int) in /usr/lib/libwx_baseu-2.6.so.0[0xb79c178d]
[7] wxMsgCatalogFile::FillHash(wxMessagesHash&, wxString const&, bool) const in /usr/lib/libwx_baseu-2.6.so.0[0xb79a31cb]
[8] wxMsgCatalog::Load(wchar_t const*, wchar_t const*, wchar_t const*, bool) in /usr/lib/libwx_baseu-2.6.so.0[0xb79a91cb]
[9] wxLocale::AddCatalog(wchar_t const*, wxLanguage, wchar_t const*) in /usr/lib/libwx_baseu-2.6.so.0[0xb79a9f6b]
[10] wxLocale::AddCatalog(wchar_t const*) in /usr/lib/libwx_baseu-2.6.so.0[0xb79aa1f2]
[11] wxLocale::Init(wchar_t const*, wchar_t const*, wchar_t const*, bool, bool) in /usr/lib/libwx_baseu-2.6.so.0[0xb79aa303]
[12] wxLocale::Init(int, int) in /usr/lib/libwx_baseu-2.6.so.0[0xb79aa59f]
[13] InitLocale(wxLocale&, int) in OtherFunctions.cpp:1312
[14] CamuleApp::Localize_mule() in amule.cpp:1129
[15] CamuleApp::OnInit() in amule.cpp:522
[16] CamuleGuiApp::OnInit() in amule-gui.cpp:318
[17] wxAppConsole::CallOnInit() in app.h:87
[18] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.6.so.0[0xb79a12fa]
[19] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.6.so.0[0xb79a13fe]
[20] main in amule-gui.cpp:145
[21] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xb7702ea2]
[22] __gxx_personality_v0 in start.S:122
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: used to crash very often. Now it doesn't start anymore at all.
« Reply #1 on: January 25, 2006, 05:03:37 PM »

bug on wx 2.6.2. Disable NLs, or use wxCVS
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: used to crash very often. Now it doesn't start anymore at all.
« Reply #2 on: January 25, 2006, 06:29:50 PM »

Or search this forum for a patch. ;)
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: used to crash very often. Now it doesn't start anymore at all.
« Reply #3 on: January 25, 2006, 08:21:50 PM »

if you have the patch you have to recompile wxGTK tho ;)
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."