aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: libupnp not detected by configure in Ubuntu 20.04.1  (Read 1474 times)

Menion

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 95
  • Winter is coming...
libupnp not detected by configure in Ubuntu 20.04.1
« on: September 22, 2020, 10:23:30 AM »

Hi all

I am trying to compile latest code on Ubuntu server 20.04.1 with the following configure command:

Code: [Select]
./configure --disable-monolithic --with-toolkit=base --enable-amule-daemon --enable-amulecmd --enable-webserver --with-boost --enable-optimize
I have installed the repository version of libupnp-dev which is:

Code: [Select]
(1:1.8.4-2ubuntu2)
However configure does not find it:

Code: [Select]
checking for libupnp version >= 1.6.6... no (pkg-config not found)
configure: WARNING: UPnP code has been disabled because libupnp >= 1.6.6 not found (pkg-config not found).
I see that some deb s have been succesfully built, so I am wondering what may be the issue here
Logged

Menion

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 95
  • Winter is coming...
Re: libupnp not detected by configure in Ubuntu 20.04.1
« Reply #1 on: September 22, 2020, 10:41:30 AM »

Sorry, it was just missing pkg-config
Logged