aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Help! aMule and wxGTK-2.4.2-3  (Read 3292 times)

luke_old_boy

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Help! aMule and wxGTK-2.4.2-3
« on: March 09, 2004, 11:37:00 AM »

Hallo,
 I have a problem running both aMule(latest version) and videoLAN(0.7.1, latest) on a Fedora Core 1(kernel 2.4.22-2115.nptl). aMule requires wxGTK-2.4.2-1 , and videoLAN requires wxGTK-2.4.2-3; if I install the -1 version , aMule will work quietly, but videoLAN returns "Segmentation fault". With -3 release, videoLAN works properly, but aMule returns this message:
Initialising aMule
 
OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--
 
  • amule(_ZN9CamuleApp16OnFatalExceptionEv+0x3b) [0x81bd07f]
  • [1] /usr/lib/libwx_gtk-2.4.so.0(wxFatalSignalHandler+0x2d)
[0xcc0c7d]
[2] /lib/tls/libpthread.so.0 [0x7e2f18]
[3] /usr/lib/libwx_gtk-2.4.so.0(_ZN8wxString10AssignCopyEjPKc+0x6d) [0xc6cced]
[4] /usr/lib/libwx_gtk-2.4.so.0(_ZN8wxStringaSEPKc+0x3e) [0xc6ce4e]
[5] /usr/lib/libwx_gtk-2.4.so.0(_ZN12wxHtmlWindow4InitEv+0xd1) [0xce4131]
[6] amule(_ZN10CServerWndC1EP8wxWindow+0x134) [0x8187b40]
[7] amule(_ZN9CamuleDlgC1EP8wxWindow8wxString+0x394) [0x81be754]
[8] amule(_ZN9CamuleApp6OnInitEv+0x655) [0x81b9dc1]
[9] /usr/lib/libwx_gtk-2.4.so.0(_Z7wxEntryiPPc+0x228) [0xb3e468]
[10] amule(main+0x17) [0x81b930b]
[11] /lib/tls/libc.so.6(__libc_start_main+0xf0) [0x563750]
[12] amule(_ZN18wxBaseArrayPtrVoidD2Ev+0x31) [0x80916e1]

Can you give me a solution?

Thanks
Luca
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5822
Re: Help! aMule and wxGTK-2.4.2-3
« Reply #1 on: March 09, 2004, 10:25:14 PM »

What happens if you install the wxGTk from our webpage?
Logged