aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: "More" button is always disabled :(  (Read 3768 times)

tonnzor

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
"More" button is always disabled :(
« on: January 01, 2008, 02:57:26 PM »

Button "More" exists on "Search" panel, but it's always disabled. Does anybody know how to enable it?

My search matches ~10000 files, but server is configured to show 2000 items only. As far as I know, "More" button should download next 2000 files, so I could get all the matches.

However, this button is simply disabled :(
« Last Edit: January 03, 2008, 12:46:40 AM by tonnzor »
Logged

skolnick

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 24
  • Offline Offline
  • Posts: 1188
  • CentOS 6 User
Re: How to enable "More" button for search
« Reply #1 on: January 01, 2008, 08:29:47 PM »

I think the button gets disabled when you reach a maximum amount of search results. For example, when I do server searches, I get 300 results, and pressing "more" will bring 300 more, and so until some limit (2000 I think).

Regards.
Logged

tonnzor

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: How to enable "More" button for search
« Reply #2 on: January 03, 2008, 12:44:46 AM »

I think the button gets disabled when you reach a maximum amount of search results. For example, when I do server searches, I get 300 results, and pressing "more" will bring 300 more, and so until some limit (2000 I think).

The problem is that "More" button is never enabled :(

My search returns 2000 matches (I know that real number is >4000) just after I press "Search", however "More" button is disabled. As far as I know server is configured to limit 2000 matches per request (just like you have 300).

I will try the same query using latest eMule tomorrow and report here. Seems like a bug.
Logged

skolnick

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 24
  • Offline Offline
  • Posts: 1188
  • CentOS 6 User
Re: "More" button is always disabled :(
« Reply #3 on: January 03, 2008, 04:44:07 AM »

You are right, the more button is always disabled, I also did a global search that would usually return lots of results, but after the first 300, the more button would remain disabled. Funny how this used to work, and got broken some time ago, and I didn't even noticed it.

Regards.
Logged