aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2] 3

Author Topic: Ubuntu packages  (Read 123809 times)

habichauch

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Ubuntu packages
« Reply #15 on: May 25, 2009, 09:22:53 PM »

hello,
first, thx for the good packackes. The 2.2.5 packages from May 16 were alright!

Installed with "apt-get update":
/etc/apt/sources.list:
 deb http://ppa.launchpad.net/amule-releases/ppa/ubuntu intrepid main

Since I updated today with the newer 2.2.5 version with "apt-get update" there is a problem:
The daemon started alright (also there is no error in the logfile):

user@serverxy:~# /etc/init.d/amuled start
Starting amuled: amuled: OnInit - starting timer
Initialising aMuled 2.2.5 using wxGTK2 v2.8.10
Checking if there is an instance already running...
No other instances are running.
ListenSocket: Ok.
amuled: forking to background - see you
amuled.

But I cannot start the graphical "amulegui" on this machine:
user@serverxy:~$ amulegui
amulegui: /usr/local/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.10' not found (required by /usr/lib/libwx_gtk2u_core-2.8.so.0)

perhaps, you've an idea. here the dpkg.log:
2009-05-25 20:45:20 status installed man-db 2.5.2-2
2009-05-25 20:45:21 status installed libwxbase2.8-0 2.8.10.1-0intrepid1~ppa3
2009-05-25 20:45:21 status installed amule-common 2.2.5-0ubuntu1~intrepid3
2009-05-25 20:45:21 status installed amule-daemon 2.2.5-0ubuntu1~intrepid3
2009-05-25 20:45:21 status installed amule-utils 2.2.5-0ubuntu1~intrepid3
2009-05-25 20:45:21 status installed libwxgtk2.8-0 2.8.10.1-0intrepid1~ppa3
2009-05-25 20:45:21 status installed amule-utils-gui 2.2.5-0ubuntu1~intrepid3
2009-05-25 20:45:21 status installed libc6 2.8~20080505-0ubuntu9


user@serverxy:~# dpkg -l |grep wxgt
ii  libwxgtk2.8-0                             2.8.10.1-0intrepid1~ppa3                                   wxWidgets Cross-platform C++ GUI toolkit (GT
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: Ubuntu packages
« Reply #16 on: May 26, 2009, 12:14:09 AM »

Compiled with  wxwidgets 2.8.10.1
Hmm - what's 2.8.10.1 ? Only 2.8.10 has been released afaik.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #17 on: May 26, 2009, 12:19:47 PM »

But I cannot start the graphical "amulegui" on this machine:
user@serverxy:~$ amulegui
amulegui: /usr/local/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.10' not found (required by /usr/lib/libwx_gtk2u_core-2.8.so.0)

Thanks for report it. I'll see if I can fix it  :-\

You could test whether the same problem occurs with the deb packages from this repository:-\

Compiled with  wxwidgets 2.8.10.1
Hmm - what's 2.8.10.1 ? Only 2.8.10 has been released afaik.

See http://www.wxpython.org/recentchanges.php

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: Ubuntu packages
« Reply #18 on: May 26, 2009, 12:42:14 PM »

That's wxPython, not wxWidgets. I don't think it's meant to be used for anything else than building wxPython.
It's WX_2_8_BRANCH SVN 60605, while 2.8.10 is 59585. 63 changes, can't say if anything is relevant for aMule.
If you want cutting edge you could just as well use SVN (WX_2_8_BRANCH).
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #19 on: May 26, 2009, 12:47:56 PM »

See: http://packages.ubuntu.com/source/jaunty/wxwidgets2.8

If I only package wxgtk probably I will break any update of this library in Ubuntu.

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu packages
« Reply #20 on: May 26, 2009, 01:19:03 PM »

You could just use the ones from ubuntu. The ones from debian 2.8.7.1 work, so why the effort for using a newer one?
Logged
Homefucking is killing prostitution

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: Ubuntu packages
« Reply #21 on: May 26, 2009, 03:15:26 PM »

The ones from debian 2.8.7.1 work, so why the effort for using a newer one?
Because devs will infailingly answer "please try a current wxWidgets version" if anybody reports a crash with wx 2.8.7.  :P

If I only package wxgtk probably I will break any update of this library in Ubuntu.
OK, I will shut up about packaging mysteries.  :-X
Personally, I'd link the whole thing static. No dependencies, no hassle. Just one executable, and good.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #22 on: May 26, 2009, 05:30:06 PM »

But I cannot start the graphical "amulegui" on this machine:
user@serverxy:~$ amulegui
amulegui: /usr/local/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.10' not found (required by /usr/lib/libwx_gtk2u_core-2.8.so.0)

Thanks for report it. I'll see if I can fix it  :-\

You could test whether the same problem occurs with the deb packages from this repository:-\

Well, I can't reproduce the bug...

I can run amulegui without any problem:

Quote
Connecting...
Going to event loop...
Remote GUI EC event handler
LOG: Succeeded! Connection established to aMule 2.2.5
LOG:
LOG:  - This is aMule 2.2.5 using wxGTK2 v2.8.10 based on eMule.
LOG:    Running on Linux 2.6.28-11-generic i686
LOG:  - Visit http://www.amule.org to check if a new version is available.
LOG:
LOG: Loaded 248 flag bitmaps.

I suggest you uninstall all packages (amule and wxgtk) and make a fresh install, perhaps there was a problem in updating of wxwidgets packages...

       
Or you can try these packages, but should be the same as in my repository.
« Last Edit: May 26, 2009, 05:32:26 PM by Festor »
Logged

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #23 on: May 27, 2009, 09:45:30 PM »

I uploaded a new build that fixes a small problem with the integration of  emulecollections files.

Now it should work fine... ::)

tHatdUde

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Ubuntu packages
« Reply #24 on: May 29, 2009, 04:10:23 AM »

Thank you, I was already using amule-emc, so I did not notice that it was included  :D

If you want to add support for elinks in konqueror it can be done by adding the file:
/usr/share/services/ed2k.protocol

with this content:

Code: [Select]
[Protocol]
exec=ed2k '%u'
protocol=ed2k
input=none
output=none
helper=true
listing=false
reading=false
writing=false
makedir=false
deleting=false
Logged

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #25 on: May 29, 2009, 10:34:45 AM »

Thank you, I was already using amule-emc, so I did not notice that it was included  :D

The truth is that amule-emc (or this) is not used but the system uses the command 'ed2k -e'.

If you want to add support for elinks in konqueror it can be done by adding the file:
/usr/share/services/ed2k.protocol

with this content:

Code: [Select]
[Protocol]
exec=ed2k '%u'
protocol=ed2k
input=none
output=none
helper=true
listing=false
reading=false
writing=false
makedir=false
deleting=false

Thanks!  :o :o

I will try it when I have time...  :-\
« Last Edit: May 29, 2009, 11:35:26 AM by Festor »
Logged

habichauch

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Ubuntu packages
« Reply #26 on: June 07, 2009, 07:24:55 PM »

hello,
no chance. I removed all relevant packages and reinstalled them. no change.

Than I only removed libwxgtk2.8-0 and amule-utils-gui (your last one, 2.5) and installed the old amule-utils-gui 2.2. amulegui runs without problem.

After re-installation of these 2 packages, I have the same problem.  Perhabs this is a problem with this build of libwxgtk2.8-0, perhaps because of my 64bit-Ubuntu (Intrepid Ibex 8.10).

userxy@serverxy:~$ amulegui
amulegui: /usr/local/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.10' not found (r
equired by /usr/lib/libwx_gtk2u_core-2.8.so.0)

bye


ps: now I use the first 2.2.5 package (amule-utils-gui_2.2.5-0ubuntu1~intrepid1_amd64.deb) from may 16 with the original-ubuntu package libwxgtk2.8-0. This works fine.
« Last Edit: June 07, 2009, 07:39:17 PM by habichauch »
Logged

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #27 on: June 21, 2009, 06:26:24 PM »

Ok, I recompiled all packages without wxwidgets 2.8.10.1.

Now all builds should works fine... or at least I hope.  :-\

Next maybe debug packages or konqueror ed2k links support.... :D

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Ubuntu packages
« Reply #28 on: June 22, 2009, 05:48:10 PM »

Added a little video tutorial...  ;D in Spanish...   :-[ (I hope you understand it anyway)

http://www.youtube.com/watch?v=WRqxlWVkQPY&fmt=22

It shows:
* process to install the PPA repository
* process to install aMule
* a little demo of ed2k links handling and emulecollection files usage
« Last Edit: June 23, 2009, 11:18:33 AM by Festor »
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Ubuntu packages
« Reply #29 on: June 22, 2009, 06:27:07 PM »

Well done! This makes everything even easier!

For a future video, you might want to increase the text size in the emule content db, because it's very hard to read. The rest is surprisingly well readable even on YouTube.
Logged
Pages: 1 [2] 3