aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2]

Author Topic: aMule Crashes  (Read 5818 times)

able

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: aMule Crashes
« Reply #15 on: April 07, 2011, 05:00:30 PM »

Code: [Select]
$ LD_LIBRARY_PATH=/home/able/Descargas/wxWidgets-install/lib ldd `which amule`
linux-gate.so.1 =>  (0x00499000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00bdb000)
libz.so.1 => /lib/libz.so.1 (0x006a4000)
libcrypto++.so.8 => /usr/lib/libcrypto++.so.8 (0x0070d000)
libupnp.so.3 => /usr/lib/libupnp.so.3 (0x00f90000)
libthreadutil.so.2 => /usr/lib/libthreadutil.so.2 (0x00110000)
libixml.so.2 => /usr/lib/libixml.so.2 (0x001fd000)
libwx_gtk2u_adv-2.8.so.0 => /home/able/Descargas/wxWidgets-install/lib/libwx_gtk2u_adv-2.8.so.0 (0x00118000)
libwx_gtk2u_core-2.8.so.0 => /home/able/Descargas/wxWidgets-install/lib/libwx_gtk2u_core-2.8.so.0 (0x00bf5000)
libwx_baseu_net-2.8.so.0 => /home/able/Descargas/wxWidgets-install/lib/libwx_baseu_net-2.8.so.0 (0x0053d000)
libwx_baseu-2.8.so.0 => /home/able/Descargas/wxWidgets-install/lib/libwx_baseu-2.8.so.0 (0x0020b000)
libGeoIP.so.1 => /usr/lib/libGeoIP.so.1 (0x003a4000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0056a000)
libm.so.6 => /lib/libm.so.6 (0x00b0e000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x001d3000)
libc.so.6 => /lib/libc.so.6 (0x00fc4000)
/lib/ld-linux.so.2 (0x00386000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x18002000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x003de000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x0035a000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x0385c000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x0049a000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00475000)
libpng12.so.0 => /lib/libpng12.so.0 (0x004c0000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x004e5000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00b34000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00655000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x006b9000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x001ef000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x001f3000)
librt.so.1 => /lib/librt.so.1 (0x00375000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x15188000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x001f8000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x0048e000)
libdl.so.2 => /lib/libdl.so.2 (0x0037e000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00527000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00685000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x0068f000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x006fc000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00afe000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00bab000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x0e0df000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00382000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00537000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x0069d000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0x0c90f000)
libpcre.so.3 => /lib/libpcre.so.3 (0x13c10000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00bb7000)
libselinux.so.1 => /lib/libselinux.so.1 (0x18efb000)
libexpat.so.1 => /lib/libexpat.so.1 (0x09d2d000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x1c0de000)
libuuid.so.1 => /lib/libuuid.so.1 (0x00704000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x11234000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x0a817000)
libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0x00709000)
libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x00bcb000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00b08000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00bd3000)

amule lo instalé del repo ubuntu 10.10
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5898
Re: aMule Crashes
« Reply #16 on: April 07, 2011, 08:13:35 PM »

Quote
(determinado por aMule en tiempo de compilación)

Oh. De hecho... si. Asi que en realidad, te podia haber funcionado todo este tiempo...
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5898
Re: aMule Crashes
« Reply #17 on: April 07, 2011, 08:14:18 PM »

Y segun lo que acabas de pegar, te esta funcionando con 2.8.12 ya.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule Crashes
« Reply #18 on: April 07, 2011, 09:03:39 PM »

Efectivamente:

Code: [Select]
ver += CFormat(wxT(" v%d.%d.%d")) % wxMAJOR_VERSION % wxMINOR_VERSION % wxRELEASE_NUMBER;
able, estás funcionando ya con wx 2.8.12. Si te peta cuentanos estaremos interesados.
Logged

able

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: aMule Crashes
« Reply #19 on: April 07, 2011, 11:22:13 PM »

Vale, si peta pego el dump. La duda que me queda es ¿por qué arranca así?
Code: [Select]
$ LD_LIBRARY_PATH=/home/able/Descargas/wxWidgets-install/lib amuleInitialising aMule 2.2.6 using wxGTK2 v2.8.11

¿Por qué indica todo el rato que es la versión 11?

E insisto, gracias por toda la ayuda y perdonad la brasa. Es que no lo acabo de entender
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5898
Re: aMule Crashes
« Reply #20 on: April 08, 2011, 02:24:29 AM »

Porque la funcion "wxVersionInfo wxGetLibraryVersionInfo()" no esta disponible con wx anteriores a 2.9.2.

Lo que te esta diciendo el aMule es la version de wxWidgets que se uso para compilar el aMule, no la que esta usando. No hay forma directa de mostar la que esta usando hasta que wxWidgets no saque las wxWidgets 3.0 y lo pongamos como requisito minimo.
Logged

able

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: aMule Crashes
« Reply #21 on: April 08, 2011, 09:06:20 AM »

Aaaah ya lo pillo. Muchísimas gracias por todas las explicaciones.

Voy a bajar la velocidad de la mula, a ver si reproduzco o no las condiciones por las que se ostia y, de ser así, os pongo un dump. Sin limitaciones de bajada no se la pega :)
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule Crashes
« Reply #22 on: April 08, 2011, 05:46:08 PM »

Aaaah ya lo pillo. Muchísimas gracias por todas las explicaciones.

Voy a bajar la velocidad de la mula, a ver si reproduzco o no las condiciones por las que se ostia y, de ser así, os pongo un dump. Sin limitaciones de bajada no se la pega :)
Ok able, ya nos cuentas. Ahora mismo si se tienen muchas fuentes aMule se queda un poco petao, lo mejor es parar algunas descargas de manera manual. De todas formas ahora tengo una buena conexión y estoy viendo algunos problemas de rendimiento, si los tienes comentalos que siempre será útil para arreglarlos. Hay también algún problema de rendimiento con el nuevo GUI que seguro que se soluciona antes de que salga la 2.3 definitiva.
Logged

able

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: aMule Crashes
« Reply #23 on: April 08, 2011, 11:11:18 PM »

He bajado el límite de velocidad de bajada, por si reproducía la incidencia, y zasca!

Si el límite es 0kb tira indefinidamente o casi. Si lo estableces, se acaba cayendo

backtrack
Code: [Select]
(amule:30117): GLib-WARNING **: /build/buildd/glib2.0-2.26.1/glib/giounix.c:411Error while getting flags for FD: Descriptor de fichero erróneo (9)


--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.6 using wxGTK2 v2.8.11
Running on: Linux 2.6.35-28-generic-pae i686

[2] ?? in amule[0x80800b9]
[3] wxFatalSignalHandler in /home/able/Descargas/wxWidgets-install/lib/libwx_baseu-2.8.so.0[0xa21096]
[4] ?? in [0xb17400]
[6] ?? in /home/able/Descargas/wxWidgets-install/lib/libwx_gtk2u_core-2.8.so.0[0xd45464]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0[0x627e62]
[7] ?? in /lib/libglib-2.0.so.0[0x7f3de9b]
[8] g_main_context_dispatch in /lib/libglib-2.0.so.0[0x7ef6855]
[9] ?? in /lib/libglib-2.0.so.0[0x7efa668]
[10] g_main_loop_run in /lib/libglib-2.0.so.0[0x7efaba7]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x6def1d9]
[12] wxEventLoop::Run() in /home/able/Descargas/wxWidgets-install/lib/libwx_gtk2u_core-2.8.so.0[0xd43ce8]
[13] wxAppBase::MainLoop() in /home/able/Descargas/wxWidgets-install/lib/libwx_gtk2u_core-2.8.so.0[0xdcbcce]
[14] wxAppBase::OnRun() in /home/able/Descargas/wxWidgets-install/lib/libwx_gtk2u_core-2.8.so.0[0xdcb8b1]
[15] wxEntry(int&, wchar_t**) in /home/able/Descargas/wxWidgets-install/lib/libwx_baseu-2.8.so.0[0x9b7ec3]
[16] wxEntry(int&, char**) in /home/able/Descargas/wxWidgets-install/lib/libwx_baseu-2.8.so.0[0x9b80a7]
[17] ?? in amule[0x815636b]
[18] __libc_start_main in /lib/libc.so.6[0xfc4ce7]
[19] ?? in amule[0x807f061]


--------------------------------------------------------------------------------
Abortado

Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5898
Re: aMule Crashes
« Reply #24 on: April 09, 2011, 12:00:22 AM »

Estas seguro de que lo ejecutaste con LD_LIBRARY_PATH ?
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule Crashes
« Reply #25 on: April 09, 2011, 01:19:30 AM »

¿Estas usando amule 2.2.6? Ese crash me suena que ya lo hemos visto y es otro diferente prueba a ver con la útlima versión de amule 2.3 rc.
Logged

able

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: aMule Crashes
« Reply #26 on: April 09, 2011, 11:48:13 AM »

a) si, lo ejecuté con LD_LIBRARY_PATH. Estoy siendo sistemático para que lo que os postee os pueda servir. De hecho, quité el límite de descarga, mantuve el límite de subida y no palma

b) alguna recomendación para instalar la v. 2.3rc y que no se fostie con la anterior? URL?

gracias, como siempre.

PS.: por cierto, sabéis si con ubuntu 11.04 la cosa va a ir bien? Ni por lo más remoto pido responsabilidades (faltaría más), sino que reflexionaba sobre lo que creo que es un hecho: la mula es un software importante para el switching a linux en muchos hogares. Haciendo memoria, diría que nunca ha estado tan inestable como en ubuntu 10.10. Creo que un cambio en el kernel empezó a provocar estos problemas, pero el hecho es que quien hizo el switching con 10.10 se encontraría con una mula poco funcional. Esperemos que ubuntu 11.04 deje de producir problemas
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: aMule Crashes
« Reply #27 on: April 10, 2011, 10:54:34 AM »

b) alguna recomendación para instalar la v. 2.3rc y que no se fostie con la anterior? URL?
En la web tienes el enlace de descarga. Simplemente tienes que usar un ./configure --with-wxdir y el directorio donde tengas wx 2.8.12 instalado.

Despues hace únicamente make, y puedes ejecutar el nuevo amule con el LD_LIBRARY_PATH apuntando a las nuevas libs y el amule lo tienes en src/amule.
Quote
PS.: por cierto, sabéis si con ubuntu 11.04 la cosa va a ir bien? Ni por lo más remoto pido responsabilidades (faltaría más), sino que reflexionaba sobre lo que creo que es un hecho: la mula es un software importante para el switching a linux en muchos hogares. Haciendo memoria, diría que nunca ha estado tan inestable como en ubuntu 10.10. Creo que un cambio en el kernel empezó a provocar estos problemas, pero el hecho es que quien hizo el switching con 10.10 se encontraría con una mula poco funcional. Esperemos que ubuntu 11.04 deje de producir problemas
No sé que decir, yo creo que el problema está en aMule, pero podría haber algún bug en Ubuntu sin duda. Seguro que el 11.04 va bien. También parece que los problemas tienen que ver con que cada vez la gente tiene más velocidad en sus casas.
Logged
Pages: 1 [2]