aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Conflit Glib  (Read 3598 times)

Strider

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Conflit Glib
« on: May 13, 2005, 10:01:03 AM »

Bonjour

Comme il n'y a pas de RPM pour Mandrake 10, j'ai voulu recompiler aMule depuis ses sources. Il faut donc que j'installe GTK+, Glib, Pango et compagnie.
J'ai donc récupéré et compilé Glib 2.6.4. Mais quand je m'attaque à la compilation de Pango, j'ai ce message :
*** 'pkg-config --modversion glib-2.0' returned 2.6.4, but GLIB (2.5.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. (...)
Comment virer l'ancienne version de Glib et "faire reconnaitre" au système la 2.6.4 ?

Merci d'avance.
Logged

gnuk

  • Guest
quelle version exactement ?
« Reply #1 on: May 13, 2005, 11:39:29 AM »

Quelle version de mdk ? la 10.0, la 10.1 ou la 10.2 (alias 2005) ?
Quelle version de aMule ? la 2.0rc8 ou la 2.0 ?

Je viens de regarder rapidement les mirroirs de plf, et les paquets existe :
[list=1]
  • mdk 10.0 > aMule 2.0rc8
  • mdk 10.1 > aMule 2.0rc8
  • mdk 10.2 > aMule 2.0
  • [/list=1]
    Si ce n'est pas déjà fait, ajoute les sources de paquets de plf via easy urpmi et installe les paquets via urpmi, sinon tu va t'amuser à maintenir glib, ce qui n'est pas une mince affaire.
Logged

Strider

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
RE: quelle version exactement ?
« Reply #2 on: May 13, 2005, 01:40:25 PM »

Merci je vais essayer avec urpmi.
Pour info j'ai Mdk 10.0 et je voudrais installer aMule 2.0.
Logged

Strider

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Mandriva
« Reply #3 on: May 18, 2005, 02:15:46 PM »

Ca ne marche pas... mais j'ai récupéré les RPM pour la version Mandriva et ça m'a l'air de fonctionner avec la Mandrake 10.0  :))
Logged